Windows 10: Cannot boot into windows after updating RaidXpert2 Drivers Solved

  1.    16 Jan 2018 #1

    Cannot boot into windows after updating RaidXpert2 Drivers


    Edit: I gave up trying to fix the issue and reverted to a backup of my PC from last month.

    Sorry in advance but this will be a long post to detail my issue.

    Background: Yesterday I updated from AMD's 17.11.1 graphics driver to 17.12.1 and immediately started experiencing freezes in a game called Halo Online. The previous driver did not have this issue, so I decided to revert back to 17.11.1. While I was looking for the driver I stumbled upon an update for RaidXpert 2, version 17.4 which is newer than my current version so I decided to download that as well. I then downloading DDU (Direct Driver Uninstaller) and wiped my PC clean of AMD graphics drivers. I rebooted back into windows and installed the newer RAID driver (17.4) and then tried to restart again. I haven't been able to boot into windows since (so I have not yet had the chance to install 17.11.1 graphics driver).

    My PC is set up with my OS on a MydigitalSSD BPX 256GB M.2 drive, and two Seagate HDD's in raid 1 for storage. My entire PC (all drives) are encrypted with Bitlocker and I have it set up so that I enter one bitlocker key for the OS drive and then the rest unlock automatically in windows.

    When I boot up I am asked for my bitlocker key as usual, after it is accepted my computer crashes and restarts again. When I do this twice in a row automatic system repair comes up the second time. I have tried a variety of different things here including:

    1. Startup repair (after running for 10 seconds says the issue cannot be fixed).
    2. Checking for the system restore point that was created by DDU. For some reason it doesn't exist, as if it was never made?
    3. Booting into safe mode (fails like a regular boot).

    I was considering running CMD prompt and SFC/scannow to see if it helps. I'm honestly completely at loss as to what went wrong here. All I did was install an update for my RaidXpert 2 driver and suddenly my PC won't boot?

    I also tried entering the AMD RAID Bios (first screen that comes up at boot before bitlocker) and everything there was perfectly fine as it was before.

    So what happened to my OS drive? Did it fail or something?

    Any help is greatly appreciated. I have the option of reverting to my monthly backup created by Macrium Reflect if needed but haven't given up hope yet.
    Last edited by Ocman76; 17 Jan 2018 at 20:21.
      My ComputerSystem Spec


 

Related Threads
A discussion about updating drivers in Drivers and Hardware
I want to initiate a serious talk about updating drivers on Windows 10. Some of you use tools for updating, some of you don't recommend tools. Some of you recommend the WU version of the drivers, some of you recommend the OEM drivers and some of you...
Solved Updating Drivers in Drivers and Hardware
Do I need to "update" drivers? I see "partners" of windows saying I have 15 out dated drivers that need updating and I should install their software..or whatever it is..to update. Obviously I'm a newby at all this. Should I? And if not..is there...
One of the most unpopular features of Windows 10 seems to be auto updating of drivers. I've read quite a few horror stories about Windows 10 installing unwanted GPU drivers and causing issues. I am very much of the mantra "If it ain't broke...
This might be a dumb question, but can you install Windows 10 drivers onto a Windows 7 system? I upgraded to windows 10 not to long ago, and suffered a sleuth of problems that led me to reverting back to Windows 7. I've concluded out-dated drivers...
That's what I want to know, have they fixed it so you can say no, I don't want to update my hardware drivers! Every time it does my sound quits working. Mike
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:33.
Find Us