Windows 10: Printer Has Me Flummoxed Solved

  1.    05 Jan 2018 #1

    Printer Has Me Flummoxed


    I have a wireless home network consisting of, among other things, a desktop (Windows 10), and two laptops (Windows 10), and a network printer (Canon TS9020).

    Until a week ago, everything worked flawlessly. Last week, I discovered my Dell XPS13 no longer works with my printer. When I try to print I get "Collecting Printer Status" followed by "Printer Not Responding." The desktop and the other laptop continue to work well.

    I've done all the usual stuff. Rebooted the router, deleted/reinstalled the printer multiple times, etc. Win10 shows the printer on-line and available, but it will not communicate with the Dell.

    I'm completely stumped. Any suggestions?
      My ComputerSystem Spec

  2.    05 Jan 2018 #2

    Go to Devices and Printers. If your Canon Printer is here, right click it and Delete it. If the printer is plugged into the computer with a USB cable, remove the USB cable from the computer end. Press the Win key+X and choose Apps and Features. Uninstall any Canon software, and restart the computer. When the computer comes back up, go to the Canon Drivers Web Site for your model. Download the Full driver package and software. When installing it will ask if you want to connect the computer via Wireless or USB. If connecting Wireless it will search for the printer and add it.
      My ComputerSystem Spec


  3. Posts : 1,890
    Win 10 X64 Pro 1803 17751.1
       05 Jan 2018 #3

    Have you power cycled the printer yet? (If it has no power switch, like one of my printers, simply unplug it, wait 10 seconds, and plug it back in again.)

    I suppose that you've tried that already, but you didn't explicitly say so.
      My ComputersSystem Spec

  4.    06 Jan 2018 #4

    I tried the power cycle a couple of times to no effect. I'm going to follow spunk's suggestion as soon as Canon Support site is back on line. Thanks for your response.
      My ComputerSystem Spec

  5.    06 Jan 2018 #5

    I uninstalled/reinstalled again following spunk's suggestion. As usual, the software installs flawlessly until I get to the "Print Test Page/Execute" process. It tries to print "Collecting Printer Status" followed by the "Printer Not Responding." The printer screen shows "Processing . . . Please wait momentarily." That will continue for a few more minutes, then it will return to its home state.
      My ComputerSystem Spec

  6.    06 Jan 2018 #6

    After communicating with Canon Tech Support I disabled the IPV6 settings on the printer, turned off and unplugged the printer, shut down the router, turned off all three computers. After a few minutes I plugged the printer back in, turned it on, restarted the router, turned all computers back on, resulting in the same problem. I again uninstalled the printer, uninstalled the software, and reinstalled using Windows 10 Settings. This time, lo and behold!, it works. I had tried that approach previously without results. I don't know if disabling the IPV6 setting played a part, or whether the computer gods were tired of jerking me around.
      My ComputerSystem Spec


 

Related Threads
Hello, New to forum.......I am having issues with wireless printing. Had to replace wireless router, now computer will not maintain connection to printer. I want to configure port to a static IP, but it will not allow access. I am set as...
I have two printers, one of which is an Epson Artisan 1430 (very new, installed with current drivers and current firmware) and one of which is a Canon iP6000D (very old, with old, unsupported drivers), and both of them frequently will not actually...
Hi Guys, I'm getting quite frustrated with this issue and wondering if anyone has seen it, and able to resolve the issue. The issue is I have a network printer selected as the default in Windows 10. I have the option "Let Windows manage my...
Hi to all. I am having an annoing problem with shared printers. The user that share a printer lose the default printer in any case when another user print on this shared and it turn immediatly default printer only for the user that share the...
Hi, I work in IT doing Help Desk/Support for a company. We want to give standard users restricted assess to a printer. If they are a manager they can print in colour, but if they are just a standard staff member they only get the option to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:30.
Find Us