Both of these began exactly concurrent with the latest major update.

I'm using a (genuine) Microsoft IntelliMouse Optical. The mouse cursor is unresponsive at bootup, but if I disconnect and reconnect it, it works fine. The mouse buttons still work initially (I can successfully left- or right-click whatever the cursor happens to be on), but the cursor itself initially won't move. Not a deadly problem, just irritating to dig through the cables twice a day. Tried a different port; no change. Tried the mouse on a different PC, no problems. Device Manager says driver is up to date, and hey, it's MS's own product after all.

Second, and conceivably related: the Task Switcher shortcut (ALT+TAB) no longer works. Unlike the mouse, this doesn't resolve if I disconnect & reconnect the keyboard. And testing with a different keyboard gives the same issue, so clearly it's not mechanical. To be clear: I'm not talking about the new multiple virtual desktop feature, just switching between program windows.

Any ideas how to fix one or both of these? I know keyboard and mouse issues are common after an update, but this is the first time I've actually had it happen so I'm unacquainted with the usual remedies. The mouse issue I could live with; the other will drive me to drink.

Thanks in advance for any clues.

Mark