USB HD turns into a local disk and then is ok - why?


  1. Posts : 136
    Win 10
       #1

    USB HD turns into a local disk and then is ok - why?


    I've plugged in my 4T USB backup HD into the same USB 3.0 slot for about a
    year with no issues. Yesterday I plugged in another 2T USB HD into the same slot and then plugged in my backup HD into the 3.0 slot right next to it. Which means they are sharing the same USB port.


    All of a sudden I found out my backup HD became an unidentified 'local disk" according to Windows Explorer. It looked blank and the properties showed 0 data. I then unplugged both USB HD's and plugged in only my 4T USB backup HD and it was then fine. It wasn't a local disk anymore.

    In the past I have had a quirky 1T HD that sometimes would turn into a local disk and I'd reformat it and load it back up with some double backuped files. About a month ago I removed it from my computer, since it seemed unstable and since it was only filled with double backed up image files. I can always access it if needed. So that's the only other instance I've run into with a good HD suddenly turning into a local disk.

    If anyone has a clue why this happened and what should I do to prevent this from happening? Does this mean my 4T backup is unstable? Or is this a Win 10 quirk? Or should I avoid plugging 2 USB HD's into a shared port? If this happens again and it is stuck as a local disk, how can I fix that without losing all my data? My computer is a dedicated audio recording computer so I purposely have Win Updates off and last updated last April.
      My Computer


  2. Posts : 3,682
    Windows 11 Pro 64 Bit 21H2
       #2

    No need to post the same thread more then once, you are being helped here USB HD turns into a local disk and then is ok - why? - Windows 10 Forums
      My Computer


  3. Posts : 136
    Win 10
    Thread Starter
       #3

    spunk said:
    No need to post the same thread more then once, you are being helped here USB HD turns into a local disk and then is ok - why? - Windows 10 Forums
    I posted in the General forum after not getting a response and someone moved this 2nd thread here. Since there's no response to this thread I was hoping it would be removed by the moderator. Sorry for any inconvenience and thanks for the response on the other thread
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:57.
Find Us




Windows 10 Forums