Page 1 of 5 123 ... LastLast
  1.    30 Jul 2015 #1
    Join Date : Jul 2015
    Posts : 16
    Windows 10

    Intel RST RAID driver in Windows 10 causing disk errors!


    Hi,

    I have a PC with Asus P9X79 Deluxe motherboard. It has Intel chipset and Intel BIOS RAID (RSTe) and 6 SATA ports connected to it. The chipset IDE controller lists in Linux as:

    Intel Corporation C600/X79 series chipset SATA RAID Controller (rev 06),
    and the PCI ID is:
    0104: 8086:2826 (rev 06).

    My RAID configuration is 2xOCZ-VERTEX4 256GB SSD's in RAID0, as boot drive (C: drive), and 2 (quite old) WDC WD2500KS 250GB disks in RAID0 for extra storage (games, movies etc) (J: drive).

    So yesterday I decided to upgrade my Windows 7 Ultimate to Windows 10 Pro. All seemingly went well during the upgrade process, and the system booted fine, and most stuff seemed to work as it should. But after a while when I accessed files on the J: drive I started experiencing random (temporary) freezes.

    Then after a while it got more serious and the whole system froze, I had to hit the reset button.

    So I rebooted and looked in the event log, I get see tons of errors there saying that the disk has a bad sector.

    Then I try using the J-drive again, by viewing some videos there, and it works fine, but after a while there are some freezes and then I see in the event log, that the drive was reset. After this it works again for a while but then another of those resets comes, and freezes everything for a short while (like 30 seconds).

    But when I try to copy some large files off the J-drive, another reset comes, and then the event log starts showing a lot of the error messages from before, with "the disk has an bad sector". (I will post screenshots of these errors after I reboot back into Windows).

    After this I can't access the J-drive at all, and Windows gives me error messages when I try to.

    So, I figure that I might have just got unlucky and the old WDC drive actually developed read errors, although it's strange that it happens exactly when I install Windows 10 (these drives are something like 7 years old).

    Well I can't copy the contents off the disk from Windows since it keeps failing as described above, so I boot into Ubuntu Linux from a USB stick, so I can use ntfsclone to image the J-drive to another disk. I start it running expecting that I'll start seeing read errors, but to my surprise there are NONE. It also copies all files off the J-drive without any problems from inside Linux!

    So it was after all not the old drive that had failed, but instead Windows 10/Intel had failed me in a big way.

    I trawled the web for updated Intel chipset drivers and installed those from the Asus site, but it made no difference at all. I couldn't find any other Intel drivers and when I searched for the RST drivers on Intel's own site, I could only find ones for Windows XP upto Windows 8.1, but none for Windows 10.

    For now I'm left with a PC that I can't use, because I can't go back to Windows 7 and Windows 10 is not working with my RAID arrays. I got some spare 2TB disks, and I'm right now copying all the data from the old J-drive (the RAID1 about 500GB) over to this, hopefully I can then work in Win 10, but I am VERY concerned because the same RAID and drivers are used for my master boot drive with the two OCZ SSD's.

    I can't believe my setup is so rare, that they haven't tested this, and that it's failing in such an abysmal way, easily causing data corruption. Well I guess I made a mistake when I thought Windows 10 was ready for prime time, now I am paying the price. Thanks MS and Intel!

    Any suggestions to what I can do to fix this? I doubt there is an easy fix and I just wanted to put this out here so that ohters can be warned.

    Cheers,
    Thomas
      My ComputerSystem Spec
  2.    30 Jul 2015 #2
    Join Date : May 2015
    Posts : 1,624
    Win 10 X64 Pro 15063

    These may be the latest IRST drivers:

    Intel Download Center

    (You may ignore the "NUC".)

    I believe that these are the same version as Asrock serves up for Windows 10 X64 for my X99 board. You could also download them from Asrock:

    ASRock > X99 OC Formula

    Good luck.

    I have no personal experience with these drivers. I gave up on motherboard RAID a few years ago, after an annoying experience with a RAID 10 array (4 X 500 GB).
      My ComputerSystem Spec
  3.    30 Jul 2015 #3
    Join Date : Jul 2015
    Posts : 16
    Windows 10
    Thread Starter

    Thanks, but I already tried those - it just gave "Platform not supported" when I tried to install them.

    Edit: I'll try the ASRock ones after I reboot (at least I now have a full backup).
      My ComputerSystem Spec
  4.    30 Jul 2015 #4
    Join Date : May 2015
    Posts : 1,624
    Win 10 X64 Pro 15063

    Quote Originally Posted by thomash View Post
    Thanks, but I already tried those - it just gave "Platform not supported" when I tried to install them.

    Edit: I'll try the ASRock ones after I reboot (at least I now have a full backup).
    That's unexpected. The drivers are supposed to support the 7 series chipsets.
      My ComputerSystem Spec
  5.    30 Jul 2015 #5
    Join Date : Jul 2015
    Posts : 16
    Windows 10
    Thread Starter

    Quote Originally Posted by bobkn View Post
    That's unexpected. The drivers are supposed to support the 7 series chipsets.
    It did generate a log file when I tried installing it but I couldn't make sense of it - if it's any use I can try pasting it after I reboot back into Win 10.
      My ComputerSystem Spec
  6.    30 Jul 2015 #6
    Join Date : Jul 2015
    Posts : 16
    Windows 10
    Thread Starter

    Ok, the ASRock driver is identical to the Intel one as far as I can tell, here's what it says:

    Click image for larger version. 

Name:	screenshot.png 
Views:	2535 
Size:	43.6 KB 
ID:	26868
    I pasted the contents of the logfile at http://pastebin.ca/3081904.

    As promised earlier here's a screenshot of the error messages. The first one, "iaStorAV" is the one that makes the UI freeze for a bit, and then if you do more intensive disk IO, the second error starts appearing, and literally thousands and thousands of those come in the log, and after that starts happening you can't access the array any more before a reboot.

    Click image for larger version. 

Name:	firsterror.png 
Views:	33 
Size:	242.1 KB 
ID:	26871

    Click image for larger version. 

Name:	nexterrors.png 
Views:	19 
Size:	261.5 KB 
ID:	26872
      My ComputerSystem Spec
  7.    30 Jul 2015 #7
    Join Date : Dec 2014
    Posts : 409
    Windows 10 Pro x64

    Any rst drivers after 14.0.x ( I forget the exact x) will cause system hangs and corrupted disk on a lot of chipsets when the disks are raided. Non raided disks work fine. When I get a cchance later, I will post more details.

    Ps. They also do this in Windows 7.
      My ComputerSystem Spec
  8.    30 Jul 2015 #8
    Join Date : Jul 2015
    Posts : 16
    Windows 10
    Thread Starter

    Well my driver isn't after 14.x, as seen on the screenshot below - I wonder if there really isn't a better driver?

    Also my BIOS has ability to set the Intel RAID mode to either IRST or RSTe, it's on RSTe now which worked in Windows 7, and it says in the BIOS that if you change this you need to reinstall the OS - is it worth trying this anyway and see what happens?

    Click image for larger version. 

Name:	driver.png 
Views:	38 
Size:	175.0 KB 
ID:	26875
      My ComputerSystem Spec
  9.    30 Jul 2015 #9
    Join Date : Jul 2015
    Posts : 16
    Windows 10
    Thread Starter

    In fact changing modes in BIOS from RSTe to IRST did make a difference, and I didn't need to reinstall the OS as the BIOS warned.

    Now it changed the device name from "Intel(R) C600 Series Chipset SATA RAID Controller" to "Intel Chipset SATA RAID Controller", and I was able to install the drivers that @bobbkn linked in #2.

    The sad part is, that it didn't solve the problem. I still get "Reset to device, \Device\RaidPort2, was issued." errors in the event viewer and I can't access the files on the J drive. If anything, the PC got slower from making this change.

    I guess, at least now I have the chance to try with a few different driver versions but I'm not super hopeful at this point.
      My ComputerSystem Spec
  10.    30 Jul 2015 #10
    Join Date : Jul 2015
    Posts : 16
    Windows 10
    Thread Starter

    Well, I guess it's solved FOR ME, FOR RIGHT NOW, but this whole ordeal has left me with a very bad feeling about Windows 10 and especially the Intel RAID drivers.

    What I did was I bought two 2TB disks, and created a new Intel RAID0 on those. Then using Linux, I used ntfsclone to first clone an image of the old RAID0 drive across to a spare disk (seeing as the old disks work just fine in Linux), and then I cloned that back to a new partition (now 1TB instead of 500GB) on the new RAID.

    So finally I took out the old two disks, and booted Windows 10 with the new array.

    It's beyond me why it doesn't work with the older disks, but works fine with the new Seagate 2TB disks. And it makes me very worried that the underlying issue is something to do with some timing critical bug, and might come back and bite me.

    Still, I'm now able to use my computer, seemingly without any problems, and I've "retired" the old disks as backup drives (plan to boot back into Linux and image+compress all the NTFS partitions on to there, so I have a full system backup).
      My ComputerSystem Spec

 
Page 1 of 5 123 ... LastLast


Similar Threads
Thread Forum
New Intel HD Graphics 4600 Driver Update in WU
Well! That was a jarring experience! Just got a update via WU for Intel HD Graphics 4600. During install, it went absolutely bonkers on the display. Kaleidoscope wacky! Just let it be for a minute or so to finish install, then power button...
Graphic Cards
Solved Intel HD Graphics driver not able to install
I upgraded both my desktop and laptop to Windows 10 recently. The desktop's upgrade went smoothly; NVIDIA already has Windows 10-compatible drivers. However, my laptop with Intel HD Graphics is a different story. I've tried the Dell-certified...
Graphic Cards
Intel GMA Driver Crashing on Atom Z2760-based HP Envy x2
I have a 2 year old HP Envy x2 hybrid touchscreen laptop with the z2760 (Clover Trail) chip set and GMA graphics. When I installed Windows 10 for the first time it failed to recognize the graphics chip and installed the Microsoft Basic VGA Adapter...
Drivers and Hardware
Intel(R) HD Graphics 4000 Driver Never Updates
I get this error: Intel Corporation driver update for Intel(R) HD Graphics 4000 - Error 0x80070103 It's done this with the past three builds too (using 10074). Thanks for any help.
Graphic Cards
Copying hard disk driver from Windows 10 to Windows 7?
My laptop will boot both Windows 10 and Windows 7 from a Crucial SSD. Can I use the Windows 10 hard disk drivers with Windows 7? If so how would I set about installing them? I have a USB stick with Windows 10 build 10049. At the moment...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:56.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums