1.    14 Jan 2017 #1
    Join Date : Jan 2016
    Earth - mostly Chicago and London
    Posts : 114
    Windows 10 Edu

    How can I change mouse pointer schemes from the command line?


    The default mouse pointer scheme is just to darn small in Windows 10, at least on my Dell Inspiron. So I change it via the control panel, but some games won't work when the scheme is changed, so I'd like to be able to switch back and forth from the command line and create a script for switching and running games.
      My ComputerSystem Spec
  2.    14 Jan 2017 #2
    Join Date : Oct 2013
    Posts : 25,272
    64-bit Windows 10 Pro build 17046

    Hello SOHO1,

    OPTION TWO in the tutorial below may be able to help some for this.

    https://www.tenforums.com/tutorials/...a.html#option2
      My ComputersSystem Spec
  3.    14 Jan 2017 #3
    Join Date : Jan 2016
    Earth - mostly Chicago and London
    Posts : 114
    Windows 10 Edu
    Thread Starter

    Brilliant! Cheers!

    I wonder what i searched for that didn't show that as a search result. Ah well, never said my brain worked like others, or even that it works at all.

    OK, I have my reg files for each mode that I want to run and of course I can run regedit from the command line to install them.

    However, the changes do not seem to go info effect. A bit of research suggests that I need a tool to disable and re-enable the mouse device. Such a tool, called DEVCON, is part of the Windows SDK. Looking for that and downloading next to try out.
    Last edited by SOHO1; 14 Jan 2017 at 13:25.
      My ComputerSystem Spec
  4.    14 Jan 2017 #4
    Join Date : Oct 2013
    Posts : 25,272
    64-bit Windows 10 Pro build 17046

    Other than something like that, you could sign out/in or restart to apply.
      My ComputersSystem Spec
  5.    14 Jan 2017 #5
    Join Date : Jan 2016
    Earth - mostly Chicago and London
    Posts : 114
    Windows 10 Edu
    Thread Starter

    Yes, but in addition to rarely signing out, I rarely reboot, at least as rarely as possible, and windows 10, unlike 7, has taught me great fear of rebooting (see also: various posts about boot problems, many of which seem to have been solved by this thing I found called TWEAK.com). Besides all that, it's a machine, I should be able to push a button (or enter command) and just have it do things. I guess I'm willing to endure the pain of setup once now so that I don't have to bear it 1000 times over the next year.

    PS
    Found the WDK at

    So...
    That link downloads a thing to download the WDK in which you can find the devcon tool when you are done in:
    • C:\ProgramFiles (x86)\Windows Kits\10\Tools\x64

    BUT...
    whilst true that it restarts or disables/enables devices, Windows does NOT apply the current mouse profile (if changed via the registry.)

    There is something the Control > Mouse program does that is more than all this.
    Last edited by SOHO1; 14 Jan 2017 at 15:01.
      My ComputerSystem Spec
  6.    14 Jan 2017 #6
    Join Date : Jan 2016
    Earth - mostly Chicago and London
    Posts : 114
    Windows 10 Edu
    Thread Starter

    Guess I'll just reboot or better yet, invoke the command.exe from the script each time.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
change or override default 32x32 mouse pointer size limit
I am visually impaired and am looking for a way to change or override the default 32x32 mouse pointer size limit either through Registry settings, Group Policy or through a setting in God Mode. Is there anyone who can help? I know there is some way...
Customization
How to connect/disconnect to a VPN using the command line?
Hi all I have several network connections configured. There is one wifi connection which automatically connects to my WLAN, another cable based LAN connection to a NAS which is used for backups and some L2TP connection connections (used...
Network and Sharing
Change User Language by command line
Hi, I have a Win10 Enterprise version. I have set 3 Languages under the Setting -> Language. I can manually switch between the 3 languages under the Language setting page (by the set as primary language, then perform a sign out and sign in with...
General Support
No mouse pointer after startup until i move the mouse
When windows starts up there is no mouse pointer, and will stay hidden until i move my mouse. This was the case without the logitech drivers; with the drivers installed but not running and with the drivers installed and running. So i doubt this is...
Drivers and Hardware
Solved Can't add user via command line
I am trying to add a user via the command line through a virtual pc I added with VMWare. I'm running windows 10, and unable to add because this is what I get when I open CMD: I can't go beyond this point, I keep getting error messages. Any help...
User Accounts and Family Safety
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:47.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums