Windows 10: Installing other OS fonts in Windows 10 Solved

  1. spapakons's Avatar
    Posts : 2,479
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
       26 Feb 2016 #1

    Installing other OS fonts in Windows 10


    Sorry if this is the wrong place, please move the thread as appropriate.

    I tried to install some fonts copied from an Ubuntu installation to a Windows 10 computer. I had all the fonts to a folder, selected them all, and then copy to C:\Windows\Fonts. It asked me to replace existing fonts, selected NO and check the box to do it for all fonts. I then saw the missing symbols symptom, where for example in IE 11 or Edge you see squares in place of the scrolling arrows. No matter what you do, there is no way to fix it within Windows 10 (or is there?) You have to boot from a live CD, go to C:\Windows\Fonts folder, delete all "Segoe---.ttf" files (maybe the symbol as well) and then copy them back from a working Windows 10 installation of from Windows 10 DVD. So beware, avoid copying fonts from Linux that are already present in your Windows 10 installation. If you see the C:\Windows\fonts folder from command prompt, all duplicates are shown by the original renamed to ..._0.ttf and the "new" version having the original name with small case.
      My ComputerSystem Spec

  2. Hopachi's Avatar
    Posts : 927
    Windows 10 Pro 64-bit
       27 Feb 2016 #2

    Are you trying to replace Segoe-defaults or just install extra fonts?
    Right-click install on the new fonts should place them in c:\windows\fonts
      My ComputersSystem Spec

  3. spapakons's Avatar
    Posts : 2,479
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
    Thread Starter
       27 Feb 2016 #3

    I didn't right-click to install them. I copy-paste into C:\Windows\Fonts which is essentially the same. When asked to replace existing fonts, I replied NO but they were messed nevertheless...
      My ComputerSystem Spec

  4. spapakons's Avatar
    Posts : 2,479
    Windows 10 Pro 64-bit 1803 (April 2018 build 17134.48)
    Thread Starter
       27 Feb 2016 #4

    How to fix it:

    Well I removed the hard disk from the notebook and connected it via SATA to USB adaptor to my main computer. I then had to take ownership of all the seg*.ttf files, and to be on the safe side, the sym*.ttf files. From Windows Explorer I would have to take ownership one-by-one. The quickest way was to launch an Command Prompt as Admin and then issue these commands:

    cd windows\fonts
    takeown /S SOTIRIS /U SOTIRIS/Administrators /F seg*.ttf
    takeown /S SOTIRIS /U SOTIRIS/Administrators /F sym*.ttf
    where J was the letter assigned to the hard disk and SOTIRIS is the computer (system) name.

    Unfortunately I didn't know of a quick way to add modify permissions, so I had to open the fonts folder in Windows Explorer, search for seg*.ttf and modify permissions from right-click -> Properties -> Security -> Edit and make sure Administrators have all permissions set. This had to be done one-by-one file, and then delete the results. I then had to search for sym*.ttf and repeat the procedure. After deleting all the relevant fonts, I had to copy them back from my main computer working installation, so I issued this command in the elevated command prompt:

    copy C:\Windows\Fonts\seg*.ttf J:\Windows\Fonts
    copy C:\Windows\Fonts\sym*.ttf J:\Windows\Fonts
    Then I put the disk back into the notebook and booted into Windows 10. I launched IE 11 and navigated to MSN. Sure enough it worked!

    Because of all this trouble involved to fix it, I recommend to avoid installing Linux (or any other OS) fonts in Windows.

    I'll mark it as solved, but if anyone knows of an easier way to fix it or how to install Linux fonts in Windows 10 without the missing symbols symptoms, I would like to read about it. Thank you in advance!
      My ComputerSystem Spec


Related Threads
Can anyone help me with advice on installing fonts I have downloaded on windows 10. I have read other people have a similar problem but haven't seen an answer that helps me. The "File" drop down box in Fonts is supposed to have "install new font"...
I would like to change default system fonts that are used in applications, file managers, shell menus, windows titles, but I can not find the option to do so. I am comming from the Linux Mint where you have option "fonts" in control panel and there...
With Windows 7 it was possible to change the fonts used by Windows for title bar, menus, popups, etc... This way I could get rid of "anti-aliased" fonts such as Segoe UI that are blurry and use "aliased" fonts such as Tahoma that are sharper and...
Changing all windows fonts in Customization
Hi there, I want to change the font on my PC. I am able to change icon fonts and windows fonts by methods I found on here, but I can not change all fonts including the fonts used on the lock screen and those used on the start menu. How can I...
General Tips Install Fonts in Windows 10 in Tutorials
How to Install Fonts in Windows 10 This tutorial is designed to show you how to install additional fonts in Windows 10. Starting with Windows 10 build 17704, you no longer need to be an administrator to install fonts. When you...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:39.
Find Us