"File or Folder is Open in Another Program" workflow disruption


  1. Posts : 7
    Windows 10
       #1

    "File or Folder is Open in Another Program" workflow disruption


    I'm looking for a quick solution to "action can't be completed because file or folder is open in another program".
    I'm looking for a method that doesn't interrupt workflow...I'd like to keep all my apps/windows and folders open..
    and just target that one file or folder...

    -I tried "unlocker" but it couldn't identify the process but offered to delete it on reboot which I don't like.
    -Long ago (many years) I seem to remember adding "take ownership" to context menu fixed it... it might have been windows 7 or 8.1 I'm not exactly sure when it stopped working...but a few years ago I noticed it stopped working for editing files even though the context menu button was added...I'm wondering if I have an outdated file, as I'm using windows 10 now...

    -Any other advice welcome...

    *I get this error often with apps that use multiple tabs, or just recently I compressed a folder,
    tried to delete the original and it wouldn't delete...I literally have a paper in front of me full of files/folders that need
    to be edited next time I reboot, or restart explorer...

    (Windows 10 OS Build 19041.388)
      My Computer

  2. dalchina's Avatar
    Posts : 31,260
    Win 10 Pro (1903)
       #2

    I don't often encounter this- perhaps you have multiple things simultaneously processing or handling the same files as a result what you are doing. Might be better to find the underlying cause or associated program rather than adopting a sledgehammer approach if this is frequent.

    Tools:
    Lockhunter
    Emco Unlockit

    - both add context menu entries to both files and folders.
      My Computers


  3. Posts : 7
    Windows 10
    Thread Starter
       #3

    The thing is...I don't think the file is really "locked" in that sense...
    Like I notice that certain apps, will create a ".Lock" file while open that disappears when closed.
    This situation doesn't do that. Would "LockHunter" work if "Unlocker" didn't?
    It seems like unlocking apps are more targeted at defeating .lock files...

    Not clearing a file of it's memory associations.

    I'm really not sure how to identify the problem....
    It happens mostly with Adobe CS6 software,
    Basically what I do all day is organize folders containing adobe projects (.PSD AI.)
    I'll often open 5 projects, merge content into one file, and then I need to delete
    the others..and move the merged file...but it won't let me...

    so what I wind up doing is merging everything first (sometimes 70 in a day), restarting windows,
    then going back and locating all 70 folders to do the moving/deleting/renaming....
    It's an extra 70 steps a day.. as I was already in that folder when it told me it couldn't move it.

    Could it be because I'm copying and pasting from one file to another that the info is still loaded in clipboard?
    Can I set each Photoshop tab to run in a separate process? hmmm
      My Computer

  4. dalchina's Avatar
    Posts : 31,260
    Win 10 Pro (1903)
       #4

    Thank you for your reply.

    It doesn't seem as if you're willing to try to identify the process locking the file, thinking that it's locked in some other way.

    Sorry, can't help further beyond suggesting more technical tools.
    How to Identify which Windows Process is Locking a File or Folder – GSX Help Center

    I searched for
    show process locking file

    You may find other helpful results.

    Good luck.
      My Computers

  5. Ghot's Avatar
    Posts : 10,803
    Win 10 Home 10.0.19043.1055 (x64) [21H1]
       #5

    RedQueen said:
    I seem to remember adding "take ownership" to context menu fixed it... it might have been windows 7 or 8.1 I'm not exactly sure when it stopped working...
    WinAero Tweaker will add a "take Ownership" entry to the context menu in Windows 10.

    https://winaero.com/comment.php?comment.news.1836
      My Computer


  6. Posts : 7
    Windows 10
    Thread Starter
       #6

    It's not that I'm unwilling,
    I just have no idea where to start...
    It happens with Task Manager showing no Apps running,
    There are billions of background processes running,
    It could be an issue with Photoshop, It could be an issue with file explorer...
    My file explorer is heavily customized with SageThumbs to show PSD thumbnails..
    The thumbnail might still be loaded in memory...

    I wish windows would name the friggen process that is holding it up,
    Instead of just saying something is using it but what we won't tell you what...
    Unlocker could not identify the process either...I will look into the tools you mentioned...

    I have no problem adding "Take Ownership" to the context menu...
    What I'm saying is it no longer unlocks the file...you click it...a terminal I think (Black window/white text) pops up,
    exactly like before, but when I go to delete, or change...nothing has changed...it doesn't work basically...
    I'm not even sure why it used to work...why would it be an ownership issue?

    I'm wondering if one thing I can try is launching explorer folders in seperate process...
    so maybe I can restart that folder without having to re-open the others,
    I've never tried it before so I'm not sure..

    Back to the clipboard theory, I noticed that in some programs,
    if you copy something, then delete it, then try to paste...it gives you an error,
    saying it no longer exists...this tells me in certain situations...the full asset isn't loaded,
    but it's location...ugh...

    Dalchina, I'm reading through your link...
    So Process Explorer looks like a more advanced task manager??
    I'll try it out and let you know...
    Last edited by RedQueen; 25 Aug 2020 at 10:56.
      My Computer

  7. Callender's Avatar
    Posts : 4,293
    20H2 64 Bit Home
       #7

    I'd suggest setting another image viewer as default program for opening .psd files just as a test.
      My Computer


  8. Posts : 7
    Windows 10
    Thread Starter
       #8

    Just now, I tried to move an Illustrator (.AI) file and it said it's open in another window.
    I just started my PC, and I never even opened that file once...
    I'm looking into the "Process Explorer" now as it would be nice to identify the process itself...
    It seems like it's endorsed by Microsoft but independent,,,

    Ok, I so I have "process explorer" open...
    I tried dragging the the "gun sight" icon onto the file,
    but it seems like it's highlighting the entire explorer folder,
    and just returning explorer as a result.
    It's not highlighting the individual files as they claimed,
    I did the same with desktop files and it highlighted the entire thing and said explorer, LOL
    Obviously I am in explorer!!! I don't need a tool that tells me which program I have open...

    Maybe I am missing something, I don't want to mess around to much here,
    I'll try and replicate the error pop up on my test computer.

    - - - Updated - - -

    Ok, I am noticing that when I try and delete the file,
    Process explorer dllhost.exe flashes green, then red,
    It's under WinInit.exe...some random stuff pops up also,
    but it dissapears faster than I can write it down, I think I saw comsurogate,
    I'd have to take a screenshot.

    I looked up dllhost.exe and found this...
    "For example, the Windows file manager uses COM objects to create thumbnail images of images and other files when it opens a folder. The COM object handles processing images, videos, and other files to generate the thumbnails. This allows File Explorer to be extended with support for new video codecs, for example.

    However, this can lead to problems. If a COM object crashes, it will take down its host process. At one point, it was common for these thumbnail-generating COM objects to crash and take down the entire Windows Explorer process with them."
      My Computer


  9. Posts : 7
    Windows 10
    Thread Starter
       #9

    OK, soooo...
    I decided to try "Take Ownership" again...
    This time I used "EZ Context Menu V1.6" instead of a .REG from I think GeekForums,
    They both behave differently, in the sense the REG brings up a command prompt,
    and the Other gives a blue notification....so this informs me that not all "Take Ownerships" are the same.
    Nevertheless it still does nothing to fix my problem...

    Interestingly the error code Pop-Up is now telling me the file is being used by file explorer,
    instead of not specifying..which is what I wanted ....I'm not sure if it's a W10 update or if process explorer added it in.

    My next step is to browse the files setting...
    I made sure read only was unchecked, and gave the file full control.....

    still won't delete...
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:36.
Find Us




Windows 10 Forums