Custom usb drive icon not appearing  

Page 1 of 2 12 LastLast

  1. Posts : 13
    windows 10
       #1

    Custom usb drive icon not appearing


    hello all
    I'm trying to make my usb drive icon reappear using an "autorun.inf" file. this is what my file contains :
    [AutoRun]
    Icon=Omid.ico
    Label=Omid
    and it is copied to the flash drive as well as the icon file. the name of the icon is exactly as written above. so what is the problem? looks like the autorun file is completely ignored !
      My Computer


  2. Posts : 5,478
    2004
       #2

    Did you eject and reconnect the drive?

    If autorun.inf and Omid.ico are in root of the USB it should work - I just tried it and it worked for me.

    Custom usb drive icon not appearing-screenshot-2019-05-16-15.00.27.png
      My Computer


  3. Posts : 13
    windows 10
    Thread Starter
       #3

    @Brink
    Method 1 is simply ignored by my usb drive; No changes appear. Why is that? Could you please help?
    Last edited by Brink; 18 May 2019 at 07:39. Reason: Moved to current thread
      My Computer


  4. Posts : 13
    windows 10
    Thread Starter
       #4

    Yes I tried that so many times. No use
      My Computer


  5. Posts : 5,478
    2004
       #5

    It works for me so I don't know what to suggest really.

    You could try adding it to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\DriveIcons like it says here
      My Computer


  6. Posts : 13
    windows 10
    Thread Starter
       #6

    Some one claimed that new updates of win 10 do not support autorun.inf at all !!!
    I donít know if itís true but I wonder if thereís a substitution.
    The drive icon method is not actually proper since it will appear for any plug in, even a virtual drive.
      My Computer


  7. Posts : 5,478
    2004
       #7

    I did clean install of 10 Pro version 1903 a couple of days ago (so latest version) and it still works.

    Custom usb drive icon not appearing-capture.png

    I tried with autoplay on and off in settings (just in case) but it makes no difference - it always works for me.

    Perhaps someone else has an idea but it definitely should work.
      My Computer


  8. Posts : 13
    windows 10
    Thread Starter
       #8

    Thanks for you answers. So stange! I have no idea what is wrong with it.
      My Computer


  9. Posts : 13,301
    Windows 10 Pro (x64) 21H2 19044.1526
       #9

    Mine is like this (note the icon has to be in the root directory)
    [autorun]
    icon="eye.ico"

    just two lines

    Have you tried resizing the icon, I read somewhere that they might have to be a certain size.
      My Computers


  10. Posts : 13
    windows 10
    Thread Starter
       #10

    Yes I even got help from a microsoft technician (connecting to my pc) and he did try that resizing in 34 and 200 and 256 pixels. No use!
    There should be something wrong with my windows settings (although I havenít messed up with), but they couldnít help me find it.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:39.
Find Us




Windows 10 Forums