PCMECH Forum issue


  1. Posts : 9
    Windows 10 Pro
       #1

    PCMECH Forum issue


    I don't know if this is the right place to ask, but here goes:
    I have been a member of the PCMech Forums for over 15 years, and in December I tried to change my email address. Since then, I have been able to log in, but I cannot post or contact them.
    I get this message - Your account is currently awaiting confirmation. Confirmation was sent to "my email"
    The email never comes, not in spam, nothing. tried multiple times.
    Anyone else have this issue, or know of a way I can contact them?
    I sent an email to TechJunkie and haven't heard back from them yet.
    Thanks, cork
      My ComputerSystem Spec

  2. z3r010's Avatar
    Posts : 7,931
    Windows 10 Workstation x64
       #2

    Try changing the email again to a different provider (gmail ideally if that has not been used) some ISP's just bounce forum emails and there isn't much the forum can do about it.
      My ComputersSystem Spec


  3. Posts : 9
    Windows 10 Pro
    Thread Starter
       #3

    Thanks z3r010, sorry for the delayed reply.
    My original email was a comcast email, and I switched it to another comcast email I check more frequently.
    When that didn't work, I tried my gmail address, still nothing, same with an outlook email address.
    I eventually went back to my original email address and nada.

    I have no way of contacting them, and was hoping someone here was a PCMech member and might be able to get the word to GLC or one of the other moderators that has helped me through the years.

    Thanks,
    Jim M.
      My ComputerSystem Spec

  4. z3r010's Avatar
    Posts : 7,931
    Windows 10 Workstation x64
       #4

    I just tried registering an account but didn't get the confirmation email.

    I'm in, I'll see if I can get hold of somebody for you.

    I've sent GLC a message for you.
      My ComputersSystem Spec

  5. z3r010's Avatar
    Posts : 7,931
    Windows 10 Workstation x64
       #5

    I've just been messaged back that he has validated your account
      My ComputersSystem Spec


  6. Posts : 9
    Windows 10 Pro
    Thread Starter
       #6

    Many thanks z3r010!
      My ComputerSystem Spec



 

Related Threads
Hi, For weeks I've been trying to resolve an explorer hang when launching Open Shell- it's been a persistent problem that various people experienced with Classic Shell. Where this was resolved, each reported case was different. I would advise you...
Hi, I manually upgraded to the new 1703 release of Windows 10, and this OS is very stable. I burned the ISO and did an in-place upgrade from Version 1607 on 3 PCs, and got this weird issue. All of them have NVIDIA graphics cards, and...
Hello! I upgraded to Windows 10 today. I have two issues. 1. I play a game called "Starcraft II" and I have a problem with the game minimizing and maximizing sometimes very slowly, every 5th attempt or so. During this time it takes up to 40...
To everyone on this forum in Chillout Room
I would like to thank Brink All the other admins and Mods for making this forum the best one out. Also to all the testers and hard work they put in along with the hours to make this forum and windows 10 what it is to day. Also to all members on...
New Forum in Windows Insider
New forum. Just seen this today and a new build pops up too! Thanks to the powers that be for both.:party:
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:35.
Find Us