Page 1 of 8 123 ... LastLast
  1.    05 Oct 2017 #1
    Join Date : Oct 2017
    Posts : 46
    Windows 10 Pro

    machine_check_exception BSOD on boot up after new motherboard install


    Hi there,

    My system is facing problems with an intermittent machine_check_exception BSOD during the OS boot, after I recently replaced my motherboard and reinstalled Windows. The BSOD screen states it will restart for me, but never does. When normally booting up, my system disconnects all USB devices and reconnects them shortly after Win10 logo and spinning circle appear, but on an unsuccessful boot the BSOD appears right when the devices are due to reconnect (driver conflict?), leaving them disconnected. I am aware others have faced the same stop code for reasons of either hardware or driver failure/malfunction. Most examples of this BSOD happen either at random inside the OS or during games from what I have read elsewhere.

    The crashes occur on roughly 2 out of every 3 attempts to boot/restart the system. When I finally make it into the OS and log in, everything seems to work perfectly fine, including CPU and GPU benchmarks. I have also run the Memtest USB bootable and it found no issues relating to memory, along with Intel's Processor Diagnostic Tool. No driver errors shown in device manager.

    I heard on another post that overclocking utilities such as AI Suite can cause this issue. I uninstalled the program and disabled all overclocks, but the problem persisted. My CPU core temps at both idle and under load are perfectly fine (Noctua NH-D15 cooler, 30C idling). So after all my efforts to troubleshoot, I am beginning to suspect either a potential fault with new motherboard, or perhaps a driver conflict with one of my USB devices.

    Can anyone tell me anything from crash dumps? Also, this is my first time using TenForums, so sorry for any noob errors!

    Spoochung
    machine_check_exception BSOD on boot up after new motherboard install Attached Files
      My ComputerSystem Spec
  2.    06 Oct 2017 #2
    Join Date : Nov 2015
    Posts : 2,861
    64bit Win 10 Pro ver 1709 Build 16299.64

    Hello Spoochung,

    There is only one crash dump file in the logs and it is not a Machine Check exception so I suspect that these BSODs are not being written to a dump file when they occur, probably because they are happening at the bootup stage.

    You could try turning off fast startup to see if it makes a difference.
      My ComputersSystem Spec
  3.    06 Oct 2017 #3
    Join Date : Oct 2017
    Posts : 46
    Windows 10 Pro
    Thread Starter

    Thanks for the suggestion, late last night I tried resetting BIOS to optimised default settings (despite no OC), and that seemed to fix the machine check exception BSODs at boot from what I can tell after about 5 successful cold boots and restarts.

    However, not long after this I received the different stop code USB_driver_power_state_failure while on the desktop, which restarted the system. By instinct I checked device manager for any issues with my USB devices, and found "unknown USB device (device descriptor request failed)" in the Universal Serial Bus Controller tab (provided screenshot). I have identified that this appears to be a conflict with my USB audio interface (Focusrite Scarlett 2i4 1st gen) as the message goes away when I disconnect the device, which is connected to my rear USB ports via an external powered USB 3.0 hub. I tried to uninstall the driver, restart, plug it back in, and it worked fine until I booted up my system today. I also have a web cam plugged into the hub, so would this mean the audio interface box is faulty/incompatible with my setup? Or could it still be caused by the hub? (note I haven't had the BSOD relating to this since last night, it's just the driver error I am concerned about for now)
    Attached Thumbnails Attached Thumbnails image.png  
      My ComputerSystem Spec
  4.    06 Oct 2017 #4
    Join Date : Oct 2016
    Posts : 322
    seL4

    Upload another set of logs, we'll want to take a look at the crash dumps generated from the power state bugchecks.

    Regarding the USB device, what error is shown in device manager?
      My ComputerSystem Spec
  5.    06 Oct 2017 #5
    Join Date : Oct 2017
    Posts : 46
    Windows 10 Pro
    Thread Starter

    The error can be seen in the last attachment image, stating " Unidentified USB Device (device descriptor request failed)". I have attached the details of the error and a new log file.
    Attached Thumbnails Attached Thumbnails Capture2.PNG  
    machine_check_exception BSOD on boot up after new motherboard install Attached Files
      My ComputerSystem Spec
  6.    06 Oct 2017 #6
    Join Date : Oct 2016
    Posts : 322
    seL4

    One crash dump from the 6th is corrupted (has 0 size on disk), so I was only able to look at one of the two new crashes.

    It did show that your FocusRite USB driver was responsible for blocking the Power IRP, which then caused the power state failure.

    Code:
    Irp is active with 25 stacks 24 is current (= 0xffffb3071865d758)
     No Mdl: No System Buffer: Thread 00000000:  Irp stack trace.  Pending has been returned
         cmd  flg cl Device   File     Completion-Context
    
    	 [Truncated for brevity]
    
     [IRP_MJ_POWER(16), IRP_MN_WAIT_WAKE(0)]
                0  0 ffffb307165ec060 00000000 fffff80b66146a70-ffffb307165bb5a0    
    	       \Driver\USBHUB3	UsbHub3!HUBPDO_WdmPnpPowerIrpCompletionRoutineForAsynchronousCompletion
    			Args: 00000000 00000000 00000000 00000002
     [IRP_MJ_POWER(16), IRP_MN_WAIT_WAKE(0)]
                0  0 ffffb307165ec060 00000000 00000000-00000000    
    	       \Driver\USBHUB3
    			Args: 00000000 00000000 00000000 00000002
    >[IRP_MJ_POWER(16), IRP_MN_SET_POWER(2)]
                0 e1 ffffb307167ab040 00000000 fffff80130151ed0-ffffb30717d8c180 Success Error Cancel pending
    	      *** WARNING: Unable to verify timestamp for FocusriteUSB.sys
    *** ERROR: Module load completed but symbols could not be loaded for FocusriteUSB.sys
     \Driver\FocusriteUSB	nt!PopRequestCompletion
    			Args: 00051100 00000001 00000001 00000002
     [N/A(0), N/A(0)]
                0  0 00000000 00000000 00000000-ffffb30717d8c180    
    
    			Args: 00000000 00000000 00000000 00000000

    Have you checked on FocusRite's website for a newer driver? This looks to be their download page: Downloads | Focusrite
      My ComputerSystem Spec
  7.    06 Oct 2017 #7
    Join Date : Oct 2017
    Posts : 46
    Windows 10 Pro
    Thread Starter

    Thank you for looking into this for me. I have already tried updating to the driver from their site, and I made sure to get the 2i4 Gen1 driver rather than the one for the Gen2 model. Faulty box perhaps?
      My ComputerSystem Spec
  8.    06 Oct 2017 #8
    Join Date : Oct 2016
    Posts : 322
    seL4

    It could be a hardware issue for sure, it could also be that their driver is faulty and they do not want to spend money fixing/updating software for an older device.
      My ComputerSystem Spec
  9.    06 Oct 2017 #9
    Join Date : Oct 2017
    Posts : 46
    Windows 10 Pro
    Thread Starter

    I might see about trying to contact either Focusrite or the place where I got it from in that case (may be just out of the warranty period), and I'll also try plugging it directly into my PC with the hub taken out of the equation. The fact that it's an externally powered hub might cause issues with some but not all devices I suppose. If everything else remains stable for the next 48 hours I'll make sure to mark the thread as solved!

    Thanks for all your help, wish I knew my stuff as well as you guys!
      My ComputerSystem Spec
  10.    06 Oct 2017 #10
    Join Date : Oct 2017
    Posts : 46
    Windows 10 Pro
    Thread Starter

    Update: I have plugged my audio interface into one of the rear ports and all appears to be fine and dandy now. But...
    I have been setting up my BIOS settings since I had reset them to default while troubleshooting. I'm not doing any OCing at this stage as I want the system to be confirmed to be stable before I even think about that. The settings I am tweaking are purely to speed up boot time, as boot up times on the X99 platform can be quite a drag at stock settings.
    So... I tweaked one setting at a time, no problems until disabling CSM, at which point the next reboot resulted in the same BSOD I created this thread to solve (MCE). Therefore it would seem that the root of the problem might have been caused by this setting in particular? Please let me know what you think. I have attached another log just in case the BSOD created a dump this time around.
    machine_check_exception BSOD on boot up after new motherboard install Attached Files
      My ComputerSystem Spec

 
Page 1 of 8 123 ... LastLast


Similar Threads
Thread Forum
BSOD MACHINE_CHECK_EXCEPTION during every game
Hello everyone. So Ive had this PC for a year now, recently Ive been getting Blue screens with this "Machine check exception code" it happened once then nothing for a while. Then it happened again, more and more often and as of today I cant play...
BSOD Crashes and Debugging
Solved Machine_Check_Exception BSOD
For the past few days, playing Fallout 4 seems to invariably end in a BSOD usually with a MACHINE_CHECK_EXCEPTION error, but a few times the screen has simply frozen during play, sound crashed loudly, and the machine has not responded to any...
BSOD Crashes and Debugging
Machine_Check_Exception BSOD on new laptop
So far I've gotten it twice. Before I go through the work of returning and getting a new one I'm hoping it's an easy fix. 51968
BSOD Crashes and Debugging
Bsod - machine_check_exception
Hello Ladies & Gents! I'm a SevenForums member, DreadStar/DreadStarX! It's been a long time since I've been on here, and found that SF/EF/TF is one of the best resources for OS Problems. So, here's the problem. When I boot up VMWare...
BSOD Crashes and Debugging
Random BSOD Machine_Check_Exception after Win 10
Hi, I've been getting random this random bsod every time I try to boot my laptop. It's been happening everyday after 2 weeks, since I updated from windows 7 to windows 10. Thanks in advance.
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:52.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums