BSOD- DPC Watchdog Violation Windows 10


  1. Posts : 2
    Windows 10 Home 64-bit (10.0, Build 15063)
       #1

    BSOD- DPC Watchdog Violation Windows 10


    Hey all,

    Im very new to this website FYI, but I am trying to solve the BSOD that my boyfriend's laptop is getting. Like many others, the laptop freezes during a video, usually Youtube, and makes a weird repeating sound out of the video. Some things I have tried to solve this:


    I have looked through a lot of other threads for example this : WinDBG - The Basics for Debugging Crash Dumps in Windows 10and BSOD, everytime i watch videos on youtube, DPC watchdog violation to get to know more about it. I have downloaded the WinDBG but I have no idea what I'm doing so I follow very closely on any instruction I can find.

    As suggested in some threads, I went onto the Asus website and updated my BIOS and I downgraded my Wireless to an older version.

    This solved my issue for maybe 2 days.

    Now im trying to play around with WinDBG, it always tell me I dont have access and that it needs permission. I have worked my way around this with doing the 'Run as Administrator' because I could not find any options in it's properties tab.

    Anyways, here are the specs:

    Operating System: Windows 10 Home 64-bit (10.0, Build 15063) (15063.rs2_release.170317-1834)
    System Manufacturer: ASUSTeK COMPUTER INC.
    System Model: X555LAB BIOS: X555LAB.601
    Processor: Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz (4 CPUs), ~2.2GHz

    And I'll attach my dump file.

    I really hope someone will be able to help me.I would be very thankful for it!

    Thanks in advance!

    Attachment 152804
      My Computer

  2. Spectrum's Avatar
    Posts : 546
    seL4
       #2

    It looks like your Realtek Wifi driver (rtwlane.sys) is causing the DPC Watchdog violations.

    Code:
    00 fffff801`d19d5bc8 fffff801`cf21f3d2 nt!KeBugCheckEx
    01 fffff801`d19d5bd0 fffff801`cf0f8899 nt!KeAccumulateTicks+0x124ea2
    02 fffff801`d19d5c30 fffff801`cf00a676 nt!KeClockInterruptNotify+0x599
    03 fffff801`d19d5f40 fffff801`cf092675 hal!HalpTimerClockInterrupt+0x56
    04 fffff801`d19d5f70 fffff801`cf1f0bfa nt!KiCallInterruptServiceRoutine+0xa5
    05 fffff801`d19d5fb0 fffff801`cf1f1047 nt!KiInterruptSubDispatchNoLockNoEtw+0xea
    06 fffff801`d19ce1d0 fffff801`cf008e00 nt!KiInterruptDispatchNoLockNoEtw+0x37
    07 fffff801`d19ce368 fffff801`cf008d34 hal!HalpTimerGetInternalData
    08 fffff801`d19ce370 fffff801`d8b20918 hal!KeStallExecutionProcessor+0x134
    09 fffff801`d19ce400 00000000`00000000 rtwlane+0x30918

    Try an older version of the Realtek Wifi Driver, you are currently using a release from 5/19/2017.

    If that doesn't resolve the issue, try updating to the latest driver from Realtek.
      My Computer


  3. Posts : 2
    Windows 10 Home 64-bit (10.0, Build 15063)
    Thread Starter
       #3

    Thanks for your response Spectrum.

    Unforunately I get this when I try to install that version:

    Attachment 152815

    I noticed another version that I had: 2023.43.914.2016

    So I will switch and try it with that and see what happens.

    Thanks again!
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:10.
Find Us




Windows 10 Forums