Windows 10: BSOD browsing, waking from sleep. CRITICAL_STRUCTURE_CORRUPTION

Page 3 of 5 FirstFirst 12345 LastLast
  1.    04 Jul 2017 #21

    I was able to uninstall all realtek drivers and I1KBFLTR.sys from Everything and device mananger. I ran driver verifier after that and everything seemed to be fine. I also installed the newest ethernet drivers from realteks website and tested going to the internet. It seemed to work without problems

    When I disabled driver verifier and rebooted I started getting problems. My monitor couldn't recognise my computer on boot up and therefore I got a black screen. But the fans was still running and I could hear sound. I mananged to fix the problem by connecting to my integrated graphics instead of the gpu. But then red artefacts started to apear on the monitor indicating that the integrated graphics might be faulty.

    I haven't touched the graphics drivers so I'm not sure waht might be the problem.
      My ComputerSystem Spec


  2. Posts : 20,080
    windows 10 professional version 1607 build 14393.969 64 bit
       04 Jul 2017 #22

    Open administrative command prompt and type or copy and paste these commands:
    1) sfc /scannow
    2) dism /online /cleanup-image /restorehealth
    3) chkdsk /scan
    4) post an updated zip file: BSOD - Posting Instructions - Windows 10 Forums
      My ComputerSystem Spec

  3.    04 Jul 2017 #23

    No faults or errors found by running the above commands.

    I have not had any BSOD's since the last zip file i uploaded. Only black screens.
    Last edited by slowcorals; 04 Jul 2017 at 15:21.
      My ComputerSystem Spec


  4. Posts : 20,080
    windows 10 professional version 1607 build 14393.969 64 bit
       04 Jul 2017 #24

    Code:
    The driver \Driver\rt640x64 failed to load for the device PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458&REV_06\4&7ef09b9&0&00E2.
    Code:
    rt640x64     Realtek RT640 NT Drive Realtek RT640 NT Drive Kernel        Manual     Running    OK         TRUE        FALSE        4,096             933,888     0          26/05/2017 09:02:29    C:\WINDOWS\system32\drivers\rt640x64.sys         8,192
    rt640x64.sys Realtek NICDRV 8169 PCIe GBE Family Controller driver
    http://www.realtek.com.tw/downloads/...&GetDown=false


    Code:
    Event[21926]:  Log Name: System  Source: Microsoft-Windows-Kernel-PnP  Date: 2017-07-04T21:24:50.463  Event ID: 219  Task: N/A  Level: Warning  Opcode: Info  Keyword: N/A  User: S-1-5-18  User Name: NT AUTHORITY\SYSTEM  Computer: DESKTOP-VQI609R  Description: The driver \Driver\rt640x64 failed to load for the device PCI\VEN_10EC&DEV_8168&SUBSYS_E0001458&REV_06\4&7ef09b9&0&00E2.

    1) Did you make a backup image of your drive with Macrium?

    2) Are you able to uninstall Witcher3 and Dragon Age and reinstall them?

    3) What does this mean: Inte tillgänglig

    4) Uninstall: Realtek NICDRV 8169 PCIe GBE Family Controller driver
    Reinstall: Realtek
      My ComputerSystem Spec

  5.    04 Jul 2017 #25

    1) Yes I did.
    2) I can but it would take awhile. I'm not sure why I would need to do that. I have not experienced any crashes in Witcher 3 and Dragon age only crashes because I have some mods that makes it so.
    3) It means: Not available.
    4) done. After I uninstalled and reinstalled I didn't receive any Bsod's anymore.

    I have not had any BSOD's in driver verifier for a couple of hours. So I'm starting to think my system is getting stable. I also Uninstalled Realtek Audio drivers and reinstalled from their website. I used everything and device manager to uninstall.

    The problem I have now is that I get a black screen when using the DVI port on my graphics card. I tried using my HDMI port instead and it worked. I will try with a new DVI cable tomorrow then I will report back. I also get red dots on the monitor when using integrated graphics but it's not a huge deal because I don't use it.
      My ComputerSystem Spec


  6. Posts : 20,080
    windows 10 professional version 1607 build 14393.969 64 bit
       04 Jul 2017 #26

    Code:
    03/07/2017 12:26	Application Error	Faulting application name: DAOrigins.exe, version: 1.5.13263.0, time stamp: 0x4eb19d53
    Faulting module name: d3d9.dll, version: 10.0.15063.0, time stamp: 0x7f8d5e6e
    Exception code: 0xc0000005
    Fault offset: 0x00052766
    Faulting process ID: 0x107c
    Faulting application start time: 0x01d2f3ef4501bf58
    Faulting application path: D:\Games\gog\Dragon Age Origins\bin_ship\DAOrigins.exe
    Faulting module path: C:\WINDOWS\SYSTEM32\d3d9.dll
    Report ID: 78a17c9e-da3e-4f88-a7bc-b977d243f67c
    Faulting package full name: 
    Faulting package-relative application ID:
    DAorigins is a frequently faulting application.
    When there are frequently faulting applications > uninstall/reinstall

    What's happening with the startup repairs?
      My ComputerSystem Spec

  7.    04 Jul 2017 #27

    Ok, I will uninstall Dragon age tomorrow.

    When I get blue screen two times in a row Windows automatically wants to do a repair. I suppose that is what you mean. Yesterday it was the only way for me to boot into safe mode and disable driver verifier.
    Correct me if I'm thinking of the wrong thing.
      My ComputerSystem Spec


  8. Posts : 20,080
    windows 10 professional version 1607 build 14393.969 64 bit
       04 Jul 2017 #28

    Whenever you have a bsod please up date the zip.
    The black screens need to be troubleshooted.
    Can't keep doing startup repairs.
    So as many as possible of the faulting applications need to uninstalled and reinstalled or just uninstalled so that we can troubleshoot. So if you can uninstall witcher 3 too and possibly find an alternative game that is not faulting.
      My ComputerSystem Spec

  9.    06 Jul 2017 #29

    Ok, so the DVI cable I had turned out to be broken. i switched that for a new one and that one worked. But I still get black screens. I got one just after turning the computer on from sleep.

    I also got a blue screen when running hwinfo64.exe so i reinstalled the program and drivers but that still didn't seem to work so I just removed the program and drivers completely.

    I reinstalled Dragon Age Origins But still got an error when closing the game. I only get the error when closing the game and when running it through GOG galaxy which is a game launcher. If I run the .exe without the launcher i don't get any errors. I Reinstalled GOG galaxy and that did seem to fix Witcher 3. I ran it multiple times and didn't recieve any information about it in event viewer. So I think that game is fine now. But it didn't fix Dragon age. So I think I will run Dragon age from the .exe from here on out.

    I Have been running driver verifier since I last replied in this thread.
      My ComputerSystem Spec


  10. Posts : 20,080
    windows 10 professional version 1607 build 14393.969 64 bit
       06 Jul 2017 #30

    Code:
    BugCheck C4, {2000, fffff8084cf310a5, 0, 4d4d4d4d}*** WARNING: Unable to verify timestamp for HWiNFO64A.SYS*** ERROR: Module load completed but symbols could not be loaded for HWiNFO64A.SYSProbably caused by : HWiNFO64A.SYS ( HWiNFO64A+10a5 )

    Within the log files I did not see this driver listed.
    If you see hwinfo in control panel please uninstall it.
    Open file explorer > this PC > C drive > search for HWiNFO64A.SYS
    Please post an image of the search results.
      My ComputerSystem Spec


 
Page 3 of 5 FirstFirst 12345 LastLast

Related Threads
Solved BSOD when waking from sleep in BSOD Crashes and Debugging
Hi I have had this problem for some months now. While I can put the computer to sleep, each time I wake it up it causes a BSOD. I have followed many threads about this. some suggesting it is video driver problem. So I uninstalled and...
Solved BSOD upon waking from sleep in BSOD Crashes and Debugging
133661 A new laptop with Windows 10 freezing when waking from sleep. BSOD: irql not less or equal. Please help.. Thank you very much!
Solved BSOD when waking from sleep in BSOD Crashes and Debugging
Greetings forum, Ever since I upgraded to Windows 10, I've been seeing BSODs about once a month when waking my desktop from sleep. I would greatly appreciate any help on this matter. I've never encountered this on Windows 8.1. I've attached...
Solved BSOD When Waking from Sleep in BSOD Crashes and Debugging
Just built a new computer. All of the drives and the Windows installation is the same as in the old system. I don't know if the issue would have occurred in the old system as I never tried to put my computer to sleep. I was getting one BSOD when...
Solved BSOD after waking from sleep in BSOD Crashes and Debugging
Hey guys, i am stumped on this one, every time i have put my computer to sleep after waking it it will show my pin to type in but it freezes there and the bsod after about 5secs, i have done a memtest and that passed, but yeah no idea. hopefully...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:06.
Find Us