Page 1 of 3 123 LastLast
  1.    01 May 2017 #1
    Join Date : May 2017
    Posts : 11
    Windows 10 64 bit

    Frequent & random BSOD ahcix64s.sys & ntoskrnl.exe


    I retired several years ago from 20+ years as a computer tech for a large non-profit in midwest USA. Reading error logs is not one of my strong points. I am having repeated BSODs on my own computer for quite a while that I have not been able to resolve.

    My DM Log Collector file is attached.

    Sometimes it will run for extended periods of time without problems, while other times, it will blue screen on me soon after booting. I have had problems with the system hanging for 30 seconds or more, but that is probably something for another post.

    Here are some of the things I have tried. There may be other things I have done, but did not document.
    1. The 9 Gig memory is the original factory memory that HP installed. I ran Memtest 86+ for a day or two with no errors.
    2. I have 2 WDC WD2001FASS-00W2B0 hard drives in a RAID 1 configuration. Western Digital Data Lifeguard & other drive tests have showed no errors.
    3. Some of the things I have tried recently with no permanent success: Unselected AMD RAIDXpert Service in msconfig.
    Uninstalled storage controller driver for AMD AHCI Compatible RAID Controller. ( That caused an Inaccessible boot device error for a few boots, but got that fixed.
    Let Windows reinstall the RAID controller driver.
    Tried several versions of the driver that Windows listed when trying to manually select the driver.
    Downloaded RAIDXpert v3.2.1540 from AMD & installed. Device Manager now shows AMD AHCI Compatible Controller v 3.7.150.43 (12-11-2012).

    None of these things have fixed the random BSOD problems. I am hesitating in "nuking & repaving" my PC, because I have some programs that I have installed (legally) from Giveaway of the Day - free licensed software daily that I would not be able to reinstall.

    Thanks for your help,
    Ken
      My ComputerSystem Spec
  2.    01 May 2017 #2
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,345
    Windows 10 Pro X64 16299.19

    Several of the dumps point to snapman.sys.
    Code:
    BugCheck 1E, {ffffffffc0000046, fffff8021bc0ed48, 1, 2}
    
    *** WARNING: Unable to verify timestamp for snapman.sys
    *** ERROR: Module load completed but symbols could not be loaded for snapman.sys
    Probably caused by : snapman.sys ( snapman+1cf09 )
    Driver Description: Acronis True Image Snapshot Manager driver also included in Seagate DiscWizardDriver Update Site: Support: http://www.acronis.com/support/
    Download: http://www.acronis.com/support/?TS=4-0

    The one you have is very old: Timestamp: Fri Jul 13 06:03:12 2007

    Uninstall Snapshot manager. If you still need it, get the latest version available. There are probably free alternatives available.

    YOu could probably replace it with Macrium Reflect Free or Pro (Pro is what I use, gave up on Acronis many years ago).
      My ComputersSystem Spec
  3.    01 May 2017 #3
    Join Date : May 2017
    Posts : 11
    Windows 10 64 bit
    Thread Starter

    Thanks for the info. After I made my post, I decided to review Tenforum's WinDBG tutorials. I had a v8.1 of WinDBG, so I uninstalled it and installed the Windows 10 version. I saw the references to snapman.sys in my dmp file. I forgot that I had Acronis True Image Home installed, and don't use it. I will uninstall it and see if that helps.

    I saw this link about Acronis 'leftovers' when uninstalling. Do you think I should worry about that, or just wait & see what happens? Beware of Acronis Issues | Wilders Security Forums

    Depending on how much I use the computer this week, it may be a while before I find out if the BSOD problems are resolved.

    Thanks,
    Ken
      My ComputerSystem Spec
  4.    01 May 2017 #4
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,345
    Windows 10 Pro X64 16299.19

    I use Revo Uninstaller (I have the Pro version) just because of issues like these left over files. You could try the portable version. It doesn't have to be installed, you can just run it.

    In all likelihood, the left over files would not cause you any problem.
      My ComputersSystem Spec
  5.    01 May 2017 #5
    Join Date : May 2017
    Posts : 11
    Windows 10 64 bit
    Thread Starter

    I uninstalled Acronis True Image Home 11 with Revo Uninstaller portable and the most agressive settings, & rebooted. There is still a snapman.sys file in the System32\drivers folder that is dated 7/18/2010.

    The system hasn't crashed since this morning, and I hadn't made any changes until this evening. Go figure.

    Do you see anything else in the dmp files of concern. Many of the errors seem to reference the ahcix64s.sys file. Is it causing problems, or is it just the unlucky file that gets blamed for the error?

    Ken
      My ComputerSystem Spec
  6.    01 May 2017 #6
    Join Date : May 2017
    Posts : 11
    Windows 10 64 bit
    Thread Starter

    I ran System Explorer & NirSoft DriverView. It showed 3 Acronis drivers still loading.

    tdrpman.sys Acronis Try&Decide and Restore Points Volume Filter Driver, Acronis Acronis Try&Decide and Restore Points C:\WINDOWS\system32\DRIVERS\tdrpman.sys

    tifsfilt.sys Installable Driver Acronis True Image File System Filter Acronis Acronis True Image C:\WINDOWS\system32\DRIVERS\tifsfilt.sys

    timntr.sys Installable Driver Acronis True Image Backup Archive Explorer Acronis Acronis True Image C:\WINDOWS\system32\DRIVERS\timntr.sys

    I ran 2 Acronis cleanup tools. Twice, rebooting after running each once.
    Acronis Backup & Recovery 11 Cleanup Utility | Knowledge Base
    Acronis True Image: Cleanup Utility | Knowledge Base

    Running the cleanup utilities reduced the leftover registry keys with 'acronis' in them from over 1000 to less than 100. I'll probably leave them alone.

    After that, there was only 1 Acronis file left running, tifsfilt.sys. I used Sysinternals Autoruns to unselect the driver.

    I will run the system for a while to see if I get any more crashes.
      My ComputerSystem Spec
  7.    02 May 2017 #7
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,345
    Windows 10 Pro X64 16299.19

    Great work, more complicated than it should be but sounds like you got them.
      My ComputersSystem Spec
  8.    07 May 2017 #8
    Join Date : May 2017
    Posts : 11
    Windows 10 64 bit
    Thread Starter

    Still having BSODs


    Well, I thought my BSODs were gone, but I just had another one, after restarting the system. I have attached a new log file. I might not be able to respond tonight. We are going to to see Garth Brooks in Kansas City.
      My ComputerSystem Spec
  9.    07 May 2017 #9
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,345
    Windows 10 Pro X64 16299.19

    The new dump indicates a problem with the AMD raid controller.
    Code:
    BugCheck D1, {ffffd57e6e274000, 7, 1, fffff8076dba390c}
    
    *** WARNING: Unable to verify timestamp for ahcix64s.sys
    *** ERROR: Module load completed but symbols could not be loaded for ahcix64s.sys
    Probably caused by : ahcix64s.sys ( ahcix64s+3390c )
    Driver Description: AMD AHCI Compatible RAID Controller
    Driver Update Site: http://support.amd.com/us/psearch/Pa...ords=&items=20

    Are you using a RAID setup? If not, uninstall the AMD AHCI Compatible RAID Controller

    I also see a problem with Avast anti-virus
    Code:
    ffffc581`1f3c5cc8  fffff807`6e1674a4Unable to load image aswSP.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for aswSP.sys
    *** ERROR: Module load completed but symbols could not be loaded for aswSP.sys
     aswSP+0x174a4
    Driver Description: avast! Self Protection Driver

    Uninstall Avast anti-virus.
    Make sure Windows Defender and Windows Firewall are enabled.
    Run that way for awhile to test, see if that resolves the problem.
      My ComputersSystem Spec
  10.    16 May 2017 #10
    Join Date : May 2017
    Posts : 11
    Windows 10 64 bit
    Thread Starter

    My computer is still crashing with the same ahcix64s.sys error. In response to your last post, I am still using RAIDed drives.

    Avast was uninstalled with Revo Uninstaller Portable.

    I didn't have any luck finding newer drivers from AMD.

    The strange thing is, the drivers.txt file from the DM log collector shows a date for ahcix64s.sys of 4/4/2008 2:56:04 AM, while the ahcix64s.sys file properties and the msinfo32.nfo file show a date of ‎August ‎17, ‎2012, ‏‎8:42:36 AM.

    I found another copy of the ahcix64s.sys file in one of the C:\Windows\System32\DriverStore\FileRepository\ folders (Same file properties as the original). After using a bootable flash drive, I renamed the original, then copied the FileRepository version into the drivers folder. I still get crashes.

    The system has NEVER crashed while in Safe Mode with Networking (That is how I am sending this post.) The latest log collector file was collected while in Safe Mode with Networking. NirSoft DriverView shows that ahcix64s.sys is currently loaded while in Safe Mode.

    A new log file is attached. Thanks for all of your help,
    Ken
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
need help frequent BSOD hal.dll+4e490 and ntoskrnl.exe+14a6f0
i already clean install my computer in the other day but now i got new BSOD and i dont know why? please any kind hearted here please lend me your hand again and help me... thanks and god bless here are the new attachments
BSOD Crashes and Debugging
Solved Random but frequent BSOD - whea_uncorrectable_error
I’m getting a lots of BSOD with whea_uncorrectable_error and I have tried lots of thing/suggestions from googleing…. Before this happened it all worked perfectly fine for a month and all of the sudden it began. It have never been overclocked only...
BSOD Crashes and Debugging
BSOD ahcix64s.sys
Hey everyone, I am having an issue that is driving me crazy! I am trying to write this as basic as possible, but with enough detail hopefully. This is a newer build that has never been right it seems. Drives Configuration: 1 - SATA 256GB...
BSOD Crashes and Debugging
Recent Random Frequent BSOD
Relatively new build, clean install of Win10, fully updated. Starting a couple of days ago, I've been re-booting about every hour or so, nothing helpful in the Event Viewer logs, so I'm posting here. Config: AMD Athlon X4 860K factory clocking...
BSOD Crashes and Debugging
Random frequent BSOD with various cause and time
My PC seems to have BSOD at random moment, like when playing GTA V, watching youtube, or even 30 seconds after boot up idling, but sometime it can survive 5 hours without single BSOD.. The displayed BSOD cause are also random sometime it's...
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:11.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums