1.    24 Mar 2017 #1
    Join Date : Mar 2017
    Posts : 3
    Windows 10

    System Thread Exception Not Handled (nothing here) After 1607 Update


    Background:
    I bought a graphics card (GTX 1080Ti) for my custom gaming computer running Windows 10 (10240 at the time).I'm upgrading from a GTX 770.
    Play-by-play:
    Updated to the latest driver with Geforce Experience.Shut down.
    I replaced the card and booted up.
    Booted fine, but the display running on the 1080Ti was running at 1024x768 (instead of 1920x1200).
    (Figured this was normal)
    Waited for startup programs to calm down.
    Changed the display resolution to native.
    Device Manager doesn't have any idea what the card is (lists it as VGA-Compatible with a warning icon).
    Checked for driver update in Geforce Experience.
    Tried to install.
    "Not compatible with my version of Windows"
    Tried downloading the driver directly from Nvidia: same issue.
    Try to install the driver automatically and manually with Windows from Device Manager. No luck.
    (think to myself, maybe an error message knows what it's talking about for once. check for updates)
    I install some updates and it reboots with the "Hi. We've Updated Your PC." screens.
    More updates available including the update to 1607.
    Restart to install and it gets all the way through the update process (100%) with one or two reboots.
    Reboots one last time after completing and then BSOD: System Thread Exception Not Handled (with no driver or anything listed after).

    It's been doing this ever since, no matter how many times it tries to boot. I've taken the card out and it still does it (using only the onboard graphics in the processor). There's no driver listed with the BSOD stop code and startup repair always fails. I took a look at the SrtTrail.txt file and everything passed. Safe Mode always BSODs too.

    I'm stumped at this point.
    I'm downloading an iso for 1607 at work now, but I really really really don't want to go down the nuke-your-whole-drive-and-install-windows route.
    Let me know if I can add any more relevant info about my system or the steps I took to get here.

    (also, I posted this on the Tom's Hardware forums yesterday because I forgot how good the community here always is. So if you saw it there, I'm sorry for kind of skirting the multiple threads rule).
      My ComputerSystem Spec
  2.    25 Mar 2017 #2
    Join Date : Mar 2017
    Posts : 2
    windows 10

    I am experiencing the same problem on my pc, with a 1080sc gpu. I was trying to get the headset, on a new Oculus rift, to work. I saw an exclamation on the Nvidia toolbox. Installed the driver thinking maybe it would help. BSOD loop.
    Now reinstalling windows and seeing that you have the same problem. I can see it's driver related and not hardware. Going to wait for a new driver update I guess.
      My ComputerSystem Spec
  3.    25 Mar 2017 #3
    Join Date : Mar 2017
    Posts : 3
    Windows 10
    Thread Starter

    I'm not sure what the deal is. Over the course of today I've rolled back the anniversary update twice (from the startup repair menu item "Go back to the previous build") and am in the process of installing it a third time.

    I've uninstalled all my graphics drivers. Once I upgrade, I'll install some out-of-date ones and see if I can reboot.

    Also, to add more information, the last SrtTrail.txt I read indicated that the registry was corrupt and that's why it wasn't booting.
      My ComputerSystem Spec
  4.    25 Mar 2017 #4
    Join Date : Mar 2017
    Posts : 2
    windows 10

    Just finished reinstall of Windows. I think I narrowed it down. We both are running Asus motherboards. I installed the Nvidia driver and forgot about the Mobo Drivers. Loaded the Cd and began the install. Three or four drivers in BSOD loop.
    I'm not sure if you use the Asus driver CD, but I used it a couple days ago and just now. So I think it has something to do with the problem.
      My ComputerSystem Spec
  5.    26 Mar 2017 #5
    Join Date : Mar 2017
    Posts : 3
    Windows 10
    Thread Starter

    Another update with good news this time:

    My system is up and running. It turns out it had nothing to do with the card.

    Yesterday, I took out the card, rolled back the BSOD loop updated, uninstalled all my nvidia drivers, and reinstalled the update from a bootable flash drive. This time, it didn't even boot once. It blue screened the moment the update finished.

    So what could the problem be? Well, I didn't mention this before because I thought it was irrelevant, but the only time I succeeded in booting into the updated system was when my Intel RST SSD caching was off. So to test that, I rolled back the newly broken update, turned off caching, installed the update again, and I could boot no problem. Then I turned the SSD caching back on and bam, system unrecoverable (even after I turned the caching off again).

    This had me worried because without it, my computer is dog slow and I would be miserable. Plus comparably sized SSDs to my drive costs thousands. So I tried the most methodical approach possible.

    I rolled back the update. Installed the latest version of all the potentially relevant drivers (USB, chipset, RST, Management Engine) from ASUS. Then I did an sfc /scannow to make sure my system was all good and nothing broken would carry over into the update. It DID find stuff and fixed it. I also did it again just to make sure (came up clean). Then I ran an extended SMART test on my SSD through Speedfan (all good).

    Then I ran the update with ssd caching disabled and the volumes not even set up as raid (I disabled them from the ROM on boot after syncing the cache when the previous update had failed). Once the update was installed and booted, I ran windows update immediately. There were three updates for 1607 specifically. I installed those and rebooted to test. Everything worked.

    Then I installed Geforce Experience, the latest driver and rebooted. Again, everything worked.

    As an extra precaution, I created a system restore point manually and then enabled SSD caching with the newly updated RST app and the most up-to-date windows. Keep in mind, I had done this before from a booted version of the updated OS and then it BSODed on reboot.

    Restarted again and it booted just fine. I'm going to reboot a few more times just to make myself feel more confident in this, but I suspect it's some combination of the windows update and the updated RST app that did it (and maybe the SFC).

    If I don't have any more issues, I'll mark this reply as the solution. Hopefully this can help someone else.
    Last edited by rustyspoork; 26 Mar 2017 at 18:17. Reason: trying to emphasize the command without the CODE blocks which are huge and annoying for inline
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Bsod system thread exception not handled
Hi, since updating with the Windows 10 Anniversary Update, on Aug 3rd. I have had 8 BSOD occurrences Each giving the same Stop Code: THREAD EXCEPTION NOT HANDLED also What failed? partmgr.sys. Each time I had to power off and restart. I looked...
BSOD Crashes and Debugging
System thread exception not handled(usbehci.Sys)
Hi Today I try to setup new device to my laptop And now when I turn on my laptop the blue screen error was shown : "System thread exception not handled(usbehci.Sys)" And Windows not start up !!! This error was shown when I try to use...
BSOD Crashes and Debugging
System Thread Exception Not Handled.
Okay so I have been having some blue screen issues. I have tried many troubleshooting solutions but I cannot seem to find out what is causing these issues and I need a hand. Minidump info included in link. Ran memtest today with 8 passes 0 Errors.
BSOD Crashes and Debugging
system thread exception not handled - iastorav.sys
Hi, After installing windows 10 from scratch due to problems after update from 8.1 I have the a/m error at start up. System shows the error and restarts and then everything is OK but I want to get rid of this. When I search the web I found that...
Drivers and Hardware
System Thread Exception Not Handled - Please help
I updated to Windows 10 last week from 8.1 on my Samsung laptop. The update went fine but the restart left me with the message "System THread Exception Not Handled". The only way to get my computer to reboot was to restore it to the original 8.1...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:36.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums