Windows 10: Kernel Auto Boost Lock Acquisition... on Restart, after AU update Solved

  1. Posts : 4
    Windows 10, AU 1607
       12 Oct 2016 #1

    Kernel Auto Boost Lock Acquisition... on Restart, after AU update

    On Restart, at the login screen, when entering the password, I get a sad face BSOD with
    Kernel Auto Boost Lock Acquisition with Raised IRQL.
    The crash occurs on entering the first 1 or 2 characters of the password, before enter.

    The problem persists, (repeats) after the crash restart until I do a shut down, usually on the login screen, before I enter a password.

    The problem does not show up with a Shut down, power on sequence, only when I do a restart.

    I have a dual boot environment (configured with the MS bcdedit boot manager), for Win8.1 and Win10. Win8.1 remains stable, so this is unlikely a hardware problem.

    The problem showed up immediately after the anniversary update (AU, version 1607) was installed. My Win10 was stable from July 2016 until 10/1/16 when AU installed.

    I've looked at drivers. Very few have timestamps newer than July 2015, i.e. they should already have been in place for AU. Only one has a roll back option and it's timestamp is 8/11/13.

    The problem is not completely repeatable.
    <5% of the times after a restart, I can login successfully
    <10% of the times after and crash and then shut down, it will still occur at the next login.
    Doing 2 consecutive shut downs fixes the double crash > 95%.
    I had to do 3 shutdowns once in the last 80 crashes to get stable again.
    <5% of the time I get a second crash during the restart from the first crash
    <.005% of active use I'll get a crash in the middle of a session. I think these occurred before I discovered the shutdown work around.

    I no longer have a restore available to backout the AU.

    I tried to gather the log files with dm_log_collector. It ran to the end but produced an empty zip file. Possible conflict with my BandiZip util. Will add the dumps later when I can get it to work.

    Thanks, Larry
      My ComputerSystem Spec

  2. Posts : 4
    Windows 10, AU 1607
    Thread Starter
       12 Oct 2016 #2

    Hand zipped the dump files..

    I did a quick browse of the dm_log_collector ytmp .bat file, found the TFdebugFiles folder and zipped the files here. See Attached.
      My ComputerSystem Spec

  3. Posts : 4
    Windows 10, AU 1607
    Thread Starter
       13 Oct 2016 #3

    Boot config file, LEDs stuck on

    Since the failure only occurs on restart, the boot sequence (timing) may be involved. Here's the bcdedit config file display. bcdedit /export file also attached.

    Annotations with #cmt; NC means NoChange since Win10 AU installed. I don't have a Win10 BCD dump from before the anniversary update. I don't know what may have changed with AU.

    Also occasionally after a shutdown, the machine doesn't fully shut down. It will be idle and quiet indefintely but these may get stuck, individually or in pairs:
    CPU LED is on, fan still runs in low power mode and the MoBo remains warm
    Hardrive LED busy, but quiet
    WiFi LED on
    When any of these is stuck on, the power button is non-responsive, except for a long press to force a power off. After the forced power off, at the next power on login, the BSOD may occur, maybe 50% of the time.

    ===bcdedit output===

    Microsoft Windows [Version 10.0.14393]
    Windows Boot Manager #9 /v
    identifier {bootmgr} #{9dea862c-5cdd-4e70-acc1-f32b344d4795} NC
    device partition=\Device\HarddiskVolume2
    path \EFI\Microsoft\Boot\bootmgfw.efi
    description Windows Boot Manager
    locale en-US
    inherit {globalsettings} #{7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e} NC
    badmemoryaccess Yes
    default {current} #{e8627976-52e7-11e6-835f-f81654c73a0c} NC
    resumeobject {e8627975-52e7-11e6-835f-f81654c73a0c} #NC
    displayorder {current} #{e8627976-52e7-11e6-835f-f81654c73a0c} NC
    {6a6a35a4-52d8-11e6-835f-f81654c73a0c} #NC
    toolsdisplayorder {memdiag}
    timeout 30

    Windows Boot Loader #9a
    identifier {current} #{e8627976-52e7-11e6-835f-f81654c73a0c} NC
    device partition=C:
    path \WINDOWS\system32\winload.efi
    description Windows 10
    locale en-US
    inherit {bootloadersettings} #{6efb52bf-1766-41db-a6b3-0ee5eff72bd7} N
    recoverysequence {e8627977-52e7-11e6-835f-f81654c73a0c} #NC
    recoveryenabled Yes
    badmemoryaccess Yes
    isolatedcontext Yes
    allowedinmemorysettings 0x15000075
    osdevice partition=C:
    systemroot \WINDOWS
    resumeobject {e8627975-52e7-11e6-835f-f81654c73a0c} #NC
    nx OptIn
    bootmenupolicy Standard

    Windows Boot Loader #9b
    identifier {6a6a35a4-52d8-11e6-835f-f81654c73a0c} #NC
    device partition=D:
    path \Windows\system32\winload.efi
    description MS Windows 8.1-D
    locale en-US
    inherit {bootloadersettings} #{6efb52bf-1766-41db-a6b3-0ee5eff72bd7} NC
    badmemoryaccess Yes
    isolatedcontext Yes
    allowedinmemorysettings 0x15000075
    osdevice partition=D:
    systemroot \Windows
    resumeobject {9ce757d6-52dd-11e6-835e-806e6f6e6963} #NC
    nx OptIn
    bootlog No
      My ComputerSystem Spec

  4. Posts : 4
    Windows 10, AU 1607
    Thread Starter
       17 Oct 2016 #4

    Fixed! In the boot config data (BCD) badmemoryaccess was Yes. Setting this to No, in both the bootmanager and the boot loader items fixed my problem. Reset now cycles thru without the 'Kernel Auto Boost Lock Aquisition with Raised IRQL' crash.

    As soon as I made this single change, reset became healthy. It's hard for me to believe my/a bad memory failure was coincident with the Win 10 AU update. I know this parameter was not set in Win8.1, I have no logs for Win 10 pre AU, but it's there in AU.

    A full dump shows it's now set in {badmemory} which is inherited by most items. I'm reluctant to turn it off in {badmemory} because of the wide impact (e.g. for memory diag), but this looks to be the root cause.

    Fixed from admin console with:
    bcdedit /set {current} badmemoryaccess "No"
    bcdedit /set {bootmgr} badmemoryaccess "No"

    Definitely not related to driver updates..

    much later.. Larry
      My ComputerSystem Spec


Related Threads
Hello, Recently I upgraded Windows to the new Anniversary Update. However, when I turn on Bass Boost in the Sound settings, there seems to be a weird crackling sound when playing a video, just as if my headphones are broken or can't play enough...
Hi there! Yesterday i did a clean reinstall of windows 10 and ever since I've been getting frequent restart crashes. I've got this system stable for almost a year now without any problems but since yesterday it's just one error after the other....
Screen won't auto-lock in User Accounts and Family Safety
Personalization Lock Screen Screen Time-out settings Screen: when plugged in, turn off after 5 minutes Sleep: When plugged in, pc goes to sleep after 10 minutes Require password on wake-up is checked. When left alone,...
After upgrading to Windows 10, I noticed that sleep is not working. I can hibernate with no issues, but sleep just doesn't work. It won't wake up and only shows a black screen with Power and Network Activity in the LED indicators. initially, I...
So, I was chatting with Microsoft about an issue with OneDrive, and all of a sudden my computer crashes. The error says "KERNEL AUTO BOOST LOCK WITH RAISED IRQL". I have included the dump log in this thread. Can someone please what tell me what...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:40.
Find Us