Windows 10: Debugging a hanging system with no memory dump

  1.    28 Sep 2016 #1

    Debugging a hanging system with no memory dump


    I'm having troubles with my Windows 10 laptop freezing when it comes out of sleep mode. I get the login screen and can move the mouse but I cannot click any buttons or type into the login box. The time also remains static and there are no entries for the time it was woken up in the event viewer.

    To try and debug what might be causing it to hang I tried forcing a system crash using CTRL + SCR LK. This worked, but unfortunately Windows wasn't able to create a memory dump - it remained at 0% indefinitely. I tried forcing a system crash in a normal state to check it wasn't an issue with my setup e.g. the paging file being disabled, and can confirm it was able to create a memory dump fine in this scenario.

    This means I'm am now stuck on what to try next. Does anyone have any suggestions?
      My ComputerSystem Spec

  2. axe0's Avatar
    Posts : 13,610
    Windows 10 Pro
       01 Oct 2016 #2

    Hi vzz,

    Welcome to the 10forums :)

    it remained at 0% indefinitely
    A possible indication towards the memory.

    Debugging a hanging system with no memory dump Diagnostic Test Debugging a hanging system with no memory dump

    Run MemTest86+ to analyse your RAM. MemTest86+ - Test RAM - Windows 10 Forums

    Note   Note

    MemTest86+ needs to be run for at least 8 complete passes for conclusive results. Set it running before you go to bed and leave it overnight. We're looking for zero errors here. Even a single error will indicate RAM failure.

    Make a photo of the result and post it.

    If errors show up you can stop the test, remove all sticks but 1 and test this single stick in each slot for 8 passes or until errors show, switch sticks and repeat.
    If errors show up and you see them a lot later, no problem, the errors don't affect the test.
      My ComputersSystem Spec

  3.    08 Oct 2016 #3

    Thanks, axe0. I ran memtest for 9 passes and it didn't detect any errors with the ram.

    Due to this, I thought I'd try debugging it remotely. I brought my work laptop home with me and set up WinDbg so that I could break into it from my work laptop over the LAN. I thought I'd test the setup before debugging the actual problem and this worked perfectly.

    Unfortunately my SSD didn't like being shut down incorrectly and I can no longer get Windows to boot (I get a lovely "No Bootable Device" error message). In the past when it's hung and I've had to cut power to the computer I've also seen this message, but usually it sorted itself out after 15 minutes (

    However, in this case, it's been days and I am still unable to boot from it. I booted from my Windows 10 rescue disk and noticed I could access my files fine, so the next thing I did was take an entire disk clone using DD. I tried runing a dskchk on the disk a couple of times, but this didn't fix the issue. So I then tried running the System File Checker on it, but that also did not help. Lastly, I've tried using the Bootrec commands found on [FIX] Windows 10 Master Boot Record Is Corrupted. However, when I run the last one (to rebuild the BCD) it finds the Windows installation but gives me "The requested system device cannot be found" on adding it to the boot list. I tried Googling for this and found: bcdedit - Problem recreating BCD on Windows 7 64bit - The requested system device cannot be found - Super User, but none of these worked for me.

    I'm going to try recreating the BCD manually following Fixing the Windows Bootloader via the setup DVD as the next step, and if that doesn't work I'm stummped.

    I could probably just format the drive and reinstall everything, but that's nowhere near as interesting. I also noticed if I booted into Linux and tried to mount the disk I got an error about Windows cache data still being present, which I can no longer replicate so I assume something I've done has fixed this. The drive is also bitlockered so wasn't expecting to get far with that anyway.
      My ComputerSystem Spec

  4. axe0's Avatar
    Posts : 13,610
    Windows 10 Pro
       08 Oct 2016 #4

    A question you should ask yourself before attempting the BCD fix, is the disk using GPT or MBR. If it is GPT then the BCD fix won't work, because it is meant for disks using MBR.

    To find this out, you need to have access to a command prompt from which you can run diskpart commands.

    Another question, is the disk present in the BIOS at the first position of the list?
      My ComputersSystem Spec

  5.    08 Oct 2016 #5

    Thanks for the tip; it looks like it is GPT.

    Something interesting that I've just found is in my new laptop, which is where it was originally, it cannot see the disk at all. If I boot from the Windows 10 rescue disk and go to the command prompt then it doesn't ask for my bitlocker key and if I use diskpart it just cannot see it. It's strange as my old laptop can. I don't think my old laptop has UEFI support so I'm wondering if it's something to do with that. I also tried reinstalling Windows 10 with the disk in my new laptop and nothing appears in the partition manager, yet on my old laptop it does. In the end I reinstalled Windows using my old laptop and that's working fine on that, but it still doesn't work in my new laptop. I'm wondering if the newer laptop has a hardware fault or if it's detecting an issue with the SSD and refusing to use it.

    I tried my Linux hard drive in my new laptop and that works fine. I'm going to try my work's hard drive (which is an SSD with Windows 10) and see if that works. If it does, I think I'll return the SSD as it's still under warranty.

    Edit: I can confirm that my work laptop's SSD works fine so I think I'm going to return the SSD as faulty.
    Last edited by vzz; 08 Oct 2016 at 09:03.
      My ComputerSystem Spec

  6. axe0's Avatar
    Posts : 13,610
    Windows 10 Pro
       08 Oct 2016 #6

    Good troubleshooting
      My ComputersSystem Spec

  7.    17 Oct 2016 #7

    OK, I'm back to cause trouble with my original problem. I've received my new SSD and I used DD to put the clone I took of the my old disk onto the new disk. As expected the problem with Windows hanging when resuming from sleep still persists. It also won't write a memory dump when I force a BSOD.

    Something I noticed from having the boot issues was that the problem wasn't there when I was using my cloned disk on my spare HDD. Does this suggest that the issue is with it being able to write to the disk when it wakes up? I'm assuming it can read fine as I get my lock screen when I wake it up.
      My ComputerSystem Spec

  8. axe0's Avatar
    Posts : 13,610
    Windows 10 Pro
       18 Oct 2016 #8

    Please clean install on your new SSD to make sure the new SSD isn't bad.
      My ComputersSystem Spec


Related Threads
Recently I've noticed that there's a lot less of free space on my C drive so I've decided to run a regular Disc Clean-up. When I ran it as an administrator I've noticed that "System error memory dump files" takes up around 32GBs which shocked me....
Help needed debugging crash dump file in BSOD Crashes and Debugging
I've been experiencing some random BSOD and freezes and managed to create crash dump files using driver verifier. Unfortunately I cannot read what driver is causing the BSOD's / freezes. Can someone please help me? Please ignore...
Need help Crash Dump Debugging in BSOD Crashes and Debugging
So my PC has been BSOD like crazy in windows 10. I have tried debugging using WinDbg, all crash dump errors point towards ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+1164c ) Please advice, what am I missing? I have attached the crash dump...
Hello, I have been fighting with my computer for about four weeks now, and I am not getting anywhere. In a nutshell, my computer started to randomly shut down and seldom reboot. There are no specific patterns I notice, except that when I try to...
First memory dump from Win10 in BSOD Crashes and Debugging
I generated this using NotMyFault with a High IRQL error..... 5429 EDIT: It appears that the Symbol Server hasn't uploaded the symbols for this build :(
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:11.
Find Us