1. Joined : Sep 2016
    Posts : 4
    Windows 10
       11 Sep 2016 #1

    Unusually unfixable BSOD preventing booting: Inaccessible Boot Device


    The problem: system worked well for many months until an insertion of a regular Lexar USB somehow caused a reboot, but unknown to me with the BIOS reset. SATA RAID had reverted to SATA AHCI and the boot locked up. On reboot I checked BIOS, found the change, and reset back to RAID. From then on, I have been plagued with a BSOD Ė Inaccessible Boot Device (BSODibd). The RAID 1 drive has 4 standard partitions, BIOS boot/MBR, and a dual boot BCD (Win 10/Win 7)

    I canít afford a complete re-install (would take weeks to customize and activate everything), and I have no idea when/whether this might happen again. So far Iíve spent ages discovering that no one seems to have a real handle on this error.

    What is not the problem or doesnít work:
    -not a disk signature collision (eg. boot with clone active) Ė all h38 BCD signatures match, and generalizing the BCD to {boot} doesnít work either
    -there are no hardware errors or partition errors and all data is accessible by WIN PEís.
    -Recovery USB command and other options donít work: startup repair (automatic or manual), SFC, standard Bootrec, BCDboot commands including /rebuildBCD still cause BSODibd
    -MBR repair does nothing since the MBR and boot recs check out fine, and I know the boot does access the BCD
    -Third party software like Easy Recovery Environment doesnít recognize the multi-partitions on the RAID and thinks itís a screwed up GPT so it was useless, as were Dual Boot Repair, Easy BCD and others which all claim success at what they do but still result in the BSODibd.

    What I just discovered does work to give me the multi-boot selection screen (even though it still leaves me high and dry with application installations and activations) is replacing just the Windows 10 registry hive (not the Windows 7 one) with an older version.

    What exactly could the boot process be referencing in the registry that could cause a BSODibd under these circumstances, does anyone know?
      My System SpecsSystem Spec

  2.    12 Sep 2016 #2

    It does sound like your drivers aren't loading (or something is trying to load that shouldn't). I suppose you tried automatic repair or can't you get that far? That replaced the old last good configuration option.

    You could also check (from winPE) HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services. In each service there is a flag called start. This has a value between 0 (load at boot) and 4 (disabled) https://support.microsoft.com/en-us/kb/103000

    I don't have raid so I don't know which ones to look at but I had a similar problem with booting a VHD native and had to update Start key in HKLM\System\CurrentControlSet\Services\Msahci to get it to boot when none of the repair options worked.

    You could also try (from PE) replacing the whole HKLM\System\CurrentControlSet\Services with one that works as that should keep your activations etc.
      My System SpecsSystem Spec


  3. Joined : Sep 2016
    Posts : 4
    Windows 10
       12 Sep 2016 #3

    Thanks 1x07, Yes automatic repair has run n times in the 97 reboot attempts I've gone through in trying to resolve this thing.

    I'll check out your registry idea tonight, and replacing the entire data for the key seems like a good place to start. Makes me wonder if I shouldn't try replacing the whole HKLM key. Good idea.

    Any idea why it going to load drivers for Win 10 (though it is the default) when I could decide to load Win 7 in this dual boot setting? I hadn't considered a registry issue for all this time because I was thinking too logically I guess.
      My System SpecsSystem Spec

  4.    12 Sep 2016 #4

    With regards to your last point I think in dual boot it partially (or mostly I don't know) loads the default OS. Once it is loaded (whether fully or partially) you get the screen to choose OS. If you pick the other one it starts again.

    I'm not sure where this cut-off is but in my system I have an initial boot loader called rEFInd which if called by the EFI firmware and runs before Windows loader. I have 10 as the default OS.

    When I boot it goes rEFInd > Windows 10 starts to load > Windows 10 OS choice screen. If I pick 10 the log on screen is almost immediate.

    If I chose another OS (for example 7) it goes like this:

    rEFInd > Windows 10 starts to load > Windows 10 OS choice screen (then I pick 7) > booting restarts > rEFInd > Windows 7 loads (with no OS choice this time).

    That is only my experience though... If you updated the BCD to make 7 default it may then boot 7 using the 7 drivers. I've not tried it though and as I don't know how it really works technically I'm not sure it would work.
      My System SpecsSystem Spec


  5. Joined : Sep 2016
    Posts : 4
    Windows 10
       12 Sep 2016 #5

    Makes sense, unless the boot process is really as voodoo-like as it seems to be becoming. Can't get to the registry test yet, just managed to blow the power supply (maybe the eight disks I've got hanging off this thing now have something to do with it). I'll let you know when I get to try them, but I have hope now that it's fixable. Thanks again for taking the time and for the idea.
      My System SpecsSystem Spec


  6. Joined : Sep 2016
    Posts : 4
    Windows 10
       13 Sep 2016 #6

    I got the system to boot finally after replacing the HKLM\System\CurrentControlSet\Services key as was suggested by 1x07!

    I've got residual problems with missing drivers due to the time difference in the saved VS current registry values, and that has left some logic controllers non-functioning, and my network hobbling, but those are at least visible and fixable.

    It's great to have a sharing and knowledgeable community willing to help, and thanks to you 1x07 who had the singular insight about the default registry that I and so many others hadn't considered.
      My System SpecsSystem Spec

  7.    14 Sep 2016 #7

    That is really good news. Make another thread if you get stuck on updating your drivers but presumably you're only doing what you've done before.

    Best make a system image once it is all working just in case. Before plugging in that Lexar USB again anyway
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Solved Inaccessible usb3 boot device
Been working on this for weeks to no avail. I have Win 7 on on ssd and Win 10 on another ssd. I am not dual booting but switch to the drive I need in the bios. Using Casper 8.0, I clone the Win 7 and Win 10 to backup internal ssds. These internal...
Drivers and Hardware
Inaccessible Boot Device
Sir, I had upgraded my Acer Aspire Laptop (CORE i5 - 4GB RAM) from Windows 8.1 to Windows 10 recently. As it was running very slow, I decided to do a 'clean reset'. By mistake, the recovery partition also cleaned. It then went to a blue screen...
Installation and Setup
Inaccessible Boot Device, cant get to BIOS or boot from media
Soo... things have gone from bad to worse. My problem started after windows 10 updated when I shut down my laptop for a quick restart. Windows explorer would crash every second, reopen, then crash again without stopping. I tried a system restore...
BSOD Crashes and Debugging
Inaccessible Boot Device
I ran into a problem this evening with my laptop, Lenovo B575. The laptop kept restarting because of inaccessible boot_device. I am not sure how to fix this problem. I know it's too new for everyone with Windows 10. Mine is Windows 10 64X Home...
General Support
Warning: iMac BOOTCAMP - Clean Install - BSOD Inaccessible Boot device
My Son has an iMac on which he was running Windows 7 Pro via bootcamp. He wanted a clean install of Windows 10 Pro ... Installed the upgrade all went well. Made sure Windows was activated. Grabbed keys using Magic Jelly (now know this was...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:03.
Find Us
Twitter Facebook Google+



Windows 10 Forums