Atikmdag.sys causing huge problems during startup Solved

Page 1 of 3 123 LastLast
  1.    21 Jul 2016 #1

    Atikmdag.sys causing huge problems during startup


    about 2 weeks ago I upgraded my very good running Win 7 Ultimate to Windows 10. First it worked good but than the problems started.

    The system froze all of a sudden. OK - reset and go on but it got worse. I could not even start the computer any more because it froze during loading autostart software.

    Finally I found out that my ATI Graphic Board 260x or better the driver is causing the problem. When I started the computer in Safe Mode and uninstalled the driver I could start the computer normally and without problems. For uninstalling I used the Software AMD said you should use.

    But with the standard driver from MS I couldn't play games of course. It was just ok for office work.....

    So I tried a lot of things but with driver, doesn't matter which one I tried, it did not work.

    I finally found out that I do not have this file in my windows directory and copied it from windows.old to try what it will cause. And now the computer at least booted but took a few minutes. Strange

    So after a loot of search in the internet I decided to buy a new Graphic board. AMD seems to have a huge problems with Windows 10 and this problem (see the Forum there) and they have no solution.

    I tried a lot of other things too but no luck.

    Now the computer is booting but still needs several minutes after startup (why do I have a SSD :)). But than it works. After a few hours I get an error that Microsoft isn't working and than I can just close Browser for example but everything with Windows, e.g. start button, does not work anymore -> reset.........

    Still the problem seems to bee the same file: Atikmdag.sys

    I read also that other hardware/software/drivers may need it but which one? Do I have them? Why is it loading if I do not have/need it? How can I solve this problem?

    Because I need my computer also for work I am really interested in finding a solution without a new installation which will cause many days of work to get everything back to normal.

    Thanks a lot in advance!!
      My ComputerSystem Spec

  2. axe0's Avatar
    Posts : 13,878
    Windows 10 Pro
       21 Jul 2016 #2

    Please check ASUS for BIOS updates.

    Please remove / disable items from the startup in taskmanager
    These programs could interfere with the boot process giving you trouble and increase the boot time.

    Daemon tools, Alcohol 120% and Power Archiver Pro uses SCSI Pass Through Direct (SPTD), which is a well known cause for BSOD's.
    Please remove Daemon Tools and run the SPTD pass through remover.

    1. Uninstall Daemon Tools
    2. Download the SPTD standalone installer and follow these steps:
      • Double click the executable to open it
      • Click on the button shown below

    If the button is grayed out, like in the image, there is no more SPTD installation on your system, and you can close the window

    warning   Warning
    Programs that claim to update your drivers install either the wrong or corrupted drivers.
    If you have installed any driver with Driver Booster 3, please remove them as it may cause trouble.

    An easy way to get remove these drivers is by using a restore point prior the installation.

    Please uninstall this program and revert back the changes it made using a restore point or another system backup
    Start Menu\Programs\WinThruster	Public:Start Menu\Programs\WinThruster	Public
    Please uninstall ASUS software, it is known for causing BSODs

    Please fill in your system specs
    Please follow this tutorial and download the tool. The tool will give you detailed information about your system specs, please fill in your system specs more completely including PSU, cooling and other used stuff like mouse, keyboard, monitor, case, etc.
    The PSU, cooling and other stuff are NOT mentioned in the tool.
    How to fill in your system specs:

      My ComputersSystem Spec

  3.    21 Jul 2016 #3


    Thanks a lot!

    1. ASUS Bios Update: I already did but no more updates at the moment
    2. WinThruster: already uninstalled and never used!
    3. Daemon Tool lite: I uninstalled it a few minutes ago

    As soon as I can reboot I will check how it works and go on with your hints and post it here.

    Again: THANKS!
      My ComputerSystem Spec

  4.    21 Jul 2016 #4


    1. SPTD: no driver detected
    2. AI Suite II is uninstalled (ASUS)
    3. I changed some things in Autostart - not yet all "off" to test, just some do not start any more

    As soon as I restart the system I will give another feedback and will go on with your suggestions.

      My ComputerSystem Spec

  5. axe0's Avatar
    Posts : 13,878
    Windows 10 Pro
       21 Jul 2016 #5

    Thanks for keeping me updated :)
      My ComputersSystem Spec

  6.    25 Jul 2016 #6

    OK, sorry for the delay!

    I uploaded the details a few minutes ago on SevenForums (same NickName).

    But what is "PSU" please :) ?

    It is different meanwhile, but still the same problem: It takes 1-5 minutes for booting but somehow different. Today I had big problems to enter the system! Before it felt "better". It is also freezing after a few hours. Browsers etc. are still working, but if you want to open a new software e.g. it does not work anymore -> Reset (to press New Start does not work any more).

    Just in case, I also uploaded the new log-files here.

    Thanks a lot!!
      My ComputerSystem Spec

  7. axe0's Avatar
    Posts : 13,878
    Windows 10 Pro
       25 Jul 2016 #7

    PSU = Power Supply Unit, the part that provides the power to your system.

    Could you please remove DB3, if it already is uninstalled check the Program Files folders to delete the folder.

    I uploaded the details a few minutes ago on SevenForums (same NickName).
    What site exactly? I cannot find your name back on the Windows 7 Help Forums

    Your ASMedia sata controller drivers seem to be causing all the crashes of today.
    Please check ASUS for driver updates or reinstall the drivers.
    Child-SP          RetAddr           : Args to Child                                                           : Call Site
    ffffd000`2546f398 fffff800`fcb6c4e9 : 00000000`0000003b 00000000`c0000005 fffff801`0421e064 ffffd000`2546fc80 : nt!KeBugCheckEx
    ffffd000`2546f3a0 fffff800`fcb6bdfc : ffffd000`2546f5f0 fffff800`fcb5de6a fffff800`fccb7c20 ffffd000`25470468 : nt!KiBugCheckDispatch+0x69
    ffffd000`2546f4e0 fffff800`fcb679ed : fffff800`fcd4f000 fffff800`fca1f000 0004c644`007ca000 ffffd000`2546fb20 : nt!KiSystemServiceHandler+0x7c
    ffffd000`2546f520 fffff800`fca89469 : 00000000`00000003 00000000`00000056 ffffd000`2546fb20 00000000`00000003 : nt!RtlpExecuteHandlerForException+0xd
    ffffd000`2546f550 fffff800`fcb10ffc : ffffd000`25470468 ffffd000`25470180 ffffd000`25470468 ffffb002`00000001 : nt!RtlDispatchException+0x429
    ffffd000`2546fc50 fffff800`fcb6c5c2 : ffffe001`c6241080 fffff800`fcc27755 00000000`00000169 00000000`00000001 : nt!KiDispatchException+0x144
    ffffd000`25470330 fffff800`fcb6aca1 : ffffd000`25470620 ffffe001`00000000 ffffe001`c6241001 fffff800`00000000 : nt!KiExceptionDispatch+0xc2
    ffffd000`25470510 fffff801`0421e064 : ffffe001`bea7d670 ffffe001`00000000 00000000`0000016d 00000000`00000001 : nt!KiPageFault+0x221 (TrapFrame @ ffffd000`25470510)
    ffffd000`254706a0 ffffe001`bea7d670 : ffffe001`00000000 00000000`0000016d 00000000`00000001 ffffe001`c4005790 : asmtxhci+0x1e064
    ffffd000`254706a8 ffffe001`00000000 : 00000000`0000016d 00000000`00000001 ffffe001`c4005790 fffff801`049690d0 : 0xffffe001`bea7d670
    ffffd000`254706b0 00000000`0000016d : 00000000`00000001 ffffe001`c4005790 fffff801`049690d0 ffffe001`c10db100 : 0xffffe001`00000000
    ffffd000`254706b8 00000000`00000001 : ffffe001`c4005790 fffff801`049690d0 ffffe001`c10db100 00000000`00000001 : 0x16d
    ffffd000`254706c0 ffffe001`c4005790 : fffff801`049690d0 ffffe001`c10db100 00000000`00000001 00000000`00000000 : 0x1
    ffffd000`254706c8 fffff801`049690d0 : ffffe001`c10db100 00000000`00000001 00000000`00000000 00000000`00000000 : 0xffffe001`c4005790
    ffffd000`254706d0 ffffe001`c10db100 : 00000000`00000001 00000000`00000000 00000000`00000000 00000000`00000000 : asmthub3+0x90d0
    ffffd000`254706d8 00000000`00000001 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`c0000910 : 0xffffe001`c10db100
    ffffd000`254706e0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`c0000910 ffffe001`c0613020 : 0x1
    Bugcheck code 0000003B
    Arguments 00000000`c0000005 fffff801`0421e064 ffffd000`2546fc80 00000000`00000000
    Debug session time: Mon Jul 25 13:17:16.708 2016 (UTC + 2:00)
    System Uptime: 0 days 0:15:15.403
    0: kd> lmvm asmthub3
    Browse full module list
    start             end                 module name
    fffff801`04960000 fffff801`04985000   asmthub3 T (no symbols)           
        Loaded symbol image file: asmthub3.sys
        Image path: asmthub3.sys
        Image name: asmthub3.sys
        Browse all global symbols  functions  data
        Timestamp:        Mon Jun 24 19:16:39 2013 (51C87EF7)
        CheckSum:         00023D78
        ImageSize:        00025000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    0: kd> lmvm asmtxhci
    Browse full module list
    start             end                 module name
    fffff801`04200000 fffff801`0426d000   asmtxhci T (no symbols)           
        Loaded symbol image file: asmtxhci.sys
        Image path: asmtxhci.sys
        Image name: asmtxhci.sys
        Browse all global symbols  functions  data
        Timestamp:        Thu Sep 10 11:38:13 2015 (55F14F85)
        CheckSum:         0007A74F
        ImageSize:        0006D000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
      My ComputersSystem Spec

  8.    25 Jul 2016 #8


    Do you have access to: Monelix's Seven Forums Profile ?

    I can not find a folder "db3" in "Programme", "ProgramData" or "Programme (x86). And I do have no clue what db3 could be. I will check this out. Does it belong to TeamMedia Portal? Just an idea....

    The ASUS driver I will check now!!!

      My ComputerSystem Spec

  9. axe0's Avatar
    Posts : 13,878
    Windows 10 Pro
       25 Jul 2016 #9

    I have access to your profile, but I probably couldn't find it because your profile indicates zero posts.

    DB3 is Driver Booster 3
      My ComputersSystem Spec

  10.    25 Jul 2016 #10

    Because ASUS is not offering a driver for Win 10 64-bit for sata controller, I am choosing the driver for Win 8.1 64-bit.

    Hope that is ok.......

    Attachment 92065

    Driver right now:

    Attachment 92066
      My ComputerSystem Spec

Page 1 of 3 123 LastLast

Related Threads
build 14366 HUGE problems... in Windows Insider
i can not role back and i can not open the start menu or the settings. can someone help me with that?
100% DISK usage causing slow system startup in Performance & Maintenance
For the last week or so my system has been very slow to startup, and during this time the disk shows at 100% usage. It takes at least 5-10 minutes until everything has loaded and disk usage returns to normal and the system is usable. I have...
Not sure what is going on. Not a huge deal because once it is booted up things are snappy. Only reason I am worried about it mostly is if it is a sign of something else bad. My 10 Installation on my WD Black drive became corrupted. My backup...
I just flashed my GPU BIOS using ATIWinflash and when I restarted the PC I got the blue screen of death with the error SYSTEM_SERVICE_EXCEPTION atikmdag.sys. I have the latest AMD Catalyst 15.7.1 drivers installed. I am now in the safe mode and I...
Mpc-hc causing problems...9879 in Software and Apps
Seems that mpc-hc causes issues on the task bar, and the start menu. Anyone else..??
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:58.
Find Us