Page 1 of 4 123 ... LastLast
  1.    13 Apr 2015 #1

    Debugging Tools for Windows 10 Question


    Shouldn't Windbg work with any dump file, even if its for 10? OR is this Windbg only going to work with 10. What am I doing wrong?

    (BTW, this is a dump from a Windows 7 machine I'm trying to open)

    I get this error:
      My System SpecsSystem Spec


  2. Joined : Oct 2014
    Posts : 230
    10
       14 Apr 2015 #2

    Yes it should work.

    First try this link: https://www.osronline.com/page.cfm?name=analyze
    This'll let you upload and perform a quck analysis on a memory dump file - which will tell you if the memory dump is corrupt or not.

    Then, if it isn't corrupt, the next step would be to uninstall the Debugging Tools and then install a freshly downloaded copy (in case of corruption).

    BUT, from looking closer at the error message, it appears that you're trying to run the dump file out of a ZIP archive. That's not supported in WinDbg. Extract the .dmp file to your Desktop and try to run it from there.

    Also, try opening up WinDbg and using the File menu to open up the extracted memory dump (the one inside the ZIP archive shouldn't open there either).

    Finally (this is sorta bass-ackwards on my part), is the question - What version of Debugging Tools are you using?
    Is it the newly released version for Win10? Please remember that that version is still "beta" software.

    Good luck!
      My System SpecsSystem Spec

  3.    14 Apr 2015 #3

    Thanks John, yes its the newly released 10.0 something WinDbg. I downloaded it with Windows SDK. When I was on my 8.1 machine they would always open the same way I am trying now so I'll have to see how I have it setup. Seems as though I've always clicked the link on the thread and opened the first dump and it always worked.

    Thanks for the link and info, I'll have a look at it now.
      My System SpecsSystem Spec

  4.    14 Apr 2015 #4

    Tried to extract to a folder in my documents and into documents itself, I got this error.

    Update: I tried opening it up manually and it works. Wonder why it won't work from simply opening the file as opposed to navigating to the file from within WinDBG?
      My System SpecsSystem Spec

  5.    14 Apr 2015 #5

    I always open dumps from a zipped archive, just easier that way for me. I've never had problems doing that.
      My System SpecsSystem Spec

  6.    14 Apr 2015 #6

    derekimo said: View Post
    I always open dumps from a zipped archive, just easier that way for me. I've never had problems doing that.
    I thought this were the case but I usually default to Johns wisdom.
      My System SpecsSystem Spec

  7.    14 Apr 2015 #7

    I'm not questioning his wisdom, just stating what I do.
      My System SpecsSystem Spec

  8.    14 Apr 2015 #8

    Oh I didn't mean he is right. I was just saying I thought I always did it out of a zipped archive as well but since he said it was not supported I just figured maybe I was mistaken. I also manually opened it out of a zipped folder which worked.
      My System SpecsSystem Spec

  9.    14 Apr 2015 #9

    It may not be supported like he says, but it does work. I never extract the zip archive, I just work out of it and then only have one item to delete.

    Anyway, back to your original problem now, I didn't intend to derail the thread.
      My System SpecsSystem Spec

  10.    14 Apr 2015 #10

    Its no problem at all Derek. Your input is always welcome.

    As for the problem, I think it was because I didn't set up ALL of the associations. I only had dmp files. I set all file associations like you're supposed to and viola.. It works.

    Thanks to both for the suggestions.
      My System SpecsSystem Spec


 
Page 1 of 4 123 ... LastLast


Similar Threads
Thread Forum
WinDBG - The Basics for Debugging Crash Dumps in Windows 10
WinDBG - The Basics for Debugging Crash Dumps in Windows 10 WinDBG (Windows DeBuGger) is an analytic tool used for analysing and debugging Windows crash dumps, also known as BSODs (Blue Screens of Death). It is part of the Windows Developer Kit...
Tutorials
Announcing latest improvements for F12 developer tools in Windows 10
Source: Announcing the latest improvements for the F12 developer tools in Windows 10 | Microsoft Edge Dev Blog
Windows 10 News
Windows 10 Developer Tools released
Still installing on my VM - takes forever!!! Had to create a new VM as the old VM's hard drive wasn't big enough. Had to install Visual Studio 2015 CTP6 before installing the tools Also, the update to 10046 didn't load at first, so I had to...
Windows 10 News
Updates for F12 developer tools in Windows 10 build 9926
Source: Updates for the F12 developer tools in the Windows 10 January Technical Preview - IEBlog - Site Home - MSDN Blogs
Windows 10 News
Windows 10 Preview: Prepare 7 or 8.1 with official tools
Read more... See also: Prepare your PC to get Windows Technical Preview
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:53.
Find Us
Twitter Facebook Google+



Windows 10 Forums