Page 1 of 2 12 LastLast
  1.    10 May 2016 #1
    Join Date : Apr 2015
    Posts : 12
    Windows 10

    Edimax EW-7822PIC Bluescreen


    Hey, so I've bought a new wireless adapter. Edimax EW-7822PIC.
    When I installed the drivers, after reboot my win10 crashes. BSOD (WHEA_Uncorrrectable_error).
    When I uninstall the drivers, everything works but I dont have internet xD

    I have tried everything. Official drivers from CD, latest from the edimax website, installing in normal mode, in secure mode, trough device manager, trough installer... nothing. It always crashes.
    Whats interesting - system boots, I have a moment to log in. It looks like it detects wifi networks. But few seconds later - Bluescreen.

    Can anyone help me? Im trying to fix this for 2 days now.
      My ComputerSystem Spec
  2.    11 May 2016 #2
    Join Date : Apr 2015
    Posts : 12
    Windows 10
    Thread Starter

    I've also unplugged and plugged the card to PCIe slot. Still the same.
      My ComputerSystem Spec
  3.    11 May 2016 #3
    Join Date : May 2015
    Central IL
    Posts : 4,254
    Mac OS Sierra

    The adapter is faulty, is why you are getting the error. Send it back and get a Rosewill adapter.
      My ComputerSystem Spec
  4.    11 May 2016 #4
    Join Date : Apr 2015
    Posts : 12
    Windows 10
    Thread Starter

    OK, will try. It really might be damaged...
      My ComputerSystem Spec
  5.    11 May 2016 #5
    Join Date : May 2015
    Central IL
    Posts : 4,254
    Mac OS Sierra

    Not so much the adapter is faulty, sounds like the drivers do not like your machine.
      My ComputerSystem Spec
  6.    11 May 2016 #6
    Join Date : May 2015
    Central IL
    Posts : 4,254
    Mac OS Sierra

    You might be able to get away with one of thr PCIe cards that accepts the mini-PCIe wireless cards like the Intel 726x dual band series.

    What are the spec's on your machine? Was it a clean install or upgrade over a previous Windows install?
      My ComputerSystem Spec
  7.    11 May 2016 #7
    Join Date : May 2015
    Central IL
    Posts : 4,254
    Mac OS Sierra

    I was in the middle of a three day project with getting a Raspberry Pi 2 set up for a FreeRadius server, is why my previous post was pretty short.

    The debugging was getting to me.
      My ComputerSystem Spec
  8.    11 May 2016 #8
    Join Date : May 2015
    Central IL
    Posts : 4,254
    Mac OS Sierra

    Looks like you are not alone on issues with this card. Appears that some have been having issues since Windows 8.
      My ComputerSystem Spec
  9.    11 May 2016 #9
    Join Date : Apr 2015
    Posts : 12
    Windows 10
    Thread Starter

    Yeah, I know. Maybe Edimax Tech Support will help me if there are lots of problems with this adapter on Windows 8 and 10. I've asked the seller if I he can replace it with NetGear A6210-100PES. It's USB and should be enough for me ;d And the rosewill adapter seems not to be available anywhere in my coutry so cant talk with seller about replacing + paying some more for the Rosewill one.

    Im not going to pay for anything more since I spent over 2k bucks for components where everything is wrong xD Seriously, thats my 3rd issue with PC I bought... 2 weeks ago. I thoguht everything is fixed... And now this.

    My system specs are on the forum.

    And yes, I have clean-installed the system. I have even tried reinstalling it after those issues but it didnt help.
    Last edited by hultongetty; 11 May 2016 at 10:10.
      My ComputerSystem Spec
  10.    11 May 2016 #10
    Join Date : Apr 2015
    Posts : 12
    Windows 10
    Thread Starter

    You think I should send it back immediately or wait for Edimax Support reply? It takes at least 2 days for them for one reply ;/

    Nevermind. Sending the card back.
    Last edited by hultongetty; 11 May 2016 at 12:52.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved nvlddmkm.sys Bluescreen / Windows 10
Hello, sorry, i have no Bug Report yet cause i downgraded back to Win7 at the moment. The Problem i have/ had is: After upgrade Win7 -> Win10 i get after 5-10 Minutes latest a Bluescreen caused by: nvlddmkm.sys
BSOD Crashes and Debugging
Bluescreen on Windows 10
Hello, I am experiencing BSODs for quite some time and I would appreciate your assistance. Currently I don't have many ideas about the cause and I will update the title of the post when I know more. Please find attached my log files. ...
BSOD Crashes and Debugging
win32kfull.sys bluescreen
On Sat 4/16/2016 5:25:09 AM GMT your computer crashed crash dump file: C:\WINDOWS\Minidump\041616-8109-01.dmp This was probably caused by the following module: win32kfull.sys (win32kfull!SetRedirectedWindow+0x15F) Bugcheck code: 0x3B...
BSOD Crashes and Debugging
Bluescreen after waking from sleep
Never had a bsod occur on this machine. If anyone could provide me details on determining the cause of the situation, it'd be gladly appreciated :party: attached is the debug zip folder If there's somewhere where I can upload the memory.dmp or...
BSOD Crashes and Debugging
BlueScreen
Getting random blue screens i can't seem to find the solution its not hardware as i have tested them and i think it is software based.
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:50.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums