dual boot win7/win10 wont boot to win7 anymore +BSOD "memory managemen  

  1. Posts : 3
    windows 10, windows 7

    dual boot win7/win10 wont boot to win7 anymore +BSOD "memory managemen

    My pc specs * asus z97-p motherboard * intel i7 4790 cpu * bequiet 630w psu * 8gig corsair vengeance ram * samsung 850evo 250gig ssd (win 7pro 64bit drive) * sandisk ultra II ssd 128gig ssd (win 10 drive) * 2x crucial 500gig bx100 ssd (data drives)

    i recently rebuilt this into a new case and it had been working fine. Mainly using the win 7 os but more recently using the win 10 os more and more. The way it has been working is that win7 is the default boot and I have to hit the delete key on startup to select win10 to boot from.

    today I was on win 10 but needed to reboot to 7. Upon doing so I hit this message:

    Secure Boot Violation The system found unauthorized changes on the firmware, operating system or UEFI drivers.

    It then gave me the option to boot to win10 as it is the next boot option on the list. Win 10 is now giving me the blue screen "memory management error" although I have been able to get into win10 after some more rebooting.

    I ran SFC scanner and it told me that there were some problems that it cannot fix.

    Everything is unplugged apart from mouse, keyboard hdmi to screen and ethernet cable. Unplugging the win10 drive from the mobo and switching the win7 drive to another port has not helped.

    Has my ssd failed? has win 10 done an update that has caused this problem? It did update today, in fact the first error message I got was after win10 shut down, and when I booted into it again it installed some updates before launching.
    thanks for any help!

      My Computer

  2. Arc
    Posts : 1,626
    Microsoft Windows 10 Home

    Hi @vinvanda.

    As far as I can understand from your post that you had W7 and W10 as dual boot in two different disks.

    From the uploaded data we could not find a hint of the BSOD that you said (it is not recorded anywhere, probably because it happened during boot); but some other statements are supported by the data.
    Windows failed fast startup with error status 0xC00000D4.
    Now, it is STATUS_NOT_SAME_DEVICE; reads as .... "The destination file of a rename request is located on a different device than the source of the rename request".

    Now I am making a guess. It it is wrong, please rectify and state the proper situation.
    You name the Windows 7 Disk as "system" and the Windows 10 disk as "Win 10". You also said that windows 7 is the default boot. So I am guessing that the boot files are in the the windows 7 disk.

    The board is set as Legacy BIOS. So Fast Boot is not possible here; and if Fast Startup is enabled, windows7 needs to disk check in every startup. It is desirable to keep fast startup disabled on a computer with W7.

    Now Coming to the "Secure Boot Violation". Windows 7 does not support it at all. And, it is the Firmware Validation Process of UEFI; whereas your system is set to Legacy. I think here lies the issue.
    BIOS Mode Legacy
    Disable UEFI and Secure boot> Hopefully Windows 7 will boot back.

    If it does not, remove the windows 10 disk and run Startup Repair to Windows 7, for three times, with restarts after every instance. Windows 7 will boot back again.

    Now remove the Windows 7 boot entry.

    Next, attach the Windows 10 disk back and remove the windows 7 disk. Run Startup Repair foe Windows 10.

    Now you have two different OSs in two different disks. No possible of any further conflict, just remember to not enable Secure Boot in BIOS.

    The computer will boot to the first boot device by default. To choose which OS you want to boot from, use the "Boot Menu" key of the motherboard. For ASUS, it is F8 key. It will list up all possible disks to boot from. Choose which one you want.
      My Computer

  3. Posts : 3
    windows 10, windows 7
    Thread Starter

    thank you for the reply. I will try this tomorrow. It seems like windows 10 changed something with an update that may have caused this problem. Here is a reply I got from someone on Reddit who also had this problem since the newest update https://www.reddit.com/r/techsupport..._win7_anymore/

    I just got this error today too.I've been looking into it for well over an hour. Two people started threads about it in the last 24 hours:
    1. [Translated Here] Says to check out Howtogeek.com
    2. [Translated Here] Loosely says that Windows 10 might have installed a new Windows Boot Manager fitted for Windows 10 and not Windows 7, thus corrupting the whole BCD Store.
    I'm still troubleshooting, but at the moment, here is what I've tried:

    • Disabling CSM Trough BIOS, since BIOS won't let me disable Secure Boot directly. - Did Not Work
      • I thought maybe Secure Boot was an issue with UEFI. Perhaps setting the CSM to "disable" would ensure a Legacy Boot. (Which I didn't expect anything to happen since I set my drives up with GPT instead of MBR.)

    • Running Windows 7 RE from the Windows 7 PE [Installation CD]. - Surprisingly, this Did Not Work

    • Since I can't get to the RE troubleshooting tools, I had to use the command prompt by hitting Shift+F10. I'm now somewhat in progress to finding the issue.

    At this point, I think it's pretty clear. It's the second week of the month, the time when Microsoft sends out updates. Apparently though, which I'm assuming, they are pushing these "Free Windows 10" Upgrades on Windows 7 OS. People were saying that this upgrade would upgrade (or at least download to my knowledge) to their system without prior knowledge or consent.
    In other words, I believe Microsoft gave anyone running UEFI + GPT Windows 7 Users the shaft and installed a Windows 10 BCDStore or some updated Windows Boot Manager overtop the Windows 7 Windows Boot Manager, thus creating corruptions. If anyone backed up their BOOTMGR file, they should feel lucky as this mightbe an easy fix.
    Let me read my text book and I'll get back on my thoughts. I'm a bit rusty on terms and notes at the moment.
    EDIT: Found out that the BOOTMGR file resides in the the special 100-MB System Partition. No way to back that up without intentionally going in there with software.
    In my case I might need to load the harddrives on a different computer, backup, and move on to this shitty Windows 10 so that this doesn't happen again. Microshaft kept signalling a download for Windows 10 all this time anyways. They forcefully broke my system.
      My Computer

  4. Arc
    Posts : 1,626
    Microsoft Windows 10 Home

    May be it is due to an update. I am always on UEFI+GPT, so I havent had any issue with any updates. I've stopped using Windows 7 long ago, when 10 was just a preview. It satisfies all my needs.

    Let us know the results of your experiments.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:55.
Find Us

Windows 10 Forums