1.    22 Mar 2016 #1
    Join Date : Mar 2016
    Posts : 6
    Windows 10

    BSOD Whenever I run Backup & Restore (ntfs.sys page_fault_in_nonpaged)


    Running Windows 10, Full specs are in profile.

    I get the BSOD: "PAGE_FAULT_IN_NONPAGED_AREA"

    Who crashed tells me it was triggered by: ntfs.sys (NTFS!NtfsCommonWrite+0xB40)

    This happens randomly, but i can trigger it by running backup & restore and trying to create an image of C: Drive

    I have tried new ram (after googling) but the BSOD is still there.

    I have attached my dmp file, but i am really at a loss here. iv'e been trying for a few weeks. (it's important that i have a daily image of C: drive)

    I haven't installed any new software. it used to happen once every 2 months, which i could live with, now it's everyday.
      My ComputerSystem Spec
  2.    22 Mar 2016 #2
    Join Date : Sep 2015
    Hellsinki
    Posts : 383
    Windows 10 Home

    Hello TheBuz and welcome to 10forums!

    Please right click on Windows key on the taskbar -> Command Prompt(Admin) -> chkdsk /r /f

    Also I would recommend that you download from Corsair, SSD Toolbox, you can find it under the downloads tab:
    Force 60gb

    Cheers, Boris
      My ComputerSystem Spec
  3.    22 Mar 2016 #3
    Join Date : Mar 2016
    Posts : 6
    Windows 10
    Thread Starter

    Quote Originally Posted by BorisTheAnimal View Post
    Hello TheBuz and welcome to 10forums!

    Please right click on Windows key on the taskbar -> Command Prompt(Admin) -> chkdsk /r /f

    Also I would recommend that you download from Corsair, SSD Toolbox, you can find it under the downloads tab:
    Force 60gb

    Cheers, Boris
    Hi Boris

    I have just tried chkdsk /r /f i also updated my SSD firmware, and no had no luck i ran "backup & restore" again and got the same BSOD
    (i already had SSD Toolbox installed)

    EDIT: added crash dump
      My ComputerSystem Spec
  4.    22 Mar 2016 #4
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,369
    Windows 10 Pro X64 16299.19

    All 3 of the dumps indicate memory_corruption.

    Please follow this tutorial to run memtest86+ to checkout your system ram.

    MemTest86+ - Test RAM - Windows 10 Forums

    Information


    MemTest86+
    is a diagnostic tool designed to test Random Access Memory (RAM) for faults. MemTest86+ will verify that:

    • RAM will accept and keep random patterns of data sent to it
    • There are no errors when different parts of memory try to interact
    • There are no conflicts between memory addresses


    Memtest86+ runs from bootable media to isolate the RAM from the system, no other components are taken into account during the test.



    Warning
    MemTest86+ needs to run for at least 8 passes to be anywhere near conclusive, anything less will not give a complete analysis of the RAM.

    If you are asked to run MemTest86+ by a Ten Forums member make sure you run the full 8 passes for conclusive results. If you run less than 8 passes you will be asked to run it again.


    Note
    MemTest86+ has been known to discover errors in RAM in later passes than the eighth pass. This is for information only; if you feel there is a definite problem with the RAM and 8 passes have shown no errors feel free to continue for longer.

    Running 8 passes of MemTest86+ is a long and drawn out exercise and the more RAM you have the longer it will take. It's recommended to run MemTest86+ just before you go to bed and leave it overnight.
      My ComputersSystem Spec
  5.    23 Mar 2016 #5
    Join Date : Mar 2016
    Posts : 6
    Windows 10
    Thread Starter

    Hi ztruker,

    I have tried 12 passes of memtest, and swapping out the RAM with RAM from my other pc with no change.

    I have also just done a full clean reinstall of windows 10 and the problem is stll there :-(
      My ComputerSystem Spec
  6.    23 Mar 2016 #6
    Join Date : Sep 2015
    Hellsinki
    Posts : 383
    Windows 10 Home

    Hello Buz.

    I've noticed that your motherboard is running on an older BIOS version, it might solve the problem by updating it.

    ASRock Z97 Extreme 6 Download BIOS

    How to update BIOS ASRock

    Cheers, Boris
      My ComputerSystem Spec
  7.    23 Mar 2016 #7
    Join Date : Mar 2016
    Posts : 6
    Windows 10
    Thread Starter

    Hi i have updated the bios, and still no change, using 3rd party backup software, which uses the same windows services (VSS, Shadow copy ect.) has no BSOD.

      My ComputerSystem Spec
  8.    23 Mar 2016 #8
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,369
    Windows 10 Pro X64 16299.19

    You have a lot of stuff starting at boot that I don't recognize or could be disabled:

    Code:
    Caption                                       Command                                                                                                                                                       User                          
    CouchPotato                                   CouchPotato.lnk                                                                                                                                               MediaServer-PC\Media Server   
    Deluge                                        Deluge.lnk                                                                                                                                                    MediaServer-PC\Media Server   
    SABnzbd                                       SABnzbd.lnk                                                                                                                                                   MediaServer-PC\Media Server   
    Sonarr                                        Sonarr.lnk                                                                                                                                                    MediaServer-PC\Media Server   
    Private Internet Access                       "C:\Program Files\pia_manager\pia_manager.exe" --startup                                                                                                      MediaServer-PC\Media Server   
    Viscosity                                     C:\Program Files\Viscosity\Viscosity.exe                                                                                                                      MediaServer-PC\Media Server   
    uTorrent                                      "C:\Users\Media Server\AppData\Roaming\uTorrent\uTorrent.exe"  /MINIMIZED                                                                                     MediaServer-PC\Media Server   
    NoIPDUCv4                                     "C:\Program Files (x86)\No-IP\DUC40.exe" /minimize                                                                                                            MediaServer-PC\Media Server   
    Plex Media Server                             "C:\Program Files (x86)\Plex\Plex Media Server\Plex Media Server.exe"                                                                                         MediaServer-PC\Media Server   
    Belvedere                                     C:\PROGRA~2\BELVED~1\BELVED~1.EXE                                                                                                                             Public                        
    Remote Launcher Server                        C:\PROGRA~2\REMOTE~1\REMOTE~1.JAR                                                                                                                             Public                        
    XFast LAN                                     C:\Program Files\ASRock\XFast LAN\cFosSpeed.exe                                                                                                               Public                        
    StableBit DrivePool Notifications             C:\Program Files\StableBit\DrivePool\DrivePool.Notifications.exe                                                                                              Public
    Try doing a Clean Boot and test for awhile, see if the problem goes away. If so then follow the instructions on how to isolate the cause of the problem.

    Clean Boot - Perform in Windows 10 to Troubleshoot Software Conflicts - Windows 10 Forums
      My ComputersSystem Spec
  9.    23 Mar 2016 #9
    Join Date : Mar 2016
    Posts : 6
    Windows 10
    Thread Starter

    I would like to thank everyone for all the time they have put into helping me, it really is appreciated.

    This machine i am using as our media server and back up machine, and I'm going to take the cowards way out, as i want to minimise downtime.

    I have a feeling its a software issue as i can run the backup once with no issues, but it will blue screen on the 2nd backup.

    Im going to fresh install Windows 10 again and split plex and my download programmes into 2 separate VMs and run the system that way. It might also help to isolate the issue, although i might run the VMs in linux.

    So it much easier to restore if there's a problem.

    I have a nightly c drive image backup in case the ssd dies (which would have been an easier problem to fix)

    Thanks again for everyones help
    Last edited by TheBuz; 23 Mar 2016 at 22:52. Reason: Spelling
      My ComputerSystem Spec
  10.    25 Mar 2016 #10
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,369
    Windows 10 Pro X64 16299.19

    Please let us know how you make out after splitting the VMs.
      My ComputersSystem Spec

 


Similar Threads
Thread Forum
BSOD'S System Service Exception. win32kfull.sys/win32kbase,sys/ntfs.sy
Well Here I am again. Built a brand new PC and windows 10 hates me again. I am getting BSODs in game. On Wed 3/16/2016 4:29:44 AM GMT your computer crashed crash dump file: C:\WINDOWS\Minidump\031516-9203-01.dmp This was probably caused by...
BSOD Crashes and Debugging
Solved Need to restore files to Win 10 from Win 7 backup-is this possible?
My folder is: MediaID.bin It has all my documents, photos, etc. from a PC that I converted to Win 10 and gave a family member. But I can't seem to get the file to open on my own Win 10 Pro laptop. Is there a program, command or process that...
Backup and Restore
BSOD caused by NTFS.sys & ntoskrnl.exe on a brand new PC.
There's not much to explain as it can occur randomly, I am guessing it is some driver conflict but I am not tech savvy, regardless, the BSODs are caused by NTFS.sys and ntoskrnl.exe. Here's an image from BlueScreenView 40292
BSOD Crashes and Debugging
Backup and Restore not working
I am using pre rtm build with all updates installed. I can't get backup and restore to complete a system image. It fails with message about failure in preparing the backup. Does it work for anyone?
Backup and Restore
Backup and Restore (Windows7)
I have used Backup and Restore (Windows 7) since Win 7. It is still in Control Panel but it doesn't work. It worked up until I installed 10240. If I access settings, backup it is listed as an alternative to file history but it still basically...
Backup and Restore
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:56.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums