1. Joined : Jan 2016
    Posts : 6
    10
       14 Jan 2016 #1

    Modified using Regedit; can't access programs/change back


    [I tried to download the file as requesting the in the BSOD Posting Instructions, but I can't due to the problem below.]

    I was trying to download/install a program, but did not have enough space in my C drive. As the download/installation was automatic, I could not directly select for the installation to occur where I wanted, my D drive (a memory card). So, I used regedit and modified ProgramFilesDir, ProgramFilesDir (x86), and ProgramW6432Dir to D:\Programs, D:\Program Files (x86), and D:\Program Files. I did not create these folders in the D drive prior to doing this.

    Now I still cannot download the program I wanted and cannot open files for the program. Worse, I cannot access regedit, task manager, system restore, or other such 'crucial' things as an administrator. Using my other (non-administrator) account, I can access regedit and task manager. In task manager, under the 'Users' tab (this is in 10), the status of my administrator account is listed as 'disconnected.' When I log into my administrator account, things run slowly, and if I try to open regedit, taskmanager, or CCleaner it does nothing for around 5 minutes, then there is an error pop-up claiming something along the lines of 'There are no files.' I suspect that if I just redirect back to C:\ Program Files and C:\Program Files (x86), this might be fixed. But without access to regedit as an administrator, I can't do that. Help would be appreciated.

    Thanks.
      My System SpecsSystem Spec

  2.    14 Jan 2016 #2

    I suppose you can't just right click and run regedit as administrator from your standard account? If should prompt you for your administrator account password.

    If that doesn't work can you open an elevated cmd prompt from your standard user account? Right click, run as administrator again...

    If you can then you could enable the built in administrator account with net user administrator /active:yes and then sign on as that.
      My System SpecsSystem Spec


  3. Joined : Jan 2016
    Posts : 6
    10
       14 Jan 2016 #3

    Thanks for the reply. I can't run anything as administrator. Although I can log into my administrator account. While there I can't even open up task manager or regedit or cmd, much less change anything there. I've tried right clicking. I know that it normally causes that pop-up where I enter my admin password, but now it doesn't do even that.
      My System SpecsSystem Spec

  4.    14 Jan 2016 #4

    What about enabling built in administrator at boot time? Option 4 here Administrator account - Enable or Disable in Windows 10 - Windows 10 Forums
      My System SpecsSystem Spec


  5. Joined : Jan 2016
    Posts : 6
    10
       14 Jan 2016 #5

    I just tried what you suggested. However, I cannot select 'Load Hive' in regedit--it's grayed out. I do not have a backup recovery USB, disc. I got 10 by updating from 8 and never made a recovery disc/flash drive. I've tried to make system restore points in the past, but haven't been able to--I assumed it was because most of the space on my harddrive is used up. I'm a bit ashamed to admit this, but it's the case. So I tried just entering the command prompt using Settings, Troubleshoot, etc. As stated, at least using this way I cannot get past the 'Load Hive' instruction. Out of curiosity, I looked at the ProgramFilesDir part. Instead of C or D, it says X; I'm assuming this is what it should be saying?
      My System SpecsSystem Spec


  6. Joined : Jan 2016
    Posts : 6
    10
       14 Jan 2016 #6

    Would resetting my computer solve the problem? At this stage, I'm willing to accept the inconvenience it might cause, although I'm wondering if I'll lose the programs that came with the computer.
      My System SpecsSystem Spec

  7.    15 Jan 2016 #7

    tsmith said: View Post
    I cannot select 'Load Hive' in regedit--it's grayed out.
    You could download a Windows PE recovery disk written by one of your members @Kyhi from here Windows 10 Recovery Tools - Bootable Rescue Disk - Windows 10 Forums

    You can boot from that and then you should have authority to load the hive. It is correct to have X as the drive when you boot into this environment but as described in the tutorial above you want to load the hive from your Windows installation (may be C or D and not necessarily the same letter as in Windows). What you don't want to do is just change the registry of the PE image (as that wouldn't do anything to Windows) - that is why you need to load the hive.

    If you reset, as you have upgraded from 8 I think it would delete the programs the computer came with though (you'll definitely lose all of you files). You need to be administrator to reset anyway as far as I know.

    At least with PE rescue disk you can back up any documents you want and worst case have to do clean install. Do try enabling the built in administrator from PE first though - or even resetting program files using regedit from PE - that should work.

    EDIT: I am just having to change registry on offline image and I remembered this quote of yours.

    tsmith said: View Post
    I cannot select 'Load Hive' in regedit--it's grayed out.
    There are 2 reasons. Either you aren't authorized, the second is you haven't highlighted anything.

    If you want to load a hive you must select HKEY_LOCAL_MACHINE (or HKEY_USERS but you don't want that). Only after you do that does the load hive option appear in the file menu. If you just open regedit and Computer is highlighted then load hive option is greyed out..
    Last edited by lx07; 15 Jan 2016 at 07:09. Reason: Another thought...
      My System SpecsSystem Spec


  8. Joined : Jan 2016
    Posts : 6
    10
       15 Jan 2016 #8

    Thanks for staying with me here. I didn't select HKEY_LOCAL_MACHINE prior to trying to load hive. When I did do that, I was able to get to the point where I enter 'REM_SAM,' but then I get a pop-up message stating that the file can't be loaded due to "The process cannot access the file because it is being used by another process."

    Maybe similarly, I also tried using command prompt to run sfc /scannow, but get a claim that it's in the middle of a repair process and to reboot the computer and try sfc again. When I do that, I just get the same message, and cannot run scannow.
      My System SpecsSystem Spec


  9. Joined : Jan 2016
    Posts : 6
    10
       17 Jan 2016 #9

    I ended up just resetting the computer, getting the administrator level by using Settings, Recovery, Troubleshooting, Restart, Reset. I'm going to count this as solved, but if some future user experiences the same problem, and doesn't have this option, sorry.
      My System SpecsSystem Spec

  10.    17 Jan 2016 #10

    Glad you got it sorted anyway
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Randomly cannot type in to programs until alt tab and back
Hi, Having a problem. What seems random, although I not it does not seem to happen mid sentence, is that I try to type, for example in an address bar, or FB chat, or any other place (I think), and no text appears, I can change the cursors active...
General Support
Programs that require administrator access
I have a program (game) that I wish to allow a child to run but it requires administrator access to run the program. I don't particularly want to be required to walk over and type in the password every time the child wants to run the game, but I...
User Accounts and Family Safety
Launching exe file change its modified date
I have upgraded to Win 10 and getting used to it little by little. There is something new which I find quite annoying. Whenever I launch an exe file, the modified date is changed to the present date/time. Is there a way to disable that like in all...
Software and Apps
Can't access all programs and documents in both user and adm account.
Hi, Is there a setting that will allow me to access all documents and and apps in both user account and administrator account? I can not find one!
User Accounts and Family Safety
Does anyone know if we can change "All Apps" back to "All Programs"?
I really don't like the term "All Apps" on the new Start menu. I would like to put it back to "All Programs". Does anyone have any idea if this can be changed? I don't use "apps". I'm not a mobile device user; I have a custom-built tower and I...
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:47.
Find Us
Twitter Facebook Google+



Windows 10 Forums