Page 1 of 2 12 LastLast
  1.    12 Dec 2015 #1
    Join Date : Oct 2015
    Posts : 24
    Windows 10 professional

    Hard lockups without error messages, (Update: dxgkrnl.sys)


    Lately I have been getting hard lock ups on my desktop. I had no real software or hardware changes but I did notice the crashing was only happening during GTA 5. The locks up would never have an actual BSOD or error message just a hard freeze requiring me to restart or the system would restart itself.

    Now it started happening even without running GTA 5. My cpu temps were a bit high (98 was the max) with GTA 5 so I thought that was the issue, but when idling + my hyper 212 evo, I get 30 deg temps and still crashed.

    Interestingly I also crashed when using the dmp application to make the mini dump I uploaded for you guys to analyze.

    Please help me out. Thanks so much.
    Last edited by Smodtactical; 13 Dec 2015 at 14:42.
      My ComputerSystem Spec
  2.    13 Dec 2015 #2
    Join Date : Oct 2015
    Posts : 24
    Windows 10 professional
    Thread Starter

    So I figured out how to analyze the mini dumps and it seems the 2 things that are failing is one is the cpu itself, I get problems with 'genuineintel'. But also dxgkrnl.sys

    From my research this might point to a bad motherboard. But am trying to get mem test to work to at least test the ram.
      My ComputerSystem Spec
  3.    15 Dec 2015 #3
    Join Date : Oct 2015
    Posts : 24
    Windows 10 professional
    Thread Starter

    Just wanted to say that I disabled SLI and I haven't tried to game with 1 card but with SLI off so far I had no crashes. So maybe this is the video card. Ran memtest for a few hours, no errors, but ill do a longer run soon.

    I would appreciate any input.
      My ComputerSystem Spec
  4.    15 Dec 2015 #4
    Join Date : Jun 2015
    Posts : 12,960
    Windows 10 Pro

    GenuineIntel doesn't mean anything more then that your CPU is from Intel.
    The 0x124 doesn't give much as usual, but the CPU always returns in a 0x124 because it is the component reporting the error.

    Regarding the dxgkrnl.sys in the 0x3B, it is the DirectX Graphics Kernel driver what points to the graphics drivers from the GPU.
    However, the graphics drivers from the GPU aren't flagged, but the Avast drivers.
    Code:
    ffffd000`214a1608  fffff801`47b8b914Unable to load image aswSP.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for aswSP.sys
    *** ERROR: Module load completed but symbols could not be loaded for aswSP.sys
     aswSP+0x3b914
    ffffd000`214a1c18  fffff801`47a91472Unable to load image aswSnx.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for aswSnx.sys
    *** ERROR: Module load completed but symbols could not be loaded for aswSnx.sys
     aswSnx+0x81472
    I suggest to uninstall Avast while troubleshooting
    Avast - Uninstall Completely - Windows 7 Help Forums

    Revert back any overclock while troubleshooting if there is any.
    Code:
    CPUID:        "Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz"
    MaxSpeed:     3500
    CurrentSpeed: 3506
    Bugcheck code 00000124
      My ComputersSystem Spec
  5.    16 Dec 2015 #5
    Join Date : Oct 2015
    Posts : 24
    Windows 10 professional
    Thread Starter

    Thanks so much for the insight Axe0! I have uninstalled Avast and will keep testing.

    I should note that I disabled SLI and since doing so and running this pc for several days I have not crashed at all. I have not yet tried a game though.
      My ComputerSystem Spec
  6.    16 Dec 2015 #6
    Join Date : Jun 2015
    Posts : 12,960
    Windows 10 Pro

    Keep me posted

    If any bluescreen occurs, please upload a new zip from the dm log collector and give some description of what happened and what you were doing.
    Describing the circumstances helps with finding a patern in the crashes and makes it easier to find the causes and/or find a solution.
      My ComputersSystem Spec
  7.    16 Dec 2015 #7
    Join Date : Oct 2015
    Posts : 24
    Windows 10 professional
    Thread Starter

    Will do man thanks so much. I am going to do a manual clean reinstall of my nvidia drivers too just to see if that makes a difference.
      My ComputerSystem Spec
  8.    18 Dec 2015 #8
    Join Date : Oct 2015
    Posts : 24
    Windows 10 professional
    Thread Starter

    Ok so just a brief summary of what I have done:
    1. Ran memtest for 8 passes, it gave me 0 errors.
    2. Disabled SLI 3 days ago (since doing this I have completely stopped crashing) but I didn't try to game yet
    3. Ordered a Corsair H105, will install this weekend.
    4. Uninstalled AVAST recently
    5. Did a very clean safe mode reinstall of nvidia drivers
    I turned SLI back on, did some basic pc stuff for a few hours, no crashes. Launched a game and instant hard lockup before the game even went into the menu. Uploaded a new crash dump to check out.

    Looked at the crash dump and it shows the same dxgkrnl.sys crash. Here is the analysis (file also uploaded)

    Code:
    ********************************************************************************                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    
    SYSTEM_SERVICE_EXCEPTION (3b)
    An exception happened while executing a system service routine.
    Arguments:
    Arg1: 00000000c0000005, Exception code that caused the bugcheck
    Arg2: fffff801b101673e, Address of the instruction which caused the bugcheck
    Arg3: ffffd00024198f80, Address of the context record for the exception that caused the bugcheck
    Arg4: 0000000000000000, zero.
    
    
    Debugging Details:
    ------------------
    
    
    
    
    SYSTEM_SKU:  All
    
    
    SYSTEM_VERSION:  System Version
    
    
    BIOS_DATE:  07/01/2013
    
    
    BASEBOARD_PRODUCT:  MAXIMUS VI HERO
    
    
    BASEBOARD_VERSION:  Rev 1.xx
    
    
    DUMP_FILE_ATTRIBUTES: 0x8
      Kernel Generated Triage Dump
    
    
    BUGCHECK_P1: c0000005
    
    
    BUGCHECK_P2: fffff801b101673e
    
    
    BUGCHECK_P3: ffffd00024198f80
    
    
    BUGCHECK_P4: 0
    
    
    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%p referenced memory at 0x%p. The memory could not be %s.
    
    
    FAULTING_IP: 
    dxgkrnl!DxgkMiracastQueryMiracastSupportInternal+8a
    fffff801`b101673e 488b88b8070000  mov     rcx,qword ptr [rax+7B8h]
    
    
    CONTEXT:  ffffd00024198f80 -- (.cxr 0xffffd00024198f80)
    rax=20bfef4f20bfef40 rbx=0000000000000000 rcx=ffffd00024199930
    rdx=0000000000000000 rsi=0000000000000001 rdi=ffffe001751349c0
    rip=fffff801b101673e rsp=ffffd000241999a0 rbp=ffffd00024199b00
     r8=ffffc000766495e0  r9=00000000000007ff r10=fffff801545e1560
    r11=ffffd00024199970 r12=000000007ffdb000 r13=0000000000000000
    r14=000000000019a100 r15=ffffd00024199ae0
    iopl=0         nv up ei pl nz na pe nc
    cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00210202
    dxgkrnl!DxgkMiracastQueryMiracastSupportInternal+0x8a:
    fffff801`b101673e 488b88b8070000  mov     rcx,qword ptr [rax+7B8h] ds:002b:20bfef4f`20bff6f8=????????????????
    Resetting default scope
    
    
    CPU_COUNT: 8
    
    
    CPU_MHZ: db2
    
    
    CPU_VENDOR:  GenuineIntel
    
    
    CPU_FAMILY: 6
    
    
    CPU_MODEL: 3c
    
    
    CPU_STEPPING: 3
    
    
    CUSTOMER_CRASH_COUNT:  1
    
    
    DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT
    
    
    BUGCHECK_STR:  0x3B
    
    
    PROCESS_NAME:  FarCry2.exe
    
    
    CURRENT_IRQL:  0
    
    
    ANALYSIS_VERSION: 10.0.10240.9 amd64fre
    
    
    LAST_CONTROL_TRANSFER:  from fffff801b101669f to fffff801b101673e
    
    
    STACK_TEXT:  
    ffffd000`241999a0 fffff801`b101669f : 00000000`0019a168 ffffd000`24199b00 ffffd000`00000001 00000000`00000000 : dxgkrnl!DxgkMiracastQueryMiracastSupportInternal+0x8a
    ffffd000`24199ac0 fffff801`543d5b63 : ffffe001`7df6d840 00000000`00000000 ffffe001`00000000 ffffe001`77843410 : dxgkrnl!DxgkNetDispQueryMiracastDisplayDeviceSupport+0x1f
    ffffd000`24199b00 00000000`761a520a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
    00000000`0009e6e8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x761a520a
    
    
    
    
    FOLLOWUP_IP: 
    dxgkrnl!DxgkMiracastQueryMiracastSupportInternal+8a
    fffff801`b101673e 488b88b8070000  mov     rcx,qword ptr [rax+7B8h]
    
    
    SYMBOL_STACK_INDEX:  0
    
    
    SYMBOL_NAME:  dxgkrnl!DxgkMiracastQueryMiracastSupportInternal+8a
    
    
    FOLLOWUP_NAME:  MachineOwner
    
    
    MODULE_NAME: dxgkrnl
    
    
    IMAGE_NAME:  dxgkrnl.sys
    
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  55fa5392
    
    
    IMAGE_VERSION:  10.0.10240.16515
    
    
    STACK_COMMAND:  .cxr 0xffffd00024198f80 ; kb
    
    
    BUCKET_ID_FUNC_OFFSET:  8a
    
    
    FAILURE_BUCKET_ID:  0x3B_dxgkrnl!DxgkMiracastQueryMiracastSupportInternal
    
    
    BUCKET_ID:  0x3B_dxgkrnl!DxgkMiracastQueryMiracastSupportInternal
    
    
    PRIMARY_PROBLEM_CLASS:  0x3B_dxgkrnl!DxgkMiracastQueryMiracastSupportInternal
    
    
    ANALYSIS_SOURCE:  KM
    
    
    FAILURE_ID_HASH_STRING:  km:0x3b_dxgkrnl!dxgkmiracastquerymiracastsupportinternal
    
    
    FAILURE_ID_HASH:  {41141022-8e90-ade9-81f9-df09b03573c3}
    
    
    Followup:     MachineOwner
    ---------
    Is it possible this is a hardware failure? Is there anyway to reinstall direct x in windows 10?
      My ComputerSystem Spec
  9.    18 Dec 2015 #9
    Join Date : Oct 2015
    Posts : 24
    Windows 10 professional
    Thread Starter

    Ok just disabled SLI again and was able to play far cry 2 with no problems at all. Played for about an hour. I also read in another thread a similar situation of someone with very similar crash dump code and resolution of the problem when disabling SLI. I am not going to try to run the game with the GPU I didn't use when I disabled SLI to see if maybe that is a bad card.
      My ComputerSystem Spec
  10.    18 Dec 2015 #10
    Join Date : Jun 2015
    Posts : 12,960
    Windows 10 Pro

    If you reinstall Windows you reinstall the DirectX drivers.
    The DirectX drivers are Windows drivers
    Driver Reference Table - dxgkrnl.sys
    Driver Reference Table - dxgmms1.sys

    Please fill in your system specs
    Please follow this tutorial and download the tool. The tool will give you detailed information about your system specs, please fill in your system specs more completely.
    How to fill in your system specs:

      My ComputersSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Hard lock, loud noise crash while playing games.
Hello I've been experiencing the same crash repeatedly now, while playing any game(it's happened so far in Rainbow Six Siege, Fallout 4 and Just Cause 3) my screen will randomly lock up and there's always a loud EEEEEEEEEEEEE sound until I shut...
Performance & Maintenance
Error Messages when opening Word
I'm hoping someone can point me to a way to eliminate the error messages below when my neighbor opens Word, Excel or Powerpoint. Background: I helped a neighbor upgrade from Windows 7 to Windows 10. All went well and there were no problems. They...
Software and Apps
External 1TB hard drive(Iomega - seagate inside) RAW drive - HELP
I recently upgraded to Windows 10 and post that It was working fine without any issues. I have two external drive connected to it. 1. 1 TB Iomega powered drive. - now RAW 2. 2TB seagate external drive. The 1tb drive suddenly became RAW and I...
Drivers and Hardware
Windows 10 fails upgrade, error logs inside.
I've tried everything I can possibly try and have gotten nowhere. Gets to 18-22% and fails. "Windows 10 installation has failed" I swear M$ hires the most retarded monkeys, gerbils, and street rats to code this crap. I've ran tweaking.com's...
General Support
Who writes Microsoft's error messages?
Who writes Microsoft's error messages? Homer Simpson? "Something happened" Well, duh!
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:46.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums