Windows 10: Wireless Network Driver Uninstall BSOD Solved

  1.    26 Nov 2015 #1

    Wireless Network Driver Uninstall BSOD

    Alright, so a bit of history here. This laptop started having BSOD issues after taking the free update to Windows 10. It was apparently due to network drivers so I had attempted to update a few of them, and thought the problem had gone away. I was wrong. I had the laptop plugged in via network cable, and am now learning the problems appear to have to do with the wireless network drivers. I didn't realize this until now as I generally use the laptop when I'm away from home, and haven't had a need for it until now.


    It started off with Driver Verifier's scans causing a blue screen, DRIVER_VERIFIER_DECTECTED_VIOLATION. Opening that, it was flagging ntoskrnl.exe, nwifi.sys, and I believe tcpip.sys. To prevent the laptop from hitting a BSOD I reset Driver Verifier's settings so it wouldn't run any scans, then went to work. (That should be the first three minidumps in the included attachment.)

    I didn't have the Windows Debugging tools installed at the time, so I was using a program called "BlueScreenView" to dig into what could be an issue. I saw nwifi.sys in there, the NativeWiFi Miniport Driver. Alright, my WiFi drivers are Bigfoot Killer Wireless-N 1103 drivers. I saw that they're from 2011 (odd, WIndows says they're fully updated) so I check the website. I find drivers from 2013 with a higher version number, perfect. Searching for and downloading these drivers took some time, as the laptop would periodically BSOD with IRQL_UNEXPECTED_VALUE. (That would be the fourth and fifth minidumps.)

    So here's where I hit the main issue. I did get the drivers. They require me to uninstall the previous Killer Network Manager suite in order to install the new version. Attempting to uninstall the previous suite version causes yet another BSOD, MEMORY_MANAGEMENT (the last three minidumps), which is where I am now. I have Windows Debugging tools installed now, and it's flagging "Ak27x64.sys" as the potential reason. Go figure, that's the wireless driver that's being uninstalled.

    If I uninstall the driver manually through the Device Manager, it works just fine. However, the Killer Network Manager suite is determined to reinstall the driver before uninstalling the entire suite.

    I could extract the driver from the installation archive (it has an option for that) and install it myself. However, I'm worried that the error itself means something worse than the uninstaller tripping over the driver. I'll probably attempt a Memtest in the near future, but hopefully someone here has ideas!

    Ran a standard memtest, came back clean. That makes me think the un/installer was the issue, but maybe someone will see something else?
    Last edited by UltimateZero; 26 Nov 2015 at 16:42.
      My ComputerSystem Spec

  2. axe0's Avatar
    Posts : 13,720
    Windows 10 Pro
       26 Nov 2015 #2

    What memtest have you performed exactly? The built-in feature?
    What website have you checked exactly for updating drivers?

    *** WARNING: Unable to verify timestamp for bflwfx64.sys
    *** ERROR: Module load completed but symbols could not be loaded for bflwfx64.sys
    *** WARNING: Unable to verify timestamp for Ak27x64.sys
    *** ERROR: Module load completed but symbols could not be loaded for Ak27x64.sys
    4: kd> lmvm bflwfx64
    start             end                 module name
    fffff800`79380000 fffff800`794d7000   bflwfx64 T (no symbols)           
        Loaded symbol image file: bflwfx64.sys
        Image path: \SystemRoot\system32\DRIVERS\bflwfx64.sys
        Image name: bflwfx64.sys
        Timestamp:        Tue Feb 14 20:28:54 2012 (4F3AB5F6)
        CheckSum:         0001A6A6
        ImageSize:        00157000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    4: kd> lmvm Ak27x64
    start             end                 module name
    fffff800`7a600000 fffff800`7a8a2000   Ak27x64    (deferred)             
        Image path: \SystemRoot\System32\drivers\Ak27x64.sys
        Image name: Ak27x64.sys
        Timestamp:        Wed Dec 07 18:13:57 2011 (4EDF9ED5)
        CheckSum:         002AB75A
        ImageSize:        002A2000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
      My ComputersSystem Spec

  3.    26 Nov 2015 #3

    Yes, used the built in Windows 10 memtest, on the Standard setting.

    Qualcomm Killer Wireless N1202/N1103 Driver Driver Details | Dell US

    Downloaded the drivers from this page here, and installed them manually instead of using the installer that was giving me so much trouble. They're intended for the next model of laptop up from what I'm using, but the network card is the same, and they haven't been giving me any troubles yet. The "Ak27x64.sys" driver was replaced with "Akw8x64.sys". "Bflwfx64.sys" is also related to the bigfoot network drivers, but unlike the first driver, I haven't been able to find it in my device manager or any specific way of updating it by itself, so I assume it has to do with the function of the KIller Network Manager program itself rather than specifically the wireless function.

    I haven't had any new BSODs yet thankfully (and I am on the wireless again), but the MEMORY_MANAGEMENT one has me worried.

    EDIT: As an aside, Dell has stopped support of this hardware with Windows 10, so the Windows 8 drivers are likely as close as I'm going to get. The "Ak27x64.sys" driver to my best knowledge was a leftover driver from Windows 7, which I was using before the free upgrade to 10.

    Product Support | Dell US

    That's the support page for this model.
      My ComputerSystem Spec

  4. axe0's Avatar
    Posts : 13,720
    Windows 10 Pro
       26 Nov 2015 #4

    1 thing that is wrong, installing drivers from other sites then your manufacturers.
    With laptops, the manufacturer alter the drivers so you are forced to only use their drivers. Other drivers won't work properly.
    I recommend to check your manufacturers site, Alienware, for drivers.

    A 2nd thing, I would recommend to run MemTest86+ to test the memory.
    MemTest86+ is much better then the memory diagnostics test from Windows self.

    Wireless Network Driver Uninstall BSOD Diagnostic Test Wireless Network Driver Uninstall BSOD

    Run MemTest86+ to analyse your RAM. MemTest86+ - Test RAM - Windows 10 Forums

    Note   Note

    MemTest86+ needs to be run for at least 8 passes for conclusive results. Set it running before you go to bed and leave it overnight. We're looking for zero errors here. Even a single error will indicate RAM failure.
      My ComputersSystem Spec

  5.    26 Nov 2015 #5

    Alienware is owned by Dell, and the Support -> Drivers & Downloads link on the Alienware page send you to Dell support.
    Attachment 50676

    Now would be a good time to run Memtest86 I suppose. About to start some heavy cooking, so that'll give it time to do its thing. Thank you, I'll see what it tells me.
      My ComputerSystem Spec

  6. axe0's Avatar
    Posts : 13,720
    Windows 10 Pro
       26 Nov 2015 #6

    My bad about the site

    As it looks like, as you say, they have indeed stopped support for your laptop.
    Unfortunately, my guess would be that the solution is to revert back the OS.
      My ComputersSystem Spec

  7.    26 Nov 2015 #7

    It happens, no worries. :P I was surprised myself when it redirected me during the initial search. Wasn't expecting that!

    So I came back to check the memtest86 run, and it looks like it had restarted the laptop on its own. I assumed from a quick read around that it would just continue to test until I told it to stop? I had gone through the settings to see what was adjustable, then left it on default and let it do its thing.

    Ok, so I tried a second memtest86 run. This one I was trying to keep an eye on, and it seemed like it went for a longer period of time, then I walked into the room again just a couple minutes go to see it had restarted the laptop once more. I'm not sure what to make of that.

    Regardless, I'll keep your suggestion in mind. So far I haven't had any BSODs (and they were rapid before I replaced that driver, usually within a couple minutes of startup), so I'm going to keep going with Windows 10 for now and see if that really was the issue. If it happens again, I have a USB with a bootable Windows 7 install on stand-by.

    Thank you for the help! Very much appreciated.
    Last edited by UltimateZero; 26 Nov 2015 at 19:20.
      My ComputerSystem Spec


Related Threads
Hey Guys, ~Per a moderator's request, I have created a new thread. I had initially commented this post in another thread. ~ I did a bare metal install of Windows 10 on a Dell E7250 (touch). While docked at work, no issues at all. As soon I...
Hello everyone. My notebook would not complete installation of Windows 10 due to athwbx.sys problem. BSOD. This is a driver file found in Windows 8 for the Atheros Wireless Network hardware. However I am updating from Windows 7 and this file is...
There's a red x on my wifi icon in the tray and i cant connect to the internet. Im told i need to redownload a driver but I cant find any Windows 10 driver for it. My model name is: ar9485wb-eg I have an asus netbook. The one with no capslock...
BSOD - Network Driver issue in BSOD Crashes and Debugging
I began getting a bunch of blue screens ever since I started a new job and need to use a certain vpn: Dell SonicWall Global VPN client. The crashes usually point to swipesec.sys, which is the clients drivers, but I will get occasional blue screens...
Wireless network driver not working in Drivers and Hardware
Hi I just installed windows 10 from windows 7 and now my internet doesn't work. The rest of the computers in the house are working. Error message: "There might be a problem with the driver for the wireless network connection adapter or the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:12.
Find Us