1. Joined : Sep 2015
    Posts : 70
    Windows 10 Home 64 Bit
       16 Sep 2015 #1

    BSOD When Not Using Internet Explorer (AMD Catalyst 15.7.1 Drivers)


    Hi,

    I am having an extremely strange bug where If I try to use other browsers such as Firefox, Chrome or even Edge. It will either cause "Display Driver Stopped Responding and has recovered" or a BSOD. Chrome will cause these errors no matter what I am doing, Firefox will only cause these errors on certain pages (Pages with lots of images) and internet explorer doesn't seem to cause any of these issues.

    My PC specs are on my profile if you need them. If you need any logs/dump files uploading then let me know.

    A lot of people seem to be having BSOD issues with 15.7.1 but most of them have seemingly been able to work them out but I have had this issue for 3 weeks and haven't found a fix yet.

    Here is a screenshot of the BSOD I get (always seem message)

    Attachment 37847

    I would try downloading older drivers but they don't support windows 10 and so I am stuck using 15.7.1
      My System SpecsSystem Spec


  2. Joined : Jun 2015
    Posts : 10,908
    Windows 10 Pro / Windows 10 TP / Windows 8.1 Pro / Windows 7 Pro
       16 Sep 2015 #2

    Hi UnknownAK,

    It has no use to open a new thread for the same problem.

    The current drivers are also not 100% supporting windows 10, try an older version and see the results.
    Please make first a restore point, backup of important files and rescue media.
      My System SpecsSystem Spec


  3. Joined : Sep 2015
    Posts : 70
    Windows 10 Home 64 Bit
       16 Sep 2015 #3

    I made a new thread because other people may have had this issue and this is a lot more specific than my other thread which was just about BSODs in general.

    Also drivers pre 15.7.1 aren't windows 10 supported so I don't understand how I could use them without them causing more issues?
      My System SpecsSystem Spec


  4. Joined : Jun 2015
    Posts : 10,908
    Windows 10 Pro / Windows 10 TP / Windows 8.1 Pro / Windows 7 Pro
       16 Sep 2015 #4

    Never used an onder driver where they said it is not compatible, but it solved the problem?
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Internet Explorer 11 Favourite Bar
Some of my favourites do not display a site icon because the site tab does not have a specific icon either, just the generic blue "e". Is there any way to get my favourite bar icon to show the icon I want other than the icons in the "change icon"...
Browsers and Email
Future of Internet Explorer
Hi, I got confused about Microsoft Edge vs Internet Explorer. Is Edge engine based on IE's? / Does Edge depends on IE? Will IE still be developed or it has been discontinued? IE API can be used in 3rd party apps: Windows Scripting Host, as an...
Browsers and Email
Solved Explorer + no internet connection
Today i turned on my pc and the explorer.exe error appeared, i refreshed the screen and the icons appeared , but the start button didn't work , i tried to make troubleshoot but nothing... the worst part is that i can't acces the internet. Is there a...
General Support
Internet Explorer dead
Everything was hunky dory until just after I downloaded CrystalDiskInfo via Cnet. Probably just a coincidence as I have had no trouble using either before. I E refused to start and the only option was to reload W 10 afresh.
Browsers and Email
Solved Internet Explorer Works!!!
Hi For the first time since I installed Windows 8 Internet Explorer works. On two different computers that I've had running Windows 8, Widows Explorer has not been able to display my Comcast home page, and some other pages that I use a lot. ...
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:15.
Find Us
Twitter Facebook Google+



Windows 10 Forums