Page 1 of 2 12 LastLast

  1. Joined : Oct 2014
    Trnava
    Posts : 1,713
    Windows Home x64
       06 Oct 2014 #1

    BSOD - usbehci.sys - IRQL_NOT_LESS_OR_EQUAL


    I have already had 7 of them, just got one when trying to post this. I suspect my USB sound card. So far they have happened only in Windows, not in games, when listening to the music on youtube or via Radiosure, sometimes I was not even at PC, so I think, that I can exclude my wireless mouse and keyboard connected through USB receiver. I guess, that I just have to wait for Windows 10 drivers.
      My System SpecsSystem Spec


  2. Joined : Sep 2014
    DFW Area
    Posts : 374
    Windows 8&10
       07 Oct 2014 #2

    I haven't looked at your dump files, but if someone doesn't show up who actually knows how to analyze those, I will give it a try.

    What comes to mind is the "ehci" and your bios settings. I believe there is an option on many systems to allow or not allow that type of switch over under the USB options. You might check to see if you can find anything. If nothing is available, you might check your bios version and see if any bios updates are available.

    Can you acquire 8.1 drivers for the device? Not suggesting anything yet, just asking.
      My System SpecsSystem Spec


  3. Joined : Oct 2014
    Trnava
    Posts : 1,713
    Windows Home x64
       07 Oct 2014 #3

    Well, I have found ehci USB option in BIOS, it enables USB booting, so I have disabled it for now and I will see, what it does. So far I have got like 2-3 BSODs a day, so it should not take long.

    EDIT: I have got another BSOD in about 10 minutes, so it did not help.
    I have 8.1 drivers for everything, but Creative is known for its bad drivers.
    Last edited by TairikuOkami; 07 Oct 2014 at 16:27.
      My System SpecsSystem Spec


  4. Joined : Oct 2013
    Wolves, England
    Posts : 1,634
    W7 Pro x64 | W10 IP x64 | Linux Mint VM
       07 Oct 2014 #4

    Your dump is indicating the EHCI eUSB Miniport driver.

    Code:
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck D1, {1e5, 2, 0, fffff80016e0cabb}
    
    Probably caused by : usbehci.sys ( usbehci!EHCI_GetPacketForFrame+17 )
    
    Followup: MachineOwner
    
    1: kd> lmvm usbehci
    start             end                 module name
    fffff800`16e00000 fffff800`16e19000   usbehci    (pdb symbols)          c:\symbols\usbehci.pdb\3106D5F7086447B194C6C1E86FDCDB441\usbehci.pdb
        Loaded symbol image file: usbehci.sys
        Mapped memory image file: c:\symbols\usbehci.sys\5413C48619000\usbehci.sys
        Image path: \SystemRoot\System32\drivers\usbehci.sys
        Image name: usbehci.sys
        Timestamp:        Sat Sep 13 05:13:58 2014 (5413C486)
        CheckSum:         000202CC
        ImageSize:        00019000
        File version:     6.4.9841.0
        Product version:  6.4.9841.0
        File flags:       0 (Mask 3F)
        File OS:          40004 NT Win32
        File type:        2.0 Dll
        File date:        00000000.00000000
        Translations:     0409.04b0
        CompanyName:      Microsoft Corporation
        ProductName:      Microsoft® Windows® Operating System
        InternalName:     USBEHCI.sys
        OriginalFilename: USBEHCI.sys
        ProductVersion:   6.4.9841.0
        FileVersion:      6.4.9841.0 (fbl_release.140912-1613)
        FileDescription:  EHCI eUSB Miniport Driver
        LegalCopyright:   © Microsoft Corporation. All rights reserved.
    Given that it's a built in Windows driver it may just be that it's incompatible with the hardware at the current point in time. I've dug around the dump but can't get find anything deeper on that particular driver.

    Your ATI driver has also been flagged however.

    Code:
    ffffd000`e4b786f8  fffff800`17c7eea5Unable to load image \SystemRoot\system32\DRIVERS\atikmdag.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for atikmdag.sys
    *** ERROR: Module load completed but symbols could not be loaded for atikmdag.sys
     atikmdag+0x7eea5
    
    1: kd> lmvm atikmdag
    start             end                 module name
    fffff800`17c00000 fffff800`18c6a000   atikmdag T (no symbols)           
        Loaded symbol image file: atikmdag.sys
        Image path: \SystemRoot\system32\DRIVERS\atikmdag.sys
        Image name: atikmdag.sys
        Timestamp:        Mon Sep 15 23:21:08 2014 (54176654)
        CheckSum:         00FFED07
        ImageSize:        0106A000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    Try rolling back to an earlier version for now to check stability. Download the 13.9 driver from here then use AMD Uninstall Utility to remove all traces of your current driver, CCC etc. Reboot and install the 13.9 driver.

    Note   Note
    When installing choose 'Advanced' or 'Custom' (whichever option is available, just not Express) and uncheck everything except the video driver.
      My System SpecsSystem Spec


  5. Joined : Oct 2014
    Trnava
    Posts : 1,713
    Windows Home x64
       07 Oct 2014 #5

    Thanks for the input. I have installed 13.9 fresh when I have installed Windows.

    I will try to disable the service from loading, not many options left anyway.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\usbehci
    Last edited by TairikuOkami; 07 Oct 2014 at 17:11.
      My System SpecsSystem Spec


  6. Joined : Oct 2013
    Wolves, England
    Posts : 1,634
    W7 Pro x64 | W10 IP x64 | Linux Mint VM
       07 Oct 2014 #6

    Keep us updated, this is a learning curve for me.
      My System SpecsSystem Spec


  7. Joined : Sep 2014
    DFW Area
    Posts : 374
    Windows 8&10
       07 Oct 2014 #7

    Many times if you see a USB port type warning it is actually the device connected causing the problem. One thing we like to check is the drivers on your system. Most of yours are 2013 or 2014. The secdrv.sys is notorious and has shown 2006 since Windows 7 came out, so it is OK, but you do have one I do not recognize.

    WinRing0x64.sys Sat Jul 26 08:29:37 2008 Maybe related to some hardware monitoring?
    and
    CHDRT64.sys Thu Mar 24 14:36:14 2011 Maybe related to Conexant

    The fact drivers or old doesn't always mean they are bad, but something to check out.
      My System SpecsSystem Spec


  8. Joined : Oct 2014
    Trnava
    Posts : 1,713
    Windows Home x64
       08 Oct 2014 #8

    Yes, I have Conexant onboard soundcard, but I do not use it, so I do not bother updating it, I usually disable it along with other devices. WinRing0x64 is related to FusionTweaker (undervolting).

    Well, maybe it is a little premature, but I have a hunch, that disabling the driver did the trick. Thanks everyone for pointing me to the right direction, once I have realized, that it is a part of Windows, I recalled, that it is actually running as a service. My USB devices are working, I just get some errors.
      My System SpecsSystem Spec


  9. Joined : Oct 2013
    NW Florida
    Posts : 6,758
    Windows 10 Enterprise and Pro/Windows 7 Enterprise/Linux Mint
       12 Oct 2014 #9

    Just one question, are you using Windows 8 drivers? Most Windows 8 Drivers run well on the Windows Preview, especially the Chipset drivers and the Graphics drivers. The Chipset drivers usually contain the USB drivers.
      My System SpecsSystem Spec


  10. Joined : Oct 2014
    Trnava
    Posts : 1,713
    Windows Home x64
       13 Oct 2014 #10

    Yes, Windows 8.1 drivers, but my hardware is strange. I can not use AMD SATA/AHCI driver on 8.1 either, because it causes nonstop 30% CPU usage, I reported it on AMD forum, there is no solution.

    AMD Support and Game Forums - AHCI Driver and CPU Load
      My System SpecsSystem Spec


 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved My first BSOD in ten.
It happened after I just have installed Speccy and let it run for the first time. When it is "Analyzing", the BSOD happened. The screen says it is cpuz138_x64.sys that caused the BSOD. I dont have CPUz Installed. The later runs of Speccy...
BSOD Crashes and Debugging
Solved BSOD: Can Some Please Take A Look
My computer blue screened upon updating, can someone have a look and see what needs to be done, please?
BSOD Crashes and Debugging
My First Win 10 BSOD
Throwing it out here for everyone. A lot of symbols can't be found. Seems to blame my graphics driver and the stack indicates the driver got caught up in some type of loop. A few minutes before that, Facebook was open and a video played,...
BSOD Crashes and Debugging
BSOD's from atikmdag.sys
Hi Guys, I'm new to ten forums so I hope I'm posting this in the correct place. :huh: Ive had a few BSOD's from atikmdag.sys This happens when it seems that windows update installs a new video driver Name AMD Radeon R7 200 Series...
BSOD Crashes and Debugging
Bsod help please
Hey all getting bsod on windows 10 tech preview here is my debug info 12754 help much appreciated. I have run mem test overnight no ram errors. cheers Just a bit more info the error bcc is 0xc000021a and the cause is "ntoskrnl.exe" address...
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:16.
Find Us
Twitter Facebook Google+



Windows 10 Forums