Windows 10: BSOD when switching from ethernet to Wifi: "CRITICAL_PROCESS_DIED"

  1.    10 Sep 2015 #1

    BSOD when switching from ethernet to Wifi: "CRITICAL_PROCESS_DIED"


    I'm hoping that someone can help me solve my various BSOD events with windows 10. My windows logs are also full of critical errors.

    Essentially, every few days, (I can't replicate the issue at will), after I've used my laptop (Fujitsu u904 Lifebook) on it's docking station (Network via Ethernet), when I reboot off the docking station (Network via WiFi) I get a combination of errors. These range from:

    - a message saying that Windows was unable to start the The Group Policy Client
    - a blank desktop with no shortcuts
    - clicking on the start button doesn't work (but the windows key does)

    While not all thee errors happen together, what does happen is that I'm unable to connect to Wifi and the network icon is not visible in the tray.

    Sometimes these are also accompanied by the BSOD CRITICAL_PROCESS_DIED.

    I know error this is about to happen, because when I power down from the docking station (I never take or put my laptop on/off it without it being powered down), I hear an error sound and then when next rebooting (off the dock), the Wifi symbol on the lock screen before entering the password has changed to the Wifi symbol with a small circle at the top left. Sure enough my windows event logs show various errors including a number listed as error No 7031,

    I'm not a techie but read elsewere that if this happens, entering "netsh" & "winsock reset" from the admin screen does solve the problem after rebooting, but I'm having to do this every couple of days.

    Does anyone know what's causing this? Be grateful for any insight. I've attached a download of my laptop's data.
      My ComputerSystem Spec

  2. axe0's Avatar
    Posts : 13,705
    Windows 10 Pro
       10 Sep 2015 #2

    Hi ArkBrit,

    Welcome to the 10forums.

    You say you have several bluescreens, but there is 1 dump file in the zip.
    If you use a program like Ccleaner, please stop with it while troubleshooting. These programs are deleting dump files which are needed for troubleshooting.

    Please check {windows partition}\windows\minidump and check if there are any other dump files saved.
    Please make sure your pc is configured for small dump files How to configure minidump | Windows 10 tutorial

    Please boot into safe mode and see if the critical process died crash still occurs How to boot into safe mode

    If this crash does not occur in safe mode, please do the following:

    • Open taskmanager
      • Go to the tab startup
      • disable everything

    • Search msconfig and open it
      • Go to the tab services
      • Check 'hide microsoft services'
      • Uncheck all other services
      • Click apply and click ok

    • Reboot if asked

    See if the problem persist, if the problem does not persist enable in the startup tab in taskmanager 1 item and in the services tab in msconfig also 1 service, reboot and see if the problem persist. Keep doing this until you find the culprit or there is nothing left.

    Please do the following:

    • Open an admin command prompt
    • Copy/paste "sfc/scannow" (without quotes) and press enter
    • When it finished reboot your system
    • Open again an admin command prompt
    • Enter sfc/scannow again

    If sfc/scannow doesn't say "Windows Resource Protection did not find any integrity violation", please upload the cbs.log file located at {windows partition}\Windows\Logs\CBS\, if the file is too large try a 3rd party uploader like dropbox, onedrive, google drive, mediafire etc.
    System File Check(SFC a.k.a. Windows Resource Protection) needs to have your system rebooted in order for sfc to try to fix the problems that it finds.

      My ComputersSystem Spec


Related Threads
Debug report attached. 27187
Hi, guys I got a problem with constantly repeating BSOD mostly because these two reasons in topic. I have checked online and did everything for preventing this from happening. And it doesnt worked :/ The other things I have done are checking...
I upgraded from 8.1 to 10.0 2-3 weeks ago. Wifi worked fine until a couple of days ago. Now the icon says "Not connected - No connections are available." But there are! I'm sending this from my Windows 8.1 notebook and it says there are 4 wifi's...
On the day Windows 10 was officially launched my Precision M3800 was "upgraded" from 8.1 and I've had no significant problems... until a few minutes ago. I suddenly lost internet connection and the troubleshooter couldn't help, so I shut down via...
Hey guys, I just upgraded my OS from Windows 8.1 to Windows 10. Everything are working perfectly other than the wifi connection. When I am connected to a wifi connection it always state as a limited connection. I just did everything that I can. Help...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:09.
Find Us