Windows 10: BSOD DPC_WATCHDOG_VIOLATION, error (133) driving me crazy Solved

  1.    04 Sep 2015 #1

    BSOD DPC_WATCHDOG_VIOLATION, error (133) driving me crazy


    System Config:
    GA-970A-UD3 1.1
    AMD FX-6100, 16G RAM
    NVIDIA GeForce GT 610
    Patriot Pyro SE 120GB SSD
    WD 1TB SATA III
    ST 1TB SATA III

    I continue to get DPC_WATCHDOG_VIOLATION. I have updated BIOS, MB Drivers (Realtek LAN and Audio) , NVIDIA Drivers. I have disabled Fast Startup, Hibernate and Sleep. I have disabled Driver Install from Windows Update. Please help this is driving me crazy. Attached is mini dump. Thank you in advance.
      My ComputerSystem Spec


  2. Posts : 8,216
    Windows 10 Enterprise and Pro/Windows 7 Enterprise/Linux Mint
       04 Sep 2015 #2

    Hello, jclentini and welcome to the forums. I have looked at the last few dump reports and they all read the same.

    Code:
    BugCheck 133, {1, 1e00, 0, 0}
    *** WARNING: Unable to verify timestamp for amdsata.sys
    *** ERROR: Module load completed but symbols could not be loaded for amdsata.sys
    *** WARNING: Unable to verify timestamp for amdxata.sys
    *** ERROR: Module load completed but symbols could not be loaded for amdxata.sys
    *** WARNING: Unable to verify timestamp for mfedisk.sys
    *** ERROR: Module load completed but symbols could not be loaded for mfedisk.sys
    Probably caused by : amdsata.sys ( amdsata+9652 )
    Followup:     MachineOwner
    mfedisk is McAfee
    The AMDSata is obviously the AMD sata controller and the mfedisk is your McAfee Anti Virus. McAfee is a very well known cause of BSODs.

    Please go to Device manager and see if you have any yellow triangles there and tell me what they are on. Also please go to IDE/ATA/ATAPI controllers, expand it by clicking the small triangle next to it and post a screenshot. https://www.tenforums.com/tutorials/1...en-forums.html here. I would also remove McAfee by uninstalling it and run the McAfee Removal tool http://service.mcafee.com/FAQDocument.aspx?id=TS101331 . Also, make sure you have the latest Firmware for your SSD and run the long and short test on your Western Digital Drive with their Data Lifeguard for DOS WD Support / Downloads / SATA SAS / WD Black. Also, please enable driver downloads from Windows Updates and download the windows updates.
      My ComputersSystem Spec

  3.    06 Sep 2015 #3

    essenbe, per your instructions I have completely uninstalled McAfee, I have attached a screen shot of the Device Manager, I ran short and long diags. on the WD 1TB drive with no errors. I ran the SeaTools short and long diags. on the ST drive a it Failed. I pulled it out of the system. Once I did that she is more stable. I did add an additional OCZ Radeon R7, the idea is to clone and replace the Pyro SE which is EOL. The Pyro SE firmware is 5.0.4 and the OCZ Radeon R7 firmware is current. There is still some issue with the AMD Sata controller. The Radeon SSD Guru reports that ACHI is OFF but, it is Enabaled in BIOS, the BIOS flashes "ACHI init ..." at startup. The Device Manager reports AMD Sata Controller Drivers dated 2009. Also attached is the most recent mini dmp file. Please advise on issues and any ideas on fixing AMD Sata, if there is a problem.
      My ComputerSystem Spec


  4. Posts : 8,216
    Windows 10 Enterprise and Pro/Windows 7 Enterprise/Linux Mint
       06 Sep 2015 #4

    Gigabyte only offers 2 drivers for Windows 10. With Windows 8, it only offers a few drivers. You need the AMD Sata AHCI driver. According to your Device manager, I don't see the AHCI driver listed. Were you in AHCI Mode when you installed Windows, last clean install you did?

    Which Ports are your SSDs connected to?
      My ComputersSystem Spec

  5.    06 Sep 2015 #5

    Pyro SE, 0; OCZ Radeon R7, 1; WD 1TB, 2
    Yes, I believe ACHI was enabled during Windows 10 Install. Where can I get the AMD ACHI Drivers? I don't see them on the Gigabyte Support site for my MB.
      My ComputerSystem Spec


  6. Posts : 8,216
    Windows 10 Enterprise and Pro/Windows 7 Enterprise/Linux Mint
       06 Sep 2015 #6

    Are you sure that your sata controller in BIOS is set to AHCI? If you are not sure, check.
      My ComputersSystem Spec

  7.    06 Sep 2015 #7

    Yes, see attached.
      My ComputerSystem Spec


  8. Posts : 8,216
    Windows 10 Enterprise and Pro/Windows 7 Enterprise/Linux Mint
       06 Sep 2015 #8

    Expand Storage Controllers and see what the driver is. The Microsoft AHCI Driver is STORAHCI and should be in IDE/ATA/ATAPI controllers. You also have a Storage controllers entry in Device Manager. Typically that is only there if you have it set to Raid. You do have 'On Chip Sata Raid 5 support' enabled. I am not sure about the 'on chip sata port 4/5 type'. Your manual should tell you about enabling AHCI, but I have never understood Gigabyte Bios settings.
      My ComputersSystem Spec

  9.    08 Sep 2015 #9

    Gave up on trying to get the right ACHI drivers installed. Did a fresh install of Windows 10. No BSOD yet, system seems very stable, just had to load all my Apps again. There is only one thing that is strange, the OCZ Radeon R7 SSD shows operating in ACHI mode but at Sata II rates. This is true with either MS Standard ACHI Driver or AMD Sata Driver from AMD Chipset Driver release 15.7.1. Notice from the screenshot above it was running at Sata III rates previously.
      My ComputerSystem Spec


  10. Posts : 8,216
    Windows 10 Enterprise and Pro/Windows 7 Enterprise/Linux Mint
       08 Sep 2015 #10

    I'm wondering if your utility is Windows 10 ready. According to the specs for your motherboard, you don't have any Sata II ports. They are all sata III. The drivers can make a little difference in performance, but they should all be running sata III. I would guess it is possible you have a defective board, but I don't recall ever seeing one do that.
      My ComputersSystem Spec


 

Related Threads
BSOD DPC_Watchdog_Violation in BSOD Crashes and Debugging
Dear Sir/Madame, I have received a few messages since upgrading to Windows 10 saying my computer needed to restart and that I could find the answer at DPC Watchdog Violation. I have not had this happen while I am using the computer but the message...
BSOD DPC_Watchdog_Violation in BSOD Crashes and Debugging
Blue screen of death randomly happens saying to look up DPC_Watchdog_Violation. Have searched the internet for solutions and thus far have not found a fix that works. Solutions I have tried are: Update drivers, if it's a driver issue I can't find...
Windows 10 Insider Preview Build 10130 WIN-A82HE7DTDIP-Fri_06_05_2015_172808_86.zip attached PC Specs are in profile :P So I have windbg, I followed the how to install guide (Using both the win8.1 and win10 SDK, both give the same errors,...
Okay, I upgraded to windows 10 as soon as it released a couple of days ago. Since then I have been tearing my hair out trying to solve the few issues I have. I am about to give up and go back to windows 8.1, but thought I would post here first to...
Solved Hard Driving Cloning Question in General Support
I am looking to upgrade a computer in my office to Windows 10 once it comes out. This computer needs to have its hard drive replicated. Currently we have two option to clone the hard drive, hardware based and software based cloning. Has anyone tried...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:22.
Find Us