BSOD on cold boot - when windows update is available?


  1. Posts : 2
    Windows 10
       #1

    BSOD on cold boot - when windows update is available?


    Hello,

    Recently I had troubles with bsod, but it was only on cold boot. After that I could use my pc without troubles. First time it happend around 2 weeks ago for few days, until I noticed that widows have new update. After installation no issues till this Wednesday, again bsod on each cold boot. I made windows update and it seems that it solves issue again.

    Im using WIndows 10 Home, 22H2 currently. Generally I try to have all drivers up to date all the time, I run memtest86 and no errors, I run OCCT for 1 hour to check CPU and no issues. I did not tested recently GPU, although I can play all day and no issues at all. Previously I had automatic windows updates off so I turn it on right now. Fast boot is turn off for long time.

    Right now it seems ok, but I would like to know what may cause these issues. So I would appriciet Your help.

    DESKTOP-UUHUOV1-(2023-04-27_07-29-52).zip - Google Drive
      My Computer


  2. Posts : 402
    Windows 10 and Windows 11
       #2

    All three dumps are the same, and all three point at the AsrVDrive.sys driver as the likely problem. We see this third-party driver called several times in the call stack...
    Code:
    ffffd209`4d1098e8  fffff806`15d849a0 FLTMGR!FltpDispatch
    ffffd209`4d1098f0  fffff806`22832372 AsrVDrive+0x2372
    ffffd209`4d1098f8  fffff806`17000000 nt!VrpRegistryString <PERF> (nt+0x0)
    ffffd209`4d109900  fffff806`170d4db4 nt!setjmpexused <PERF> (nt+0xd4db4)
    ffffd209`4d109908  fffff806`1bcb0000 fileinfo!FIPreMdlOperationCallback <PERF> (fileinfo+0x0)
    ffffd209`4d109910  fffff806`1bcb80a8 fileinfo!PiRegStateDiscriptor <PERF> (fileinfo+0x80a8)
    ffffd209`4d109918  fffff806`15d80000 FLTMGR!FltGetCopyInformationFromCallbackData <PERF> (FLTMGR+0x0)
    ffffd209`4d109920  fffff806`15dab5e8 FLTMGR!FltpVerifierCodeSectionHandle <PERF> (FLTMGR+0x2b5e8)
    ffffd209`4d109928  fffff806`15d80000 FLTMGR!FltGetCopyInformationFromCallbackData <PERF> (FLTMGR+0x0)
    ffffd209`4d109930  fffff806`15dab594 FLTMGR!FltpVerifierCodeSectionHandle <PERF> (FLTMGR+0x2b594)
    ffffd209`4d109938  fffff806`15d80000 FLTMGR!FltGetCopyInformationFromCallbackData <PERF> (FLTMGR+0x0)
    ffffd209`4d109940  fffff806`15dab468 FLTMGR!FltpVerifierCodeSectionHandle <PERF> (FLTMGR+0x2b468)
    ffffd209`4d109948  fffff806`15d80000 FLTMGR!FltGetCopyInformationFromCallbackData <PERF> (FLTMGR+0x0)
    ffffd209`4d109950  fffff806`15dab420 FLTMGR!FltpVerifierCodeSectionHandle <PERF> (FLTMGR+0x2b420)
    ffffd209`4d109958  fffff806`17000000 nt!VrpRegistryString <PERF> (nt+0x0)
    ffffd209`4d109960  fffff806`170c9f18 nt!setjmpexused <PERF> (nt+0xc9f18)
    ffffd209`4d109968  fffff806`22830000 AsrVDrive
    ffffd209`4d109970  fffff806`22836048 AsrVDrive+0x6048
    ffffd209`4d109978  fffff806`17000000 nt!VrpRegistryString <PERF> (nt+0x0)
    ffffd209`4d109980  fffff806`170d6818 nt!setjmpexused <PERF> (nt+0xd6818)
    This driver is a component of the ASRock 3TB 'Unlocker' tool. I'd be interested to know why you need to run that tool? Unless you have a real need for it I would uninstall it.

    If you really need the ASRock tool then you might want to download the Kingston SSD Manager tool and use that to see whether there is a firmware update for your NVMe drive. That might (possibly?) help.
      My Computer


  3. Posts : 2
    Windows 10
    Thread Starter
       #3

    Thank You very much. I just uninstalled it and You are right I dont need it at this moment.

    Good to know it was only this application.
      My Computer


  4. Posts : 402
    Windows 10 and Windows 11
       #4

    Let us know if you have further problems.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:21.
Find Us




Windows 10 Forums