Windows 10: COM Surrogate has stopped working error, No sound


  1. Posts : 3
    Windows 10 Pro 64bit
       20 Aug 2015 #1

    COM Surrogate has stopped working error, No sound


    Recently I started getting the pop-op error stating "COM Surrogate has stopped working". At the time I was running Windows 7 and had recently updated my video drivers. I went ahead and updated to Windows 10, hoping that the update would fix the error, which it did not. Before the Windows upgrade, the COM error was intermittent, and I had sound. After the upgrade, I do not have sound, and the error is constant from startup. After clicking on "Close the program" another error box immediately pops up in it's place.

    I have already tried the following solutions to no avail:
    • Updating video/audio drivers
    • Uninstalling video/audio drivers completely
    • Uninstalling all Codecs
    • Updating DivX
    • Nero is not installed
    • Adding dllhost.exe to DEP exception
    • Ran the System File Checker - no errors
    • Ran Check Disk - no errors
    • Scanned and removed all malware using LavaSoft Ad-Aware
    • Ran Windows Repair - no errors
    • Re-registering vbscript.dll and jscript.dll


    I am out of ideas for solutions. Any and all help is appreciated.

    Attachment 32869
      My ComputerSystem Spec


  2. Posts : 11,533
    Windows 10 Pro
       24 Aug 2015 #2

    Hi Ravenot,

    Welcome to the 10forums.

    There are no dump files in the attached zip file.
    Please run the tool again and make sure there are dump files.
    If there are no dump files in the new created zip file, please check the following directory for dump files: [windows partition]\windows\minidump\
      My ComputersSystem Spec


  3. Posts : 3
    Windows 10 Pro 64bit
    Thread Starter
       26 Aug 2015 #3

    axe0,

    Thank you for the reply. I am a little bit confused as to what specifically is missing for you. I checked the file on my desktop and it contains 19 txt files and a .nfo, identical to the uploaded file when i checked it. Rerunning the utility, the zip contained the same list of files. Is a specific one not generating that needs to? (like a dump.txt?).

    I also checked the directory you indicated and found the \minidump\ folder does not exist within the windows folder.

    Here is the latest zip the utility generated, with similar results as the first one. Not sure what else to do :\
    Attachment 33876
      My ComputerSystem Spec


  4. Posts : 11,533
    Windows 10 Pro
       26 Aug 2015 #4

    HI Ravenot,

    What is missing are dump files that can be found in the automatically created (created when you have a bluescreen and the minidump is saved) minidump folder.
    Please read BSOD Minidump - configure to create in windows 10
    Without dump files we can't help you.

    What we need is a zip file that contains (.dmp file at least 1)
    Attachment 33886
      My ComputersSystem Spec


 

Related Threads
Now, for some odd reason, on my computer, the sound, start menu and cortana stopped working and I can't even get past the sign in menu without it telling me to sign out so they can "fix" this problem which I've done 3 times now so I have no clue if...
After I updated to Windows 10 I get multiple "Powershell has stopped working" errors. How do I get rid of this error. Things I have tried: Downloaded Malwarebytes and ran scan - did not fix issue. Downloaded RegCurePro and ran scan - did not...
Yesterday my audio worked fine on both my speakers on my laptop (Dell Inspiron/N5110) and headphones. Then all of a sudden they stopped working. I have made sure that all the volumes are not muted. I did a troubleshoot on playing audio and it said...
Solved DWM.exe stopped working in General Support
Hey guys, I've had this issue since far before i upgraded to Win10 but I think you could still help in some ways? As said by the title I get the annoying message of DWM.exe has stopped working every time i switch to the desktop or any explorer.exe....
My win 10 computer has just started giving me the above error code. I can log in using mouse & keyboard, but when I get to the start screen I get the above error code 0XC000021a. I have tried several times to do a fix, like shutting off the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:57.
Find Us