I have a simular problem with my ASUS TUF B450 and AMD Ryzen 5, 3600.
Its the BIOS setting "CPU Virtualization" that causes "BSOD" with the error code "System Service Exception".
AMD CPU has built protection but I cant find any where if this is a bug and waiting for a fix, or if you cant do virtual CPU with AMD CPU on ASUS new GaMING MBs.

Note: With the CPU Virtual off in BIOS, ALL hardware protection in Windows Security is not avaible (like root-kit prevention).
But the TPM 2, is running fine.

I wonder. is this a problem at all?

- - - Updated - - -

Jarrod said:
I crashed with and without the razer drivers installed so I haven't uninstalled them. And if I disable the driver my headset won't work anymore. I enabled the driver verifier and continued to use my PC and play a game. During which it BSOD again with Nvidia's nvlddmkm.sys. Is this a scapegoat for the blue screen or because the driver verifier was on?
Should I try using my PC with the headset unplugged?
Anyways, I have attached the log collector findings.
Your Kernal DMA is not enabled. Nor is your CPU Virtualization, Secure boot, TPM 2, and you BIOS is in Legacy mode.

Have you tried to use Diskpart to get your boot in UEFI?

NM.
I found this NOT on ASUS support, tried it, and it works. I have OC 3600RAM with clocked speed.

https://social.technet.microsoft.com...-ryzen-7-2700x
Issue was caused by AI Suite 3 - uninstalling EZ Update (a part of this software) resolved the issue

Question, is CPU Virtualization needed on a gaming PC?