Hi all, after upgrading my computer BIOS from F6 to F8, my computer has been experiencing a BSOD called Inaccessible_boot_device. The only thing that fixed it back then was system restore. Curiously enough, I ran that system restore with no drives plugged in except my system SSD, so when I turned off the computer and went to plug in my NVMe it was crashing again with Inaccessible_boot_device. On my F6 BIOS, when I added my NVMe there was no such BSOD. Once again I restored my computer back to a working state by using system restore.

Now my problem is that I had a power outage 2 days ago and my motherboard was having issues booting up, it would boot loop up to debug code 32 "CPU PEI Initialization". A hardware change can get it working again. For example, I had code 32 so I removed a stick of ram. Code 32 again? I add that stick of ram back in. This phenomenon only occurs on the F8 bios and when I downgrade to F6 it is gone. Clearing CMOS and unplugging everything does not solve this issue. However, I did clear the CMOS 2 days ago after I had the power outage before doing the hardware change fix.

So now my motherboard boots up again, and I have that same BSOD Inaccessible_boot_device. I thought, no problem, I will just use system restore. Unfortunately, there were no restore points :/ So I went on through trying numerous other methods to get working. Such as making sure ACHI is correctly configured in BIOS, running SFC and DISM, and rebuilding BCD. The error still persists. Curiously enough, if I try to boot the system on the F6 BIOS the BSOD does not get displayed but instead crashes on the UEFI loading screen with no explanation. I know that it is a BSOD because if I change crashcontrol autoreboot to 0 in registry, the system just stays stuck on the Gigabyte logo with no spinning circle, instead of rebooting.

Additional information would be that my system normally boots and reaches the login screen in 7 seconds, but now it takes 15 seconds just to get to the BSOD.

A person with a similar problem with me and a Gigabyte motherboard solved this problem by unplugging everything including the CMOS battery which supposedly cleared some NVRam variables which allowed him to boot again. I did the same thing and waited up to 10-15min., but it is still a no go. Also curiously enough, is that even after all this clearing CMOS stuff and unplugging the battery, some old EFI boot entries still exist. This makes me think that the NVRam is not getting cleared. I am not sure how to go about doing that.

A fix that I am almost certain would work would be restoring the registry from RegBack, however that folder is empty since Microsoft disabled automatic backup of the registry.

My system generates no ntbtlog.txt when enabling boot logging; additionally, there are no crash dumps or mini crash dumps being made.

I know a clean install would work and that is probably what I will have to do if nothing else prevails. If anything, I am very curious as to what this problem is since it is a very strange bug check considering the circumstances. If anyone has any information to what keys and values in the registry might cause this problem, I would greatly appreciate it.

Motherboard: Gigabyte Z97x Gaming-7

- - - Updated - - -

OK so I have solved this.
Turns out I was right and there was something in the registry that was causing Inaccessible_boot_device.
How I went on to debug this issue was installing Windows 10 on a spare drive I had. I would then copy the various ControlSets subkeys from the install that was BSODing to the new install. Copying the services subkey made the same exact error happen. The Windows10 bootloader would spin longer than before, and as if some sort of time out happened, it would go to Inaccessible_boot_device. I proceeded to export the services subkey from the original install and the new install and used regdiff to generate differences in the 2 subkeys. I made a .reg file that replaced the the services from the now crashing NVMe with values that it had before, and voila, it would boot. Further isolating the exact change that made it boot led me to this subkey.

[HKEY_LOCAL_MACHINE]\ControlSet001\Services\pci]
The Start tag on the crashing machine for this subkey was 4 (disabled) and changing it to 0, I have miraculously have gotten it to boot. I don't know how my machine was starting before and I don't know why a BIOS reset caused it to not load anymore with this subkey being 4. I also have no idea why it was disabled in the first place. But there you go. I hope this helps someone out in the future.