PFN_LIST_CORRUPT BSoD at third boot during Windows 10 upgrade to 1909

  1. Posts : 4
    Windows 10 Pro version 1809

    PFN_LIST_CORRUPT BSoD at third boot during Windows 10 upgrade to 1909


    I am finally ending here after having spent quite a lot of time stripping down software, drivers, and possible causes of my issue.

    I have a Windows 10 Pro 1809 rig that needs an upgrade to 1909. It has successfully upgraded from previous Windows 10 versions in the past through Windows Update, without issue. This had upgraded from Windows 7 successfully.

    However this time, the following occurs :
    Upgrade process via WU, Upgrade Assistant, or via USB image (offline upgrade) goes OK until the SECOND_BOOT phase, after the Windows setup has detected the hardware and installed its drivers again, which is visible through the screen resolution that becomes sharp and neat during this process.

    During Offline upgrade attempt using USB, I got this error code :
    0xC1900101 - 0x40017
    SECOND_BOOT phase, with an error during BOOT operation

    Basically, after the second boot, shortly after the Windows logo shows up, a PFN_LIST_CORRUPT blue screen shows up.
    Windows reboots, tries something to repair, but same BSoD after repair attempt.
    So Windows rolls back everything back to 1809, and I'm stuck there.

    This occuring at the boot time of a Windows 10 barely at the end of an upgrade process, and the system rollbacking each time, I have not found a MEMORY.DMP file to help me.

    What I did already to narrow down possible causes :
    - Uninstall crap
    - Uninstall BitDefender, only leaving Windows Defender
    - Removed optional Windows features
    - Forced-disable Hyper-V including in bcdedit
    - Unplugged non-necessary peripherals aside ETH, Keyboard, mouse and Screen
    - Used DriverStoreExplorer to remove old and useless drivers from DriverStore
    - Ensures the remaining drivers aren't abysmally old
    - Ran DISM /RestoreHealth numerous times (no issues)
    - Ran Memory Check (no issues as well)
    - Disabled useless features in BIOS including VT-D, PCI and non-urgent controller stuff

    Yet, still get this PFN_LIST_CORRUPT thing, and hardly a clue.
    Windows is extremely stable, and errors are rare, if they ever happen.

    Thus, I am here, and attach logs and what I could get.

    This hard drive has a dual-boot setup with a Linux next to the Windows, meaning I could access the Windows partition easily, before some of the reboots if necessary (which may be an idea).
    Yet I am questioning if Grub2 being on the MBR could be the cause, but I doubt it.

    I thank you in advance for your help.
      My Computer

  2. Spectrum's Avatar
    Posts : 546

    Since this is happening during a system upgrade, I'd suggest you run Microsoft's setupdiag.

    Download setupdiag, and then run PowerShell as an administrator.

    cd $home\Downloads

    When it's finished it will output several files in the same directory that it's in (which should be the downloads folder).
    Upload SetupDiagResults.log and
      My Computer

  3. Posts : 4
    Windows 10 Pro version 1809
    Thread Starter

    Thank you Spectrum, here are the resulting files from SetupDiag.
      My Computer

  4. Posts : 4
    Windows 10 Pro version 1809
    Thread Starter

    Anybody there?

    I can supply more information, logs or outputs if necessary for you to help me out.
      My Computer

  5. Posts : 392

    I'm not familiar with these logs, but here's my best guess:
    - the first log shows that suspended services may not have been stopped.
    - the zipped lolder has a lot of logs, but I can't seem to extract them.

    So, my guess here is to perform a clean boot and try the upgrade from there.

    EDIT: just thinking here, but I wonder if removing drivers from driver store could have caused a problem (if a driver was needed from the driver store).

    - - - Updated - - -

    Other thoughts:

    Make a disk image of the system (so you can restore to this point in time if you want), then do a clean install of 1909 to see if that helps.

    Make a new user account (an Administrator) and try the upgrade from it.
      My Computer

  6. Posts : 4
    Windows 10 Pro version 1809
    Thread Starter


    Perhaps the zipped folder caused you issues because I had to tweak its compression using 7zip (due to the 5MB limit of this forum).

    I have finally tried something else... and solved the issue.

    I kept thinking something was wrong within the system, since the error corresponded to a "driver issue" problem, causing corruption.

    I ended up looking in the Event viewer after the boot of my Windows 1809, and found out that there was a Windows Server failing to start : HvHost (Hyper-V Host Service), used by Windows to containerize processes apparently.

    EventViewer has logged HvHost, and subsequent services Hvsics and Cmcontrol failed.
    They failed due to a faulty or malfunctioning "device". This was the only logged occurrence of a faulty device on the system outside of the upgrade.

    So my guess that my system had a faulty Hyper-V virtual device or config, preventing Windows to properly use this system virtualization feature (present even if Hyper-V feature is disabled or uninstalled) for processes, threads or even Microsoft Edge in a container or sandbox fashion (such as Windows Defender Application Guard).

    Having read that Hyper-V could cause issues during upgrades, I looked for these services, and followed the steps from these two links :
    How to Disable Hyper-V in Windows 10?

    In addition to disabling the "Override system settings" for vmcompute.exe and vmwp.exe, I also disabled the HvHost and Cmcontrol/Cmservice in Services, to reduce chances of them failing after the Second_Boot phase, where the BSoD occured.

    Upgrade went fine, I am now finally running Windows 10 1903.

    These services and Hyper-V settings have been automatically restored after the upgrade, and I have been able to reenable the VT-D Bios feature. The only thing I had to do manually was to manually run "bcdedit /set hypervisorschedulertype core" to enable mitigations for CVE-2018-3646 for virtual machines since HyperThreading is enabled .
      My Computer

  7. Posts : 392

    Great work!
    Thanks for letting us know.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:25.
Find Us

Windows 10 Forums