Driver Power State Failure on restart, shutdown, sleep

Page 1 of 4 123 ... LastLast

  1. Posts : 141
    Windows 10

    Driver Power State Failure on restart, shutdown, sleep

    Hello Windows Ten support,

    Ever since I upgraded from Windows 10 Pro v1809 to v1903 I receive a BSOD Driver Power State Failure when I restart, shutdown or sleep. My computer attempts to shutdown and after about 5-10 minutes I receive the BSOD. This problem did not happen in Windows 10 v1809. I did upgrade to v1909 and problem persists. Returning back to v1809 resolves the problem. I am now currently on v1909 and outside the roll back window to go back to 1809.

    What I have done to attempt to remedy the BSOD. After searching the web for this specific BSOD many referenced that it is related to a bad driver or corrupted operating system. I have done the following.

    1. Performed a Windows 10 repair install
    2. Performed chkdsk /r
    3. Performed DISM /Online /Cleanup-Image /CheckHealth
    4. Reinstalled graphic card drivers to newest non-beta drivers
    5. Checked all devices in device manager and made sure none were checked to allow computer to save power under power management
    6. Changed power plan to different power plans
    7. Removed all removable USB devices
    8. Performed SFC /scannow
    9. Boot into safe mode
    10. Boot into diagnostic startup

    The only times I have been able to temporarily fix the problem was by either 9. booting into safe mode or 10. booting into diagnostic startup. Both times the computer shutdown properly. This makes me think there is a windows service causing the BSOD. So I went through a long process of elimination with loading into "normal startup" and then disabling 50 windows services at a time until I found a batch of 50 where the computer would properly shutdown. Then I would split that into two 25 services groups and then split it again. Eventually making it down to about 10 services and then all of a sudden the bad service causing the BSOD seems to disappear or maybe there are more than 1 windows services causing this problem or a combination of services that will cause the issue. I end up empty handed and start the process over just to hit a wall again. But I am convinced it is a Windows service of sorts since my computer shuts down just fine in safe mode and diagnostic startup.

    Additional information I thought of.

    1. I did perform a complete hardware diagnostic using PC Doctor and it did not report any problems with the computer
    2. Also performed additional ram testing using memtestx86 over night and nothing failed
    3. Samsung Magician software states my SSD is in "Good" drive condition with the latest firmware installed with 9.9TB written. Smart shows everything is OK. AHCI activated, TRIM enabled, RAPID mode on, over provisioning enabled.

    I have attached the V2 log collector 1.09. Please let me know what else you need. Thank you.

    - - - Updated - - -

    For some reason I can no longer edit the OP. Please see link below for memory dump.

    MEMORY.DMP - Google Drive
      My Computer

  2. Posts : 14,051
    Windows 11 Pro X64 22H2 22621.1848

    MEMORY.DMP gets - Sorry, the file you have requested does not exist.
    ZIP does not contain any mini dumps.
      My Computers

  3. Posts : 141
    Windows 10
    Thread Starter

    Updated link to dump. Thank you.

    012320-13781-01.dmp - Google Drive
      My Computer

  4. Posts : 1,538
    Windows 8.1 Enterprise x64

    Send full memory dump (MEMORY.DMP in C:\Windows)
      My Computer

  5. Posts : 141
    Windows 10
    Thread Starter

    Not that I don't want to make troubleshooting my problem as easy as possible for everyone, to my understanding, full memory dumps CAN contain sensitive information. One quick search on Google brought up several concerns of publicly posting memory dumps in fear of what people can extract from memory dumps and, its scary. And by me posting it on this forum, its completely public. I've also gone over a couple BSOD threads and a memory dump wasn't asked for or even mentioned and the problem ended up getting solved from the information gathered by your log tool that I have posted already. Unless maybe there is exchanging of memory dump files via DM or hidden means that the public cannot see. Correct me if I am wrong on the memory dump containing sensitive information but there is a lot of information on the internet on using specific extraction tools to piece together sensitive data. I just cannot risk providing more data to bad players out there who want to cause harm to others.

    That being said, based on the information I provided and the log contents attached to the PO, can we work off of that?
      My Computer

  6. Posts : 1,538
    Windows 8.1 Enterprise x64

    The cause of the problem could not be found from the memory dumps you posted. Then do it:
    1. Run Driver Verifier Manager through write verifier in search bottom
    2. Tick all standard settings and 2 additional settings (force pending i/o request and irp logging)
    3. Select "Select driver names from a list"
    4. Tick all 3rd party drivers without Microsoft drivers
    5. Apply changes and reboot computer
      My Computer

  7. Posts : 141
    Windows 10
    Thread Starter


    I performed the steps, forced rebooted because the computer will not shutdown correctly as noted, and it takes a while to load with the windows logo and progress circle on screen. Then it loads to my profile, I type in my pin and then bluescreen...

    Driver verifier detected violation
    Failed AsUpIO.sys

    I am now unable to load into my profile. What are the next steps?

    Upon a Google search of the failed file above it is part of the Asus software suite that has been installed on my computer for over 4 years. I can uninstall the Asus suite software no problem. However, I need to get back into my profile to do so. How can I turn driver verifier off so I am not in this bsod loop?
      My Computer

  8. Posts : 1,538
    Windows 8.1 Enterprise x64

    Disable Driver Verifier from safe mode and uninstall Asus software
      My Computer

  9. Posts : 141
    Windows 10
    Thread Starter

    1. I booted into safemode, disabled verifier.
    2. Booted, uninstalled Asus Suite, rebooted.
    3. Tried restarting and problem persists.
    4. Noticed there were 3 services from Asus still installed. Asus Com Service, Asuss HM Com Service and Asus Fan Control Service.
    5. Stopped and disabled all 3 services. Rebooted a couple times and problem still persists.

    Should I forcefully remove the Asus remnant services? If so how would you go about doing this?
    Should I try the driver verifier again and see if it finds something else?
      My Computer

  10. Posts : 1,538
    Windows 8.1 Enterprise x64

    See if you still have this faulty driver on your system
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:04.
Find Us

Windows 10 Forums