BSOD after a Visual Studio install Reboot Error 21a

Page 3 of 3 FirstFirst 123
  1.    #21

    Will do. Just FYI, I've tried those couple of days ago reading your other posts, and one of those gave me Access Denied consistently. Will share which one.

    Will run these again in the morning, I'm done for the day/night!

    Thanks!
      My ComputerSystem Spec

  2.    #22

    If those commands wont work then execute below command:

    Code:
    ren  C:\Windows\SoftwareDistribution   SoftwareDistribution.bak
    Replace C: letter with Windows 10 installed assigned partition letter in your case i think it was G: letter.

    After executing the command restart your computer to see Windows 10 boots normally.
      My ComputerSystem Spec

  3. axe0's Avatar
    Posts : 14,181
    Windows 10 Pro
       #23

    Unfortunately, due to recent changes I do not have the time to assist in the way I like to (properly), so I have requested others to look into this.

    Having seen FreeBooter post the BCD and MBR commands, I do want to say that the BCD and MBR commands are ineffective, because they are not involved in the problem. Saying this in case someone else wants to post it again.
      My ComputersSystem Spec

  4. philc43's Avatar
    Posts : 4,095
    64bit Win 10 Pro ver 1809 Build 17763.503 and W10 Insider Build 18362 and 18895
       #24

    axe0 said: View Post
    It looks like alongside the Visual Studio installation process, Windows Update was simultaneously installing something and it has trouble installing the update.

    Code:
    Test Performed: 
    ---------------------------
    Name: Check for pending package install
    Result: Completed successfully. Error code =  0x4
    Time taken = 219 ms
    0x4 = system cannot open file.

    I'm not very familiar with this kind of issues, so I'll see what I can find to somehow revert the package. Right now I'm going home from school so I'll attend to this when I'm home.
    I think @axe0 is onto something here. But I believe you will need to identify which package was trying to load and remove it before reverting the package.

    Try the command:
    dism /image:<driveletter here> /get-packages

    This should result in a list of packages. See if you can spot one that might be relevant (share the results and we can try and speculate), then remove it:

    dism /image:<driveletter here> /remove-package /PackageName

    After this you should be able to revert the changes:

    dism /image:<driveletter here> /cleanup-image /revertpendingactions

    Hopefully, you can then reboot the system.
      My ComputersSystem Spec

  5.    #25

    Thanks @philc43

    I ran the commands, but the problem I face is all the dism commands result in permission error to write to the disk. Even with a scratchdir option.
    I got busy with work, hence the delay. I will upload photos of the command and error later today.

    Thanks.
      My ComputerSystem Spec

  6.    #26

    Hi

    Here are the screenshots of any DISM command that results in Access Denied writing to the scratch folder.

    https://photos.app.goo.gl/VXdyTNFP2FK2hbfv6

    Thanks

    - - - Updated - - -

    I know I had a typo in the dism command in revertpendingactions. I fixed that but the error still remains same - cannot access scratchdir
      My ComputerSystem Spec


 
Page 3 of 3 FirstFirst 123

Related Threads
Source: Visual Studio Roadmap Updates and Visual Studio 2019 Information | The Visual Studio Blog
Source: Microsoft Build 2018: New releases for Visual Studio, Visual Studio for Mac, .NET Core and Xamarin.Forms | The Visual Studio Blog
Solved Can't install Visual Studio 2015. in Software and Apps
Visual studio community 2015 throws up error and stops.. 96029 The log file. 96028 I have checked the sha1 and the image is not corrupted as the sha1 matches.
I am running Visual Studio 2015 on Windows 10. I wrote a simple Windows Phone 8.1 project (Hello World) in Visual Basic. The program worked all right in the Emulator. I attached my phone (Lumia 640) to my computer using the USB connection. I...
I'v been trying to install a copy of Visual Studio 2013, and I run into an error before it even starts to install that says something along the lines of, "Windows Compatibility Mode must be turned off." Visual Studio 2015 works fine, but 2013 will...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:42.
Find Us