BSOD reboot loop "CRITICAL SERVICE FAILED"

Page 1 of 2 12 LastLast
  1.    4 Weeks Ago #1

    BSOD reboot loop "CRITICAL SERVICE FAILED"


    Hi there,

    I am in an unpleasant situation and I hope you can help me.

    First, I appreciate you need the correct information to diagnose - my system does not boot up anymore, not even in safe more, so I am unable to run the log collector app you require.

    This is what happened: I was diagnosing another PC which had issues with Windows Update. I followed a tutorial and deleted the content of the CatRoot2 folder but I unintentionally deleted the content of the PC I was remoting from instead! (yes I know, don't say anything!)
    In fact, I may have unintentionally deleted the CatRoot folder instead.
    PC was still fine but I was unable to run mmc.exe (to change partitions). I tracked the problem down to the a digital signature in the CatRoot folder I tampered with so I decided to apply a System Restore.

    I rebooted and that was the last time I saw Windows up and running.

    The system is in a constant BSOD loop. Error is "Critical Service Failed". It does not show a STOP code.

    I tried the following:
    - Safe mode - ends with stop 0xc000021a
    - Disable driver signature enforcement - the boot proceeds a bit more but then ends up with a stop code 0xc000021a
    - chkdsk
    - sfc /scannow
    - automatic startup repair
    - Apply other restore points (they all failed and eventually they all disappeared?)
    - Run DISM via command prompt. I get a "the component store is repairable" but it doesn't like my source apparently.
    - Tried boot logging but I cannot find the log file afterwards...

    I appreciate that in these cases a reinstall is the best solution but I really would like to resuscitate the system - I'd like to recover my apps for now. I'm ok if this is not the best/fastest solution.
    I also understand that to run a 'repair install' I need a working Windows installation.

    I am not sure I can find the dump file, I found the attached which has today's date. I managed to open it with a dump file analyzer even though it has a TMP extension.

    My system (apologies if not too detailed, I would need to access Windows to check!):

    Computer name: should be ENTERPRISE
    Windows version: Windows 10 , 1803
    Windows dir: C:\WINDOWS
    Hardware: MSI P67A G65 MB
    CPU: intel 2600K
    RAM: 8GB Crucial

    I've always been so impressed by this forum - you have all my trust guys! :)
    Please do let me know what you require from the system and I'll try to grab that.

    Thank you!
    BSOD reboot loop "CRITICAL SERVICE FAILED" Attached Files
      My ComputerSystem Spec

  2.    4 Weeks Ago #2

    A little update.
    Iíve been playing with DISM. It keeps saying that the source cannot be found. I inspected the logs and it looks like my source file - an install.wim from the same built of windows 10, at least the major build - cannot be accessed. I tried moving the file from a USB drive to a fixed drive but I get the same error message.
    I ran DISM from Windows PE rescue disk found on this forum hoping that it would go online to get the files but no.
    My next test will be to get a copy of the windows folder of another PC I have which is running the same version and try to set that ad a source but Iím skeptics as it seems that there are some issues accessing the files.

    Iíve also tried to investigate on why dump files are not being generated anymore but I canít find the answer. I made some extra space on the drive but that didnít help.
    I found the WMIC command which allows to set the behaviour of the dump file but I canít find a way to tell the command that this is not for the running version of windows (the recovery one).

    Thanks!
      My ComputerSystem Spec

  3. Ztruker's Avatar
    Posts : 7,236
    Windows 10 Pro X64 1809 17763.292
       4 Weeks Ago #3

    Tony, I don't know if this will work or not but I can zip up my catroot2 folder and upload it to OneDrive for you. I'm at 1809 17763.253, the latest public Win 10 version.

    catroot2 is 34.2MB. You could download it and unzip it. It belongs in C:\Windows\System32\catroot2. I don't know if that will fix your problem or not but it's worth a try. You would have to boot from a Win 10 install USB flash drive or DVD and press Shift+F10 when you get to the first install window. That will open a Command Prompt where you can hopefully use unzip.exe that I'll put in the zip file too, to extract the contents of the zip file to C:\Windows\System32\catroot2.

    Let me know if you want to do this or not.

    Edit: If you need Catroot instead of catroot2, I can do that instead or in addition too.

    Did you check the Recycle Bin?
      My ComputersSystem Spec

  4.    4 Weeks Ago #4

    Hi Rich

    Very kind of you, thanks.
    I didnít realise that that could be an option. I have another windows 10 PC in the house, should be running the same identical version. Iíll try replacing the folders

    However, the system was booting up and working ok after messing up with those folders - just the mmc would refuse to start claiming it was not signed if memory serves - and a search revealed me that the digital signature for that component was in Catroot. The booting issue then started when I applied a system restore.

    I am concerned that Iíve tampered with the digital signatures of the system and now the system refuses to execute critical files. Let me try what you suggest and Iíll report back.

    Recycle bin was empty unfortunately - I must have used Shift-Delete...

    That said, if anybody could advise on the DISM source issue Iím having, I feel itíd be nice to make that work.

    Thanks!
    Last edited by tony359; 4 Weeks Ago at 06:48.
      My ComputerSystem Spec


  5. Posts : 23,865
    windows 10 professional version 1607 build 14393.969 64 bit
       4 Weeks Ago #5

    Had you tried regback?
    The RegBack folder is located in :/windows/system32/config, which is used by Windows to hold a recent backup copy of the registry hives.
    This method works on older versions of Windows 10 and may still work on Windows 7, 8, server versions.
    I've not see it tried on Enterprise and it may be worth a try.
    If you want to try it please comment into the thread and the steps will be posted.
      My ComputerSystem Spec

  6.    4 Weeks Ago #6

    Sure, why not. Thanks for your help!
      My ComputerSystem Spec

  7. Ztruker's Avatar
    Posts : 7,236
    Windows 10 Pro X64 1809 17763.292
       4 Weeks Ago #7

    @zbook, the Regback folder is no longer being used. I think Windows 10 stopped using it in 1803. It's now an empty folder. Another terrible decision by Microsoft.

    For DISM source, KYHI posted direction on how to fix it here: SFC SCANNOW and DISM RESTOREHEALTH - Repair Corrupt Files
      My ComputersSystem Spec


  8. Posts : 23,865
    windows 10 professional version 1607 build 14393.969 64 bit
       4 Weeks Ago #8

    The regback method either works or it doesn't.
    There is little risk if any that I'm aware of trying it.
    As commented earlier in the thread it no longer works on Windows 10 unless the end user manually creates the regback folder at sometime before the problems occur.
    I've never tried it on Windows enterprise so its trial and error with your risk tolerance.
    On Windows 7, 8 and server it may still work.

    @ztrucker commented it no longer works automatically in Windows 10 and this has been confirmed in Ten Forums in multiple threads.

    On other websites this has also been confirmed for Windows 10.
    No other website that I've seen has confirmed its failure for Windows Enterprise.
    Technet links displayed that it works for Windows server.
    The windows server are 2008, 2012, etc.

    Windows Server 2012 stuck in Automatic Repair Loop (vmware)


    This is a confirmation on its failure for the latest versions of Windows 10:
    Windows 10 bug prevents Registry backup creation - gHacks Tech News

    The more the feedback to Microsoft the greater the likelihood that this could be fixed.

    See this link for the feedback:
    Cregback empty - batch - Microsoft Community



    https://support.microsoft.com/en-us/...edback-hub-app



    This is a video on the steps that use to work for Windows 10 and again is still believed to work on Windows 7, 8, and server:

    How to Fix Windows 10 Startup Problem - YouTube

    1) boot to the Windows 10 iso
    2) it may take 5 minutes displaying the windows icon
    3) Use the default settings for language, time, currency, and keyboard
    4) click next
    5) In the left lower corner click Repair your computer
    6) click troubleshooting
    7) click startup repair (it is expected to fail)
    8) click system restore (it is expected to fail)
    9) click command prompt
    You should see a pop up with title bar: Administrator: X:\windows\system32\cmd.exe
    This is the registry backup method:
    For each step you must see sizeable file sizes for this to work.
    If you see zeros the method will fail.
    The command: dir
    will be used each step to make sure you are in the proper location and check the size of the files
    10) type: C:
    11) dir
    12) type: D:
    13) dir
    Choose the C: or the D: drive to proceed. It should be the windows drive and not the USB drive.
    14) type: bcdedit | find "osdevice"
    This should display the location of the partition and in most cases is the location of the affected drive.
    For this post I will use C: however you should pick the drive letter that you found that has the windows files on your computer.
    The proper drive will display: perflogs, program files, program files (x86), users, windows, etc
    15) type or copy and paste: cd \windows\system32\config
    It should display: C:\windows\system32\config>
    16) type: dir
    It should display: bbi, bcd-template, components, default, drivers, elam, sam, security, software, system, vsmidk, journal, regback, systemprofile txr, etc.
    All of the file sizes should be sizeable. If it displays zeros then it is likely to fail.
    Make a new directory and name it backup or something similar.
    17) type: MD backup
    Copy all of the files into this new directory.
    18) type or copy and paste: copy *.* backup
    It should now display: bbi, bcd-template, components, default, drivers, elam, sam, security, software, system, vsmidk indicating the files were copied.
    Change the directory to regback
    19) type: cd regback
    It should now display: c:\windows\system32\config\regback>
    20)type: dir
    It should display: default, sam, security, software, system etc
    All of these files must be sizeable. If it displays zeros then it is likely to fail.
    21) type or copy and paste: copy *.* ..
    It should now display:
    DEFAULT
    Overwrite ..\default? (yes/no/all):
    22) type: a
    It should now display: sam, security, software, system and that the files were copied.
    23) type: exit
    24) click turn off your PC
    Remove the USB flash drive if you had changed your boot order. Otherwise you can leave it and power on your computer.
      My ComputerSystem Spec

  9.    4 Weeks Ago #9

    Ztruker said: View Post
    @zbook, the Regback folder is no longer being used. I think Windows 10 stopped using it in 1803. It's now an empty folder. Another terrible decision by Microsoft.
    Doíh!

    Iíll check the DISM guide and report back - thanks for your help so far!!
      My ComputerSystem Spec


  10. Posts : 23,865
    windows 10 professional version 1607 build 14393.969 64 bit
       4 Weeks Ago #10

    This is a link on regback in the windows seven forum.
    There were some posts where it worked in windows 10 but the version was not specified.

    Startup Repair Infinite Loop Recovery - Page 55 - Windows 7 Help Forums

    It is expected to fail (per Ten Forums and gHacks) but is still supposed to work as per this Microsoft link:

    Advanced troubleshooting for Windows boot problems | Microsoft Docs

    If it does not work for you then please use the Microsoft feedback as it may be needed at another time:


    https://support.microsoft.com/en-us/...edback-hub-app
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hi there, I'm encountering a bsod with the error "critical service failed" whenever I power my computer on, and can't seem to get around it. I had just used netplwiz to disable the login screen, then restarted the computer to see if it had...
I was in the middle of a game in BF1 and my computer just crashed out of the blue, lol pun, and went into a reboot loop of BSODs. i tried everything i could in the system troubleshooting and advanced options menu, to include system restore, system...
I am trying to make additional user accounts on my laptop or desktop, but whenever I try to do it on either one I get the following message "User Profile Service service failed to sign in / User profile cannot be loaded" I can't find a...
BSOD Critical Service Failure - Restart Loop in BSOD Crashes and Debugging
Hi everyone. I just turned on my computer this morning and got the bsod. I've surfed on different threads to try and solve my problem but nothing worked: - System restore - On the first attempt i got an error saying that windows could not find a...
When I try to login, I get the following error message: "The User Profile Service service failed the sign-in. User profile cannot be loaded." I am literally unable to use my HP Envy laptop, which is running Windows 10, because of this. I do...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:10.
Find Us