Windows 10: Impossible to set Edge to use google.com...?

  1.    30 Jul 2015 #1

    Impossible to set Edge to use google.com...?


    When I type in google.com in any address bar (Chrome, Edge, Firefox), Google redirects me to google.se (yes I am in Sweden). I don't know why, it really is not the same thing and there are many issues with this, but I guess Google has some idea of its own. Anyway, to get to google.com, I have to type in google.com/ncr. This works fine. But...

    The way to set the default search engine in Edge is to browse to the search page and then to (in Settings > Advanced setting) click Add As Default to add that page as the default search engine. When I do this, Edge erroneously stores google.se, and not the web page address that I initially entered. This is no good.

    Does anyone know of any way to work around this flaw?
      My ComputerSystem Spec

  2.    30 Jul 2015 #2

    OppfinnarJocke said: View Post
    The way to set the default search engine in Edge is to browse to the search page and then to (in Settings > Advanced setting) click Add As Default to add that page as the default search engine...
    When I do this, none of the buttons are active.
      My ComputerSystem Spec

  3.    30 Jul 2015 #3

    nigelmercier said: View Post
    When I do this, none of the buttons are active.
    Yes, it looks that way. You have to select a search provider before the buttons get active.
      My ComputerSystem Spec

  4.    30 Jul 2015 #4

    There is no google.com in Canada: Redirect automatically to google.ca. It's the same in Sweden and that's the way it works. The only way to reach it, is in the cache link of google.com (down arrow).

    Open goggle.se and search google.com and then click the cache link and copy it in the default search of Edge.

    I'm not sure what you want do there and why the Sweden search engine of google is not suitable for you?

    Take care,
      My ComputerSystem Spec

  5.    30 Jul 2015 #5

    The search provider definition is provided by Google, and is part of the headers on their homepage. (right click and choose view source, look for "opensearch"). Google has to change this, nothing Microsoft can do.
      My ComputerSystem Spec

  6.    30 Jul 2015 #6

    Mystere said: View Post
    (right click and choose view source, look for "opensearch").
    Pretty hard to play there...
      My ComputerSystem Spec

  7.    30 Jul 2015 #7

    Sorry but I was not home when I reply and was on a MAC. So, try to paste this link in Edge to see if it's work:
    Google

    Otherwise, read this article. It works fine for me under Opera 30.0.1835.125: Was able to modified the default search engine in my browser. Plus, the no country link (NCR) is working fine and is the same link (above).
    How Google Made It A Little Harder To Reach Google.com From Outside The US

    I hope you'll be able to mark that thread solved.

    All the best,
    Mike
      My ComputerSystem Spec

  8.    30 Jul 2015 #8

    Sorry, it was reset to google.ca in less then an hour. It's not working!
      My ComputerSystem Spec

  9.    31 Jul 2015 #9

    Hi there

    Cheer up -- at least you don't get THIS

    Click image for larger version. 

Name:	google.png 
Views:	3 
Size:	31.0 KB 
ID:	27059

    although you can switch it to English !!

    Cheers
    jimbo
      My ComputerSystem Spec

  10.    31 Jul 2015 #10

    OK, thanks everyone.

    First of all I'm talking about setting up the default search engine. Of course I can manually type in whatever needs to be typed to get me to google.com (there is no link on google.se to get to google.com), but that's not the issue. The issue is setting Edge up to use google.com as the default search engine. And google.se is not the same thing as google.com, the results returned are not the same from the two sites.

    This is very much an Edge issue, since it is possible and not too hard to set this up in Chrome, Firefox, and IE. The issue with Edge is the way you set up the default search engine. I guess MS thought this was a very user-friendly way, just go to the page and click "Set as default", but this gives too little user control over the format of the search string to use. I guess the answer, as usual, lies with the registry and editing things there. I'll poke around and let you know if I find something.
      My ComputerSystem Spec


 

Related Threads
google earth problems in Software and Apps
Iv'e just tried to run Google Earth and it failed. Windows tried to repair it without success, so I uninstalled it. Reinstallation has failed to produce a working copy. I'm sure that it has worked during this build (9926), has anyone had trouble...
Solved Google Earth in Software and Apps
One of my favorite Windows programs is Google Earth, in the couple of previous builds that I installed it on crashed the entire system forcing a Windows repair. I was wondering if anyone here had tried it out in any of the recent builds and how it...
Windows 10 Google account in Browsers and Email
Hi i have windows 10 build 10130. When i try to set up my google account in mail or peoples app, it says "can't connect to service' . Any help?
Source: Official Gmail Blog: The new Google Contacts: Bringing everyone together
Hi there Is it just me or is the google search now getting too unreliable and inaccurate to use. I did a search on "Converting VMWARE to HYPER-V" as I wanted to see if there were easy ways to convert VMware workstation VM's to HYPER-V Vm's...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:15.
Find Us