Windows 10: Firefox unable to complete re-install.... Solved

  1.    28 Oct 2017 #1

    Firefox unable to complete re-install....


    Having had problems earlier with Firefox my default browser decided to remove and re-install, however the new download is unable to complete saying try again. This sounds as though it hasn't uninstalled properly to begin with so any ideas how to resolve this ?

    Thanks :)
      My ComputerSystem Spec


  2. Posts : 2,429
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       28 Oct 2017 #2

    Copy and paste: %APPDATA% To file explorer address box then hit enter. Is there "Mozilla" folder existed ? If so, navigate to
    Firefox\Profiles\xxxxxx.default where xxxxxx is a random character pattern.
    and save places.sqlite to somewhere else, this is your bookmarks.

    Go back and delete "Mozilla" folder then try to re-install Firefox. Once done, replace places.sqlite to get your bookmark back.

    NOTE: if you have created a Firefox account then you will not have to replace places.sqlite.
      My ComputerSystem Spec

  3.    28 Oct 2017 #3

    Thanks no mention of Firefox at all....
      My ComputerSystem Spec


  4. Posts : 2,429
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       28 Oct 2017 #4

    did you navigate to
    C:\Users\YOURUSER\AppData\Roaming\Mozilla\Firefox
      My ComputerSystem Spec

  5.    28 Oct 2017 #5

    Yes removed all mozilla/firefox entries in appdata/roaming but it still won't go any further a notice appearing saying "Hmm there's a problem....".

    No techie at all but could the installer be at fault ?
      My ComputerSystem Spec


  6. Posts : 523
    Win 10 Home Build 1803, 17133.1,64bit
       28 Oct 2017 #6

    Random thoughts: Try each of these until successful.

    could the installer be at fault ?
    Are you downloading from Mozilla or a 3rd party ? Do you use CCleaner ?



    - Run RevoUninstaller Type Firefox in the search box for remnants. https://www.revouninstaller.com/revo..._download.html

    - System Restore (point before Firefox installed) System Restore Windows 10

    - Run sfc/scannow for corrupt files http://https://www.tenforums.com/tut...dows-10-a.html

    - Try Mozilla Support https://support.mozilla.org/en-US/kb...munity-support
      My ComputerSystem Spec

  7.    29 Oct 2017 #7

    First tried Mozilla support as being the quickest to solve it which interestingly it turned out to be. They linked me to a world list of countries so downloaded UK and immediately it went straight through thankfully as I'd been getting nowhere.

    All new to me, so I suppose I must have downloaded another country's link as there's always several available on the Net....
      My ComputerSystem Spec


 

Related Threads
Hello Everyone. I have an issue regarding my HP Deskjet 2540 Printer. Whenever I install the printer it says the printer was unable to be installed correctly. I then do it USB way, still same thing... I finally then proceed to manually install...
Windows started downloading/installing the anniversary update but couldnt complete because of space limit. It has a fix button and if pressed it tries again. I actually dont want the update and have now hid it with the show hide tool. Still in...
Windows unable to complete format in Drivers and Hardware
First of all, the drive on my laptop is DVD RW drive. I can use a CD RW disk in it, can't I? I put a new CD RW disk in and a window popped up asking me if I wanted to format and giving me two options. I didn't think I had to format a new disk....
I have tried to install software from Tachomaster, which has a local postgresql database included with it When it tries to install the database I get the message: rrSQL.Connect : Unable to read data from the transport connection: An existing...
Solved Unable to complete installation in Installation and Upgrade
Hi all. Apologies if this is a repeat topic, I had a look and couldn't see anything here that answered my question. I'm trying to do a fresh install of Windows 10 on a laptop. The laptop was previously on 7. I am also replacing the HDD with an...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:14.
Find Us