Windows 10: Flakey Edge since 1709 Update Solved

Page 1 of 2 12 LastLast
  1.    19 Oct 2017 #1

    Flakey Edge since 1709 Update


    I've noticed several Edge "glitches" since the 1709 update (that I don't have on the Insider's versions).
    One time I couldn't right click on a link to copy it in Edge. Restarted Edge and it was OK.
    Another time (after a reboot), I started Edge and the Icons for links on the Favorites Bar were missing (links worked).
    This morning the "scroll" section of msn.com, my home page, would not scroll from one item to another.

    Fortunately, Firefox is working OK.

    My PC is a desktop with an i7 6700K, 16GB RAM, SSD, Intel CPU Video and Windows Defender. Very "vanilla" as I also use this for my recording studio.
      My ComputersSystem Spec

  2.    21 Oct 2017 #2

    This morning, first time I ran Edge, RIGHT click did not work in Edge. Restarting Edge fixed it.
    This is the second time for this problem.
      My ComputersSystem Spec

  3.    23 Oct 2017 #3

    I suggest you next time, before you restart the edge, write a feedback through the option inside the Edge. If I remember correct, there exist an option to auto-include technical logs. Next solution is to search for any way to deep reset the Edge. For example, refresh the user edge profile.
      My ComputerSystem Spec

  4.    24 Oct 2017 #4

    When it happens, Edge is usually corrupted to the point the only option is to restart.


    As a side note, I was in Tommy Cash's touring band for 7 years. Tommy is Johnny Cash's younger brother.
    Last edited by fireberd; 24 Oct 2017 at 09:02.
      My ComputersSystem Spec

  5.    24 Oct 2017 #5

    fireberd said: View Post
    One time I couldn't right click on a link to copy it in Edge. Restarted Edge and it was OK.
    I posted the same issue here but it was completely blown off. Anyway I too have the issue where I can't right click links to copy from Edge. In fact, I currently have it now. Had to Ctrl + C to copy the link in this post.

    Oh, yeah, non insider as well.
      My ComputerSystem Spec

  6.    24 Oct 2017 #6

    I assumed there had to be others. Likely more than just us two.

    I have a disc image that was made before the upgrade. I'm going to fall back and let Windows install the upgrade again and see what happens. I'll post the results. May be a couple days because of recording studio schedules.

    Thanks/Jack
      My ComputersSystem Spec

  7.    24 Oct 2017 #7

    It seems Edge has become a flaky mess since this update as I discover another issue on TWO PC's - trying to upload files whether here or someplace else tends to crash Edge at times. Had it happen once here, now have it happening at dpreview.com (a photography site).

    And YES, the files fit the parameters required for uploading. Been doing it for a long time here and at DP so that's not the issue. Between the copy bug and now the upload bug, things are starting to get real annoying now.
      My ComputerSystem Spec

  8.    25 Oct 2017 #8

    Another issue I've run across is compatibility of one web site, a local TV station site. It almost always goes to "not responding" on this site. No problems with others I visit.

    Tampa News & Weather | Clearwater Florida, Sarasota, FL | WFLA.com
      My ComputersSystem Spec

  9.    25 Oct 2017 #9

    ^ I haven't encountered obvious glitches on mine so far fortunately. Even that Tampa News link works perfectly fine.
      My ComputerSystem Spec

  10.    25 Oct 2017 #10

    Two us on this thread are having Edge problems. There are others.

    However, I have the Win 10 "insider" advance versions and not having the problem there. That is why I'm going to fall back to my disc image I made before the Fall CU and try again.
      My ComputersSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I am experiencing something strange. I have Windows 10 home 32 bit version 1703 on my hp pavillion x2 and I cannot update it to 1709. Windows Update returns an error after downloading the feature update, Windows Update Assistant reports that I have...
Update 1709 failed when applying updates in Windows Updates and Activation
So, I got 1709 update via Windows Update. Download and install went through. After I got notification to restart to apply 1709 update, I restart, and applying update message shown, until 30%. Then it restarts twice, then message "Reverting to...
A new KB4041994 update has been released via Windows Update for Windows 10 version 1709 for Insiders in the Fast and Slow rings only (not Skip Ahead). The build number was not changed. Restart is not required. Release notes have not yet...
Tried Update from existing 1703 and all is working. But after clean install no player works with .mp4 files, even I installed the same codec package. Anybody the same problem or knows a solution?
Read more: No surprise: Microsoft documentation refers to Windows 10 version 1709
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:24.
Find Us