Page 1 of 2 12 LastLast
  1.    28 Sep 2017 #1
    Join Date : Sep 2017
    Posts : 5
    Windows 10

    Microsoft Edge Has Difficulty Loading Google


    Hello:

    Recently Microsoft Edge takes nearly 30 seconds to load the Google.ca page, whereas Firefox loads the same page in less than one second. This is happening on 2 workstations and one tablet in my household and there is a mixture of Ethernet and Wifi connections, but it happens on all three machines. Microsoft Edge is also slow to display Google search results as well, and general internet surfing.

    It seems to have gotten worse recently. Can anyone please assist, or does anyone know what is going on, other than Microsoft Edge simply sucking? I also know that it isn't the fault of my internet connection. Please see the image below.

    Thanks,

    Grayson

    Click image for larger version. 

Name:	Speedtest Result.JPG 
Views:	1 
Size:	172.8 KB 
ID:	155430
      My ComputerSystem Spec
  2.    28 Sep 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,133
    Windows 10 Pro Build 1703

    What happens if you just search from Address bar. You may need to set default search engine to Google to do this. Open Google page and then enter Edge settings, it will discovery Google and allow you to set as default search.

    Love the speed. You must be on Gigabit package. I just went for 150 Meg, get 180 and pay less than I did on 100Meg. Not sure why Rogers makes us fight them.

    No comment on Edge, I use Chrome.

    Ken
      My ComputerSystem Spec
  3.    28 Sep 2017 #3
    Join Date : Sep 2017
    Posts : 5
    Windows 10
    Thread Starter

    Hi Ken, thanks for the reply. I'm not on Gigabit yet; it's already across the street at my neighbour, but not on my side until November.

    Google is already set as the default search engine. Even when searching from the address bar, Microsoft Edge is still very slow to render results or surf.
      My ComputerSystem Spec
  4.    28 Sep 2017 #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,133
    Windows 10 Pro Build 1703

    Well no point in paying for it if they are going to give you +300.

    Well I have no proof but I guess if you wanted people to use Bing you could craft a little code to choke it.

    Does it behave the same when you use "InPrivate" mode.
      My ComputerSystem Spec
  5.    28 Sep 2017 #5
    Join Date : Oct 2014
    Posts : 364
    Win 10 Home Build 1709 16299.19 64bit

    What is your default search engine for Edge ? If not Google, may change if that is your desire.

    Also, do you have any Edge extensions that could effect the performance ? May disable to see if any difference.
      My ComputerSystem Spec
  6.    28 Sep 2017 #6
    Join Date : Sep 2017
    Posts : 5
    Windows 10
    Thread Starter

    The default search engine for Edge is Google. How do I check for the extensions?
      My ComputerSystem Spec
  7.    28 Sep 2017 #7
    Join Date : Oct 2014
    Posts : 364
    Win 10 Home Build 1709 16299.19 64bit

    Go to menu (three dots, upper right) and scroll down to Extensions.

    https://winaero.com/blog/reset-edge-windows-10/

    Also, may want to reset Edge and do a scan with your AV for malware.

    Edit: And Adw Cleaner. https://www.malwarebytes.com/adwcleaner/
      My ComputerSystem Spec
  8.    28 Sep 2017 #8
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 8,984
    Windows 10 (Pro and Insider Pro)

    Default search engine doesn't affect this. I have Bing as default and Google opens momentarily.

    torre above gave some good advice.
      My ComputerSystem Spec
  9.    28 Sep 2017 #9
    Join Date : Sep 2017
    Posts : 5
    Windows 10
    Thread Starter

    Hi Torre:

    I have reset Edge and performed scans using Malwarebytes. Nothing came up.

    Is there anything else I should look into?

    Thanks,

    Grayson
      My ComputerSystem Spec
  10.    30 Sep 2017 #10
    Join Date : Feb 2016
    Maribor, Slovenia
    Posts : 8,984
    Windows 10 (Pro and Insider Pro)

    If this problem persist, you could try to change DNS servers in router, or on your PC first. Open Network and sharing center (in Control panel)
    and in your network card properties select IPv4 settings. Put there 8.8.8.8 for start (Google DNS)

    Click image for larger version. 

Name:	image.png 
Views:	9 
Size:	32.1 KB 
ID:	155856
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Microsoft Edge not loading since last night updates, help me please.
I downloaded a new update when it kept prompting me to do so. Now Microsoft Edge does not work at all. ME will not even load and many other apps also. I need this fixed please or I will have to go with another browser like Google Chrome, it is the...
Browsers and Email
Microsoft Edge vs Google Chrome vs Firefox
I have had problems with Edge opening my Facebook etc very slowly. I even downloaded Firefox to see if it was faster. I prefer Chrome. It is much faster than Edge or Firefox. However, there is something weird happening. When I start my computer and...
Browsers and Email
Microsoft Edge: Not Responding while loading certain Websites
Microsoft Edge: Tab says it's not responding while loading certain Websites Whenever I look up different things on certain websites, the tab in my Edge browser says it's not responding while loading the page. This site (Windows 10 Forums)...
Browsers and Email
Microsoft Edge and IE Blocks google to install please help
So, i reset my laptop fully trying to install Google chrome please and blocks downloading.
Browsers and Email
Edge and IE Not Loading Google and Other Sites Normally
I am having a terrible time trying to get google.com and my gmail hosted web-mail to load at a normal speed or to even load at all. I have tried both Edge and IE. I am trying to stick with these two to take full advantage of the new features in...
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:41.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums