Windows 10: Edge Stopped Working as denoted in Reliability History

  1.    20 Sep 2017 #1

    Edge Stopped Working as denoted in Reliability History


    Win10 v1703 build 15063.608

    Good Afternoon:

    I'm running Chrome (default), Edge, and IE11 on a 64 bit Win10 laptop. I recently Clean Installed Win10.

    When I check Reliability History, I get a clean report for days and weeks, until I use Edge. Everyday that I use Edge, I get a Application failure with a red "x" stating that "Edge Stopped Working". I search for solutions, and try the occasional fix suggested, including reset and clear cache and cookies, but nothing works. While using Edge I occasionally get a pop-up telling me my connection is disconnected, but I select re-connect and everything continues along unaffected. Otherwise it seems to work fine. But on those few occasions that I try it I get an App Failure in Reliability History. I do not get a Disconnect pop up or Application failure with either Chrome or IE11.

    Has anyone else had this problem with Edge?

    Maddening...
      My ComputerSystem Spec


  2. Posts : 3,479
    64bit Win 10 Pro ver 1803 Build 17134.165 and W10 Insider Build 17713
       21 Sep 2017 #2

    There have been a lot of Edge problems with the latest build. After about three days they seemed to go away for me.

    See Cumulative Update KB4038788 Windows 10 v1703 Build 15063.608and following posts.
      My ComputersSystem Spec

  3.    21 Sep 2017 #3

    Thank you philc43. I'll review the Link you suggest, and wait for Microsoft to fix...
      My ComputerSystem Spec


  4. Posts : 717
    Windows 10 Home x64 Version 1803 (OS Build 17134.167)
       21 Sep 2017 #4

    Since that KB4038788 update my Edge fails about once every other day. It rarely ever gives any indication of a failure. I started keeping an eye on it with Reliability History. This is what I get for details:

    Click image for larger version. 

Name:	Capture.PNG 
Views:	17 
Size:	31.0 KB 
ID:	154354

    Does make me wonder.
      My ComputersSystem Spec

  5.    21 Sep 2017 #5

    Yes, that's pretty much it. I get it frequently too, and haven't found a fix...but been trying.

    Good luck to you too.

    Thanks for your note.
      My ComputerSystem Spec


  6. Posts : 7,707
    10 Home x64 (1803) (10 Pro on 2nd pc)
       21 Sep 2017 #6

    A few days after the update was released Microsoft updated the list of 'known issues' in its KB article to include Edge problems.

    After installing this update, some users may observe performance or unresponsiveness issues on the first launch of the Microsoft Edge browser. Closing and restarting Microsoft Edge will alleviate this issue. This issue may appear periodically.
    Microsoft is working on a resolution and will provide an update in an upcoming release.
    https://support.microsoft.com/en-us/help/4038788
      My ComputersSystem Spec


  7. Posts : 717
    Windows 10 Home x64 Version 1803 (OS Build 17134.167)
       21 Sep 2017 #7

    As always, Thanks Bree.
      My ComputersSystem Spec

  8.    21 Sep 2017 #8

    It pays to read the small print. Thank you Bree for being so thorough. Now I'm assured a fix is on the way.

    Thx to all who replied and offered advice.
      My ComputerSystem Spec

  9.    26 Sep 2017 #9

    Despite Cumulative Update KB4040724 provided on September 25 and intended to fix the Edge problem, my issue continues unabated. Reliability History shows 3 Edge failures already today, and it's still morning.

    Glad we have other browser choices.
      My ComputerSystem Spec


 

Related Threads
Just saw this this morning. System has been running fine 150070
I have upgraded to Windows 10 first my laptop and, more recently, my desktop. I use Reliability Monitor daily. Three days into Windows 10, Reliability Monitor on my desktop reported an application failure yesterday: "Cortana - stopped working". ...
I've used gpedit to allow manual control of updates and manually download and install updates when available, and I set "Notifiy to download" option. That gave me control similar to what I had with Win7. Or so I thought. But the Reliability...
When I go to control panel > Security and Maint. > Maint. > View reliability history nothing happens, and control panel closes. This happened in the last build also.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:40.
Find Us