Page 1 of 2 12 LastLast
  1.    12 Aug 2017 #1
    Join Date : Oct 2015
    Posts : 28
    windows 10

    Edge always says "Can't reach this page" and won't work


    Hi all,

    I'm an insider running build 16257, and have a problem. I have two insider computers, but one has a problem. Whatever url I may enter or click any bookmark, it says "Can't reach this page" and won't work.

    How can I fix this? sfc /scannow found no problems.

    Thank in advance!

    EDIT: I attached a screenshot of Edge. Firefox and Chrome and other Internet apps are working fine. I checked the diskimage with "Dism /Online /Cleanup-Image /CheckHealth" and it's healthy.
    Attached Thumbnails Attached Thumbnails 2017-08-13.png  
    Last edited by maverick6664; 12 Aug 2017 at 17:27.
      My ComputerSystem Spec
  2.    12 Aug 2017 #2
    Join Date : Nov 2013
    Chicagoland
    Posts : 33,747
    Dual boot Windows 10 FCU Pro x 64 & Insider 10 Pro

    Hi there. You may want to run scannow also.

    If that doesn't work, try this: Reinstall and Re-register Microsoft Edge in Windows 10 Windows 10 Browsers Email Tutorials
      My ComputersSystem Spec
  3.    12 Aug 2017 #3
    Join Date : Oct 2015
    Posts : 28
    windows 10
    Thread Starter

    Quote Originally Posted by HippsieGypsie View Post
    Hi there. You may want to run scannow also.

    If that doesn't work, try this: Reinstall and Re-register Microsoft Edge in Windows 10 Windows 10 Browsers Email Tutorials
    Thank you for suggestion. sfc /scannow says the system files has no inconsistency. So I tried reinstall and re-register edge as mentioned. The procedure succeeded, but Edge doesn't work yet...

    One more funny thing is that "New Application Guard Window" somehow works fine.

    Hmmm....

    Regards,
      My ComputerSystem Spec
  4.    13 Aug 2017 #4
    Join Date : Nov 2013
    Chicagoland
    Posts : 33,747
    Dual boot Windows 10 FCU Pro x 64 & Insider 10 Pro

    Quote Originally Posted by maverick6664 View Post
    Thank you for suggestion. sfc /scannow says the system files has no inconsistency. So I tried reinstall and re-register edge as mentioned. The procedure succeeded, but Edge doesn't work yet...

    One more funny thing is that "New Application Guard Window" somehow works fine.

    Hmmm....

    Regards,
    That's strange. The only thing I can think of is running the network troubleshooter.

    Control Panel > Troubleshooting > Connect to the Internet.
      My ComputersSystem Spec
  5.    13 Aug 2017 #5
    Join Date : Oct 2015
    Posts : 28
    windows 10
    Thread Starter

    Quote Originally Posted by HippsieGypsie View Post
    That's strange. The only thing I can think of is running the network troubleshooter.

    Control Panel > Troubleshooting > Connect to the Internet.
    I tried it now, but it says no problem found.....sigh Actually other browsers (chrome, firefox) and email program (Thunderbird) work fine.
      My ComputerSystem Spec
  6.    13 Aug 2017 #6
    Join Date : Nov 2013
    Chicagoland
    Posts : 33,747
    Dual boot Windows 10 FCU Pro x 64 & Insider 10 Pro

    Quote Originally Posted by maverick6664 View Post
    I tried it now, but it says no problem found.....sigh Actually other browsers (chrome, firefox) and email program (Thunderbird) work fine.
    Is Edge set as your default browser?
      My ComputersSystem Spec
  7.    13 Aug 2017 #7
    Join Date : Nov 2013
    Chicagoland
    Posts : 33,747
    Dual boot Windows 10 FCU Pro x 64 & Insider 10 Pro

    Learning about Edge, Bob?
      My ComputersSystem Spec
  8.    13 Aug 2017 #8
    Join Date : Oct 2015
    Posts : 28
    windows 10
    Thread Starter

    Quote Originally Posted by HippsieGypsie View Post
    Is Edge set as your default browser?
    No. That's the good thing to me So don't worry so much.

    BTW I posted this problem on Microsoft tech forum also, and the Microsoft guy asked me if I used proxy, but I don't use one.
      My ComputerSystem Spec
  9.    13 Aug 2017 #9
    Join Date : Nov 2013
    Chicagoland
    Posts : 33,747
    Dual boot Windows 10 FCU Pro x 64 & Insider 10 Pro

    Quote Originally Posted by maverick6664 View Post
    No. That's the good thing to me So don't worry so much.
    Just for grins try changing it to default just to see if that works. I'm curious. You can always change it back.
      My ComputersSystem Spec
  10.    13 Aug 2017 #10
    Join Date : Oct 2015
    Posts : 28
    windows 10
    Thread Starter

    Quote Originally Posted by HippsieGypsie View Post
    Just for grins try changing it to default just to see if that works. I'm curious. You can always change it back.
    Now I tried it, but things didn't change. Edge can't connect to any site. It looks like it is cut off from the Internet.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Prevent "My Feeds" from Showing in Edge Start Page
Hello all, I have been reading and following the community here for a while now. Thanks for all the indirect help! The expected behavior with my settings of Edge, and what I see on every other Windows 10 setup, is that Edge should open with...
Browsers and Email
Using Edge, can I save a web page in ".mht" or an equivalant format?
In IE, with one click I can easily save a web site page as a ".mht", which captures the entire web page (as opposed to a "snip" which gets only the part of the web view that is currently visible) plus the mht keeps any embedded links to other...
Browsers and Email
Change " edge" to different home page
Hi guys looking for some help on setting my home page in the Edge (spartan) which ever they call it by ! Everything i try does not work, i have tried >>> Microsoft Edge - Reinstall and Re-register in Windows 10 - Windows 10 Forums and also >>>...
Browsers and Email
Solved Edge: Hmm, we canít reach this page?
I've set Google as my search provider in Edge. If I open a new tab and type where it says: Search or enter web address, I get: Hmm, we canít reach this page. Try this ēMake sure youíve got the right URL: http://windows%207%20iso%20download...
Browsers and Email
Solved delete "saved password" and "form data" from microsoft edge manually
Hello how can I delete "saved password" and "form data" of microsoft edge manually ?! after too much search in google .... I trid to delete some value of the following registry address HKEY_CURRENT_USER\SOFTWARE\Classes\Local...
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:33.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums