YouTube won't play on Microsoft Edge

Page 1 of 3 123 LastLast

  1. Posts : 127
    Windows 10 Professional 64X
       #1

    YouTube won't play on Microsoft Edge


    I was trying to figure out why is YouTube not playing on the browser of Microsoft Edge. I have read different articles online trying to solve this problem. With Google Chrome YouTube is working with no problem but not Microsoft Edge. Is there a reason why can't YouTube run on the Microsoft Edge browser. I did try to fix one part and still the same. The one is from Microsoft Help. And here is below:

    This might fix Edge as well. Not positive.

    1: Open Internet Explorer.
    2: Click the Tools button and go to Internet Options.
    3: On the Advanced tab, browse to the Accelerated graphics section.
    4: Select: Use software rendering instead of GPU rendering.
    5: Click Apply & OK.
    6: Restart your computer and test it.

    I did check in the box with " Use software rendering instead of GPU rendering. Still no help.

    What is the other alternative to fix this problem?

    Thank you,

    John
      My Computer


  2. Posts : 273
    Windows 10 Pro 1709 x64
       #2

    Internet explorer is different from Edge so those settings are not applicable
      My Computer


  3. Posts : 127
    Windows 10 Professional 64X
    Thread Starter
       #3

    Thank you for your reply. Now may I ask you if you are quoting that Internet Explorer is different from Microsoft Edge for YouTube. But I have seen several people are using YouTube on Microsoft Edge. So I believe that it can work on this browser but I need to get this fix before using YouTube on Microsoft Edge. Yes I have used Internet Explorer with YouTube and no problem to show on the browser. I prefer to have one browser not two with Internet Explorer and Microsoft Edge.

    John
      My Computer


  4. Posts : 1,767
    Windows 10 Home
       #4

    I use youtube on Edge a LOT. Do you get audio but no video or neither ? First thing to check is if you have Flash enabled.
    Hit the hamburger menu in upper R corner/Settings/View Advanced Settings. Then turn on 'Use Adobe Flash Player' which will get security updates thru Windows Update in the future

    YouTube won't play on Microsoft Edge-screenshot_1.jpg
      My Computer


  5. Posts : 127
    Windows 10 Professional 64X
    Thread Starter
       #5

    Just checked to see what I have my Adobe Flash Player in advanced settings and already is on.

    So this have to be something else with the problem of YouTube on Microsoft Edge.

    John
      My Computer


  6. Posts : 2,354
    Windows 10
       #6

    YouTube uses HTML5 Player in preference to Flash Player.
    Edge uses HTML5 Player it does not matter whether Flash is enabled or not.
    Works OK with either here, with Flash Player you may need to enable via the puzzlepiece icon in the address bar on some websites.
    https://www.youtube.com/html5
      My Computer



  7. Posts : 25,314
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #7

    In Edge, try typing about:flags in the address bar to get the Developers Settings page. Then click the 'Reset all flags to default' button.
      My Computers


  8. Posts : 127
    Windows 10 Professional 64X
    Thread Starter
       #8

    Bree -- I did that already and still no show to get working on YouTube in Edge browser. Thank you for your tip about reset all flags to default button.

    Helmut -- I copy and paste the link that you posted above and came on Edge browser. Show me that all six boxes with blue that support on Edge browser with no problem.

    But can't get YouTube site to work on Edge browser. The only way is that I can run YouTube on Internet Explorer to watch the videos unless someone have a better solution to solve the problem with Adobe Flash or Microsoft Edge to let YouTube run the videos on Edge browser.

    Thank you,

    John
      My Computer


  9. Posts : 127
    Windows 10 Professional 64X
    Thread Starter
       #9

    Hello everyone and still nothing with this Adobe Flash -- still the same as before. Any idea how to fix or recover this problem?

    John
      My Computer


  10. Posts : 3,085
    W10 Pro + W10 Preview
       #10

    Open All Settings....click on Apps.....then Default Apps......then click on Reset.....see attachment.
    Attached Thumbnails Attached Thumbnails YouTube won't play on Microsoft Edge-reset.jpg  
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:36.
Find Us




Windows 10 Forums