Page 1 of 3 123 LastLast
  1.    15 Jul 2017 #1
    Join Date : Apr 2015
    Posts : 68
    Windows 10 Professional 64X

    YouTube won't play on Microsoft Edge


    I was trying to figure out why is YouTube not playing on the browser of Microsoft Edge. I have read different articles online trying to solve this problem. With Google Chrome YouTube is working with no problem but not Microsoft Edge. Is there a reason why can't YouTube run on the Microsoft Edge browser. I did try to fix one part and still the same. The one is from Microsoft Help. And here is below:

    This might fix Edge as well. Not positive.

    1: Open Internet Explorer.
    2: Click the Tools button and go to Internet Options.
    3: On the Advanced tab, browse to the Accelerated graphics section.
    4: Select: Use software rendering instead of GPU rendering.
    5: Click Apply & OK.
    6: Restart your computer and test it.

    I did check in the box with " Use software rendering instead of GPU rendering. Still no help.

    What is the other alternative to fix this problem?

    Thank you,

    John
      My ComputerSystem Spec
  2.    15 Jul 2017 #2
    Join Date : Jan 2015
    Los Angeles
    Posts : 260
    Windows 10 Pro 1709 x64

    Internet explorer is different from Edge so those settings are not applicable
      My ComputerSystem Spec
  3.    16 Jul 2017 #3
    Join Date : Apr 2015
    Posts : 68
    Windows 10 Professional 64X
    Thread Starter

    Thank you for your reply. Now may I ask you if you are quoting that Internet Explorer is different from Microsoft Edge for YouTube. But I have seen several people are using YouTube on Microsoft Edge. So I believe that it can work on this browser but I need to get this fix before using YouTube on Microsoft Edge. Yes I have used Internet Explorer with YouTube and no problem to show on the browser. I prefer to have one browser not two with Internet Explorer and Microsoft Edge.

    John
      My ComputerSystem Spec
  4.    16 Jul 2017 #4
    Join Date : Jul 2015
    Posts : 870
    Windows 10 Home

    I use youtube on Edge a LOT. Do you get audio but no video or neither ? First thing to check is if you have Flash enabled.
    Hit the hamburger menu in upper R corner/Settings/View Advanced Settings. Then turn on 'Use Adobe Flash Player' which will get security updates thru Windows Update in the future

    Click image for larger version. 

Name:	Screenshot_1.jpg 
Views:	65 
Size:	36.2 KB 
ID:	144190
      My ComputerSystem Spec
  5.    16 Jul 2017 #5
    Join Date : Apr 2015
    Posts : 68
    Windows 10 Professional 64X
    Thread Starter

    Just checked to see what I have my Adobe Flash Player in advanced settings and already is on.

    So this have to be something else with the problem of YouTube on Microsoft Edge.

    John
      My ComputerSystem Spec
  6.    20 Jul 2017 #6
    Join Date : Nov 2016
    Posts : 422
    Windows 10

    YouTube uses HTML5 Player in preference to Flash Player.
    Edge uses HTML5 Player it does not matter whether Flash is enabled or not.
    Works OK with either here, with Flash Player you may need to enable via the puzzlepiece icon in the address bar on some websites.
    https://www.youtube.com/html5
      My ComputerSystem Spec
  7.    20 Jul 2017 #7
    Join Date : Aug 2016
    S/E England
    Posts : 4,488
    10 Home x64 (1709) (10 Pro on 2nd pc)

    In Edge, try typing about:flags in the address bar to get the Developers Settings page. Then click the 'Reset all flags to default' button.
      My ComputersSystem Spec
  8.    20 Jul 2017 #8
    Join Date : Apr 2015
    Posts : 68
    Windows 10 Professional 64X
    Thread Starter

    Bree -- I did that already and still no show to get working on YouTube in Edge browser. Thank you for your tip about reset all flags to default button.

    Helmut -- I copy and paste the link that you posted above and came on Edge browser. Show me that all six boxes with blue that support on Edge browser with no problem.

    But can't get YouTube site to work on Edge browser. The only way is that I can run YouTube on Internet Explorer to watch the videos unless someone have a better solution to solve the problem with Adobe Flash or Microsoft Edge to let YouTube run the videos on Edge browser.

    Thank you,

    John
      My ComputerSystem Spec
  9.    09 Aug 2017 #9
    Join Date : Apr 2015
    Posts : 68
    Windows 10 Professional 64X
    Thread Starter

    Hello everyone and still nothing with this Adobe Flash -- still the same as before. Any idea how to fix or recover this problem?

    John
      My ComputerSystem Spec
  10.    09 Aug 2017 #10
    Join Date : Oct 2014
    Posts : 2,456
    W10 Pro + W10 Preview

    Open All Settings....click on Apps.....then Default Apps......then click on Reset.....see attachment.
    Attached Thumbnails Attached Thumbnails reset.jpg  
      My ComputersSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
YouTube videos do not play in Chrome
Hello Everybody! Today I wanted to watch some YouTube videos but the videos never played. If I press the Play button it doesn't play but I can drag the slider around. It has been happening for a few days and it's getting really annoying!...
Browsers and Email
Solved The youtube fails to play in user account without admin privilages
Hello Mine Win 10 x64 version 1607. I have all the latest updates installed. I do not have flash player installed. The desk top has two user accounts. One with Administrator privileges. I find you tube plays fine when accessed the user account...
Browsers and Email
edge and fullscreen youtube problem
When i see a YouTube film on full screen and afterwards press esc than there is a problem. By taskbar is on top of the screen. And after pressing esc button the tabs are behind the taskbar why ?
Browsers and Email
Youtube app that can play live streams?
Is there a Youtube app for Windows 10 that can play live streams, streams like sky news, concerts and other live events? Tried several apps but none of them could do this.
Software and Apps
Cannot play video with Microsoft Edge or Internet Explorer 11
Greetings everyone: When going to the following page, there is a video, it plays in Chrome but not Internet Explorer 11 or Edge, anyone knows what plug-in is actually used and how to fix it as it's the same reason moji's are not playing in skype....
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:06.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums