Windows 10: Browsing is Very Slow on Both Edge and Chrome

  1.    15 Jul 2017 #1

    Browsing is Very Slow on Both Edge and Chrome


    So I got a new Asus E200HA. Read some very good reviews about it in amazon.
    While using the OS (Windows 10) everything works quite smoothly - Browsing around files, editing Office documents, even coding on VS Code. However, Web browsing, for the most part, is extremely slow. Facebook is almost unusable. Ebay, Amazon etc. scroll quite slowly. I've tried multiple ad blockers, but that didn't help. Any advice? I know my CPU is quite slow but everything other than web browsing works well. I also tried disabling some services, like windows search, but that didn't noticeably improve performance. I'm using a fresh OEM Windows 10 Home, with all bloatware removed. Maybe I should use a different windows build?

    Thanks in advance,

    Samuel
    Last edited by mulic3; 15 Jul 2017 at 17:36.
      My ComputerSystem Spec


  2. Posts : 363
    Win 10 Home Build 1709 16299.19 64bit
       15 Jul 2017 #2

    https://www.tenforums.com/gtsearch.p...&sa.x=0&sa.y=0


    - Above link is for similar problems.


    - Do you have all the Win10 updates ? (Settings/Update&Security)

    - Check internet speed.

    - Check Device Manager to see if Network Adapter drivers are current

    - Go to the Asus site to insure you have the latest drivers.
      My ComputerSystem Spec

  3.    16 Jul 2017 #3

    Do you have any other computers in the same location to see if it's your Asus that is slow? I've switched to Opera for most of my browsing and it seems quicker than other browsers.
      My ComputerSystem Spec


  4. Posts : 2,096
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)
       16 Jul 2017 #4

    Check your internet speed connection and inSSIDer to check your WiFi signal level - see http://www.majorgeeks.com/files/details/inssider.html

    Check your WiFi driver is up to date and maybe consider changing the WiFi channel on your router if inSSIDer shows co-channel signals from neighbours.
      My ComputersSystem Spec

  5.    16 Jul 2017 #5

    Thanks for all the help.
    My OS is up to date with the latest updates and the latest drivers from asus website.
    My network is fine as I can download files in 4mbps at any given moment. Also, other laptops work fine.
    Some websites, like this one for example, work great. But others, like facebook, my university website and others, are painfully slow. Any ideas?

    Thanks again,

    Samuel
      My ComputerSystem Spec


  6. Posts : 363
    Win 10 Home Build 1709 16299.19 64bit
       16 Jul 2017 #6

    starflyr said: View Post
    Do you have any other computers in the same location to see if it's your Asus that is slow? .

    If you do not have another computer, take the Asus to another location to see if any difference.

    - Have you tried both Wifi and Ethernet ?

    - Is 4mpbs the standard in Israel ? Check with your ISP to see if they are having any issues ?

    - Run scan with your AV and run AdW Cleaner.


    https://www.malwarebytes.com/adwcleaner/
      My ComputerSystem Spec

  7.    16 Jul 2017 #7

    torre said: View Post
    If you do not have another computer, take the Asus to another location to see if any difference.

    - Have you tried both Wifi and Ethernet ?

    - Is 4mpbs the standard in Israel ? Check with your ISP to see if they are having any issues ?

    - Run scan with your AV and run AdW Cleaner.


    https://www.malwarebytes.com/adwcleaner/
    Thanks. As I mentioned above, other laptops work great. My download speed is similar on all computers in the house, but browsing is slow on my new Asus E200HA. Maybe it's just due to its' low power cpu? Is there something that can be done to make it nippier? Thanks again.
      My ComputerSystem Spec


  8. Posts : 363
    Win 10 Home Build 1709 16299.19 64bit
       16 Jul 2017 #8

    http://www.trustedreviews.com/asus-e200ha-review


    Ah, now we know. Not familiar with Asus. Review above may be helpful.

    Intel Atom processor, 2GB ram, basically a tablet. Hopefully, someone may have tips for better performance.
    A friend had the same issue, can't recall if it was an Asus. He basically conceded to the low performance.
      My ComputerSystem Spec

  9.    16 Jul 2017 #9

    torre said: View Post
    http://www.trustedreviews.com/asus-e200ha-review


    Ah, now we know. Not familiar with Asus. Review above may be helpful.

    Intel Atom processor, 2GB ram, basically a tablet. Hopefully, someone may have tips for better performance.
    A friend had the same issue, can't recall if it was an Asus. He basically conceded to the low performance.
    Actually mine has 4GB of ram. But yes, the cpu is quite weak. It seems, as if, magically, browsing performance has improved a bit..
      My ComputerSystem Spec

  10.    25 Jul 2017 #10

    mulic3 said: View Post
    Actually mine has 4GB of ram. But yes, the cpu is quite weak. It seems, as if, magically, browsing performance has improved a bit..
    Just as I was about to report that it was an anti virus issue (I uninstalled nod32 8.0 and installed version 10 which made the browsing much more smooth), it is slow again. I uninstalled nod32 completely, didn't help. disabled defender, didn't help. How can it be? I'm using a fully updated genuine windows 10, and everything was smooth smooth for quite some time. I really start to dislike windows 10...
      My ComputerSystem Spec


 

Related Threads
BSOD during web browsing in Chrome in BSOD Crashes and Debugging
I just upgraded my platform (config below) about week ago, all listed components were new. After a couple of days I started to receive BSOD's (dump files attached). Till now I encountered them only during watching an online stream on twitch or a...
BSOD during Chrome browsing in BSOD Crashes and Debugging
I have received multiple BSOD with various codes, always during browsing on Chrome Most commonly "CRITICAL_PROCESS_DIED" but also KERNEL_DATA_INPAGE_ERROR what failed: dxgmm2.sys I downloaded the tool from advice on another thread but started...
Hello all, I've had this laptop for about 3 months now. I was browsing the web today and watching Twitch.tv while I suddenly received a BSOD with the error message "Bad_Pool_Caller" in it. This is the first time I've received a BSOD on this...
BSOD while browsing Chrome and Firefox in BSOD Crashes and Debugging
Hello, Im facing BSOD many times while browsing internet using chrome, even i tried firefox both having same problem. My screen get artifacts block block all screen and freeze after 5 seconds. Gaming on computer more then hours no issue at all....
While browsing using Chrome, a BSOD occurred with the following error NETIO.SYS please give code to system adminstrator.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:19.
Find Us