Page 1 of 2 12 LastLast
  1.    19 May 2017 #1
    Join Date : May 2017
    Posts : 8
    Window 10

    Microsoft Edge crashing on startup since most recent windows update


    Hoping you all can help me with a sticky issue here, as my google-fu is failing me.

    The issue:
    Since installing the most recent windows updates (May 2017) Certain users at my organization are reporting that Edge is crashing almost immediately after opening. No error messages, the program just disappears. I've replicated the issue (so far) on four separate systems with very different hardware configurations.

    I've tried the usual recommended steps to solve the problem with no success. So far I've tried:
    On command line -
    dism.exe /online /cleanup-image /scanhealth
    dism.exe /online /cleanup-image /restorehealth
    sfc /scannow

    I've also tried:
    - Deleting the Microsoft Edge folder in %localappdata% and reinstalling edge through powershell
    - Deleting the registry entries under "Computer\HKEY_CURRENT_USER\Software\Classes\Local ---Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wek yb3d8bbwe\Children" (obviously after backing up the registry)
    - Creating a new user profile on the affected machine(s)

    So far, none of these solutions have helped. I'm stumped and my desk is going to have a permanent imprint of my face soon if I don't stop beating my head against it. Any suggestions?
      My ComputerSystem Spec
  2.    19 May 2017 #2
    Join Date : Jun 2014
    UK
    Posts : 1,050
    W10 pro x64 and W8.1 x86

    Firstly, I've no quick fix or answer but I think you need to be asking questions...

    Four different PC's, all with the same issue which apparently followed the latest cumulative update. That's odd for sure. Is the original W10 installation standard, or was it from some custom company tweaked deployment image ? Does Edge crash if you take the PC off line ?

    Perhaps just things to explore, as I say, I've no real answer other than eliminating things and proving things by trial and error. There has to be a common link somewhere between the four setups and how they are deployed.
      My ComputerSystem Spec
  3.    19 May 2017 #3
    Join Date : May 2017
    Posts : 8
    Window 10
    Thread Starter

    Quote Originally Posted by Mooly View Post
    Firstly, I've no quick fix or answer but I think you need to be asking questions...

    Four different PC's, all with the same issue which apparently followed the latest cumulative update. That's odd for sure. Is the original W10 installation standard, or was it from some custom company tweaked deployment image ? Does Edge crash if you take the PC off line ?

    Perhaps just things to explore, as I say, I've no real answer other than eliminating things and proving things by trial and error. There has to be a common link somewhere between the four setups and how they are deployed.
    This is a bone standard windows 10 install. We're a small shop, so there's no deployment images. They either shipped with windows 10 preinstalled from Dell, or were upgraded from Windows 7 (which was also preinstalled by Dell)
    There doesn't seem to be any common thread between these four machines that would cause the problem. I'll try taking a machine offline and see if edge still crashes like you suggested, though.
      My ComputerSystem Spec
  4.    20 May 2017 #4
    Join Date : Apr 2017
    Mountains of Western NC
    Posts : 295
    Win 10 Pro x64 17040 Skippy

    This may be completely unrelated to your issue but I had a very similar problem after installing and using the Intel Driver Update Utility a day after I loaded the 16199 insider update. I did a Restore back to pre Intel download and all was good after that.
      My ComputersSystem Spec
  5.    22 May 2017 #5
    Join Date : May 2017
    Posts : 8
    Window 10
    Thread Starter

    Quote Originally Posted by Fisher Mann View Post
    This may be completely unrelated to your issue but I had a very similar problem after installing and using the Intel Driver Update Utility a day after I loaded the 16199 insider update. I did a Restore back to pre Intel download and all was good after that.
    Interesting. I'll check to see if any of the affected machines are using that utility.
      My ComputerSystem Spec
  6.    01 Jun 2017 #6
    Join Date : May 2017
    Posts : 8
    Window 10
    Thread Starter

    Hello all. Checking back in to see if anyone else has any ideas. I can confirm that the affected machines are not using the Intel Driver Update Utility and that disconnecting the machine from the network does not prevent the issue from occurring.

    Following advice from a thread on another web site, I opened the "Problem Reports" app and found several related to edge. The fault module is ntdll.dll. I also noticed during my testing that the address bar in edge "flashes"; it intermittently stops accepting input. The app crashes after a short amount of time whether I attempt to open a web site or not, it crashed while I was clicking through the settings menu looking for anything I might have missed.
      My ComputerSystem Spec
  7.    02 Jun 2017 #7
    Join Date : Jun 2014
    UK
    Posts : 1,050
    W10 pro x64 and W8.1 x86

    Very very odd. If you are not connected to a network and Edge still crashes on all four machines then the only thing I can think of is that the update was in some way corrupted. W10 has the ability to obtain updates from other PC's on a network (if you have that setting enabled).

    Four different PC's all with the same issue... have you tried uninstalling the update ?

    (this is where system image backups come into there own, if you have one then you can recover back prior to this and try the update afresh)
      My ComputerSystem Spec
  8.    02 Jun 2017 #8
    Join Date : May 2017
    Posts : 8
    Window 10
    Thread Starter

    We have not tried uninstalling the update, but might be worth a shot. I'm pretty sure we have the "Updates from more than one place" setting disabled company wide (it is on my machine, at least.) but I'd have to check to be sure. Another disadvantage of not using system images, unfortunately. I'll convince my boss to use them at some point!
      My ComputerSystem Spec
  9.    02 Jun 2017 #9
    Join Date : May 2017
    Posts : 8
    Window 10
    Thread Starter

    Update : Rolling back the update appears to have worked for one machine, at least. I'm re-applying the update to see if the issue occurs again. My boss is adamant that we have this update because it's supposed to protect against the recent WannaCry attack.
    *edit* Did not work on the other machine I've tested so far, though. Back to the drawing board...
    Last edited by disposablintern; 02 Jun 2017 at 11:48.
      My ComputerSystem Spec
  10.    02 Jun 2017 #10
    Join Date : Jun 2014
    UK
    Posts : 1,050
    W10 pro x64 and W8.1 x86

    Hmmm... very strange (as I keep saying). You will have to have words with your boss
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Browsers & Email Change Startup Page in Microsoft Edge
How to Change Microsoft Edge Startup Page in Windows 10 Microsoft Edge is a new web browser that is available across the Windows 10 device family. It is designed for Windows 10 to be faster, safer, and compatible with the modern Web. The...
Tutorials
Microsoft Edge recent jump list corrupted?
Hi. I have a problem with Edge recent jump list. It's not working correctly. See attachment. Is anybody else having this problem and does anyone know how I can fix this? Thanks.
Browsers and Email
Microsoft Edge Startup Page Profile Picture
Hi, The upper right profile picture on the default Startup Page of Microsoft Edge doesn't update. It keeps displaying the first profile picture I used when I installed Windows 10. Maybe it's a detail for most of the people but being a...
Browsers and Email
Help cant bridge connection after recent windows 10 recent update
it saids is ethernet unidentified network? no internet access sharing option is off. i try restarting the pc:( it use to work fine until the update bridging network cable
Network and Sharing
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:25.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums