Chrome browser not working with W10 Creators update...


  1. Posts : 114
    Windows 10
       #1

    Chrome browser not working with W10 Creators update...


    ...the browser just hangs on opening. Chrome latest version. Anybody else having problems?
      My Computer


  2. Posts : 14
    Win 10 Home
       #2

    Chrome works the best for me of the different browsers i use with Win 10 Creators update.
      My Computer

  3. cbwilsha's Avatar
    Posts : 289
    Windows 10 Home
       #3

    rafikiphoto said:
    ...the browser just hangs on opening. Chrome latest version. Anybody else having problems?
    I had that problem and spent several hours trying to fix. Finally solved by turning off hardware acceleration in Chrome Settings. Of course, Settings doesn't open either so you have to boot in Safe Mode, go to Chrome Settings there and uncheck the box under Advanced Settings that says use hardware acceleration and then Restart.

    At least that worked for me. I hope it does for you also.

    C.B.
      My Computer


  4. Posts : 114
    Windows 10
    Thread Starter
       #4

    insulator17 said:
    Chrome works the best for me of the different browsers i use with Win 10 Creators update.
    Bully for you. Doesn't help me in any way though!
      My Computer


  5. Posts : 114
    Windows 10
    Thread Starter
       #5

    cbwilsha said:
    I had that problem and spent several hours trying to fix. Finally solved by turning off hardware acceleration in Chrome Settings. Of course, Settings doesn't open either so you have to boot in Safe Mode, go to Chrome Settings there and uncheck the box under Advanced Settings that says use hardware acceleration and then Restart.

    At least that worked for me. I hope it does for you also.

    C.B.
    Thanks for your helpful reply. I'll give that a go.
      My Computer


  6. Posts : 114
    Windows 10
    Thread Starter
       #6

    cbwilsha said:
    I had that problem and spent several hours trying to fix. Finally solved by turning off hardware acceleration in Chrome Settings. Of course, Settings doesn't open either so you have to boot in Safe Mode, go to Chrome Settings there and uncheck the box under Advanced Settings that says use hardware acceleration and then Restart.

    At least that worked for me. I hope it does for you also.

    C.B.
    Spot on! That did the trick for me too. Many thanks.
      My Computer

  7. cbwilsha's Avatar
    Posts : 289
    Windows 10 Home
       #7

    That's great news!! Thanks for letting me know it worked for you also.

    C.B.
      My Computer


  8. Posts : 114
    Windows 10
    Thread Starter
       #8

    cbwilsha said:
    That's great news!! Thanks for letting me know it worked for you also.

    C.B.
    The most difficult job in the current W10 is finding how to get to Safe Mode!
      My Computer

  9. Caledon Ken's Avatar
    Posts : 25,176
    Windows 10 Pro x64 Version 21H1
       #9

    If you want to get to safe mode, hold the shift key down, click restart.

    There are some menus to pass through.

    https://www.tenforums.com/tutorials/...dows-10-a.html

    Ken
      My Computer


  10. Posts : 114
    Windows 10
    Thread Starter
       #10

    Thanks, Ken. Yes, I Googled it and got there eventually. It used to be much simpler in years gone by.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:33.
Find Us




Windows 10 Forums