Windows 10: Page loading seems to be getting worse on all platforms...

  1.    04 Jul 2015 #1

    Page loading seems to be getting worse on all platforms...


    Hi All,

    Is this just me or is this getting to be a real PITA?

    Over the past two years (I've been using the web for a many years) I've been noticing increasing difficulty in getting pages to load quickly and without lockups/hangs. This is happening very frequently for many different types of sites. I've been using Chrome and IE (11) on Win 7 and the default browser on my Android phone (Note III) and seeing the same symptoms. Frequent hangs, requiring restarts, are the norm. I've tried cache clears, temp file clears, etc. to no avail.

    This is getting so frustrating. I just installed Win 10 (10162) on my laptop (above paragraph is with a high-powered work station and my phone) and both browsers behave in this manner. Some sites, CNN, and other sites heavily laden with adverts, are almost unusable.

    Are these just my experiences or are you folks seeing the exact same thing? If so, how are you mitigating the freezes/hangs?

    Thanks,
    Alan

    P.S. I have a high-speed connection, testing at 30+ Mbps download.
      My ComputerSystem Spec

  2.    05 Jul 2015 #2

    In general, most websites load much more than just their contents, a.k.a. external links or iframes, ads, etc. Some of these ads may not been put together well, slow to load, etc., and as such, you have pages that takes forever to load like CNN. This forum is a OK from that perspective and should load quickly with any browsers. If not, you may have a number of PUPs installed on your system that slows the browser down.
      My ComputerSystem Spec

  3.    05 Jul 2015 #3

    Ah.. sorry but I'm not noticing this one bit.
      My ComputerSystem Spec

  4.    05 Jul 2015 #4

    BunnyJ said: View Post
    Ah.. sorry but I'm not noticing this one bit.
    Neither do I, other than a slideshow at USA Today site, but...

    PUPs, ads, etc., can slow down browser experience to a crawl on some people's systems.
      My ComputerSystem Spec

  5.    10 Jul 2015 #5

    BunnyJ said: View Post
    Ah.. sorry but I'm not noticing this one bit.
    Is this sarcastic humor? :-)

    Well, maybe it's my browsers then. I've disabled all add-ons except flash. Any other suggestions on how to improve the response?

    I get frequent lock-ups and they're getting annoying. I've cleared my cache and temp files to no avail.
      My ComputerSystem Spec

  6.    16 Jul 2015 #6

    achristo said: View Post
    Is this sarcastic humor? :-)

    Well, maybe it's my browsers then. I've disabled all add-ons except flash. Any other suggestions on how to improve the response?

    I get frequent lock-ups and they're getting annoying. I've cleared my cache and temp files to no avail.
    Have you checked your DNS settings in both router and explorer? I recently had a problem and found that the old IPV4 is no longer used with newer browsers, I changed my router DNS to both activated and with a fixed DNS at open dns , a real improvement.
      My ComputerSystem Spec


 

Related Threads
Read more: Microsoft has begun pre-loading Windows 10 And - Woke Up and Found Win10 Upgrade already Download - Windows 10 Forums How to Upgrade to Windows 10 https://www.youtube.com/watch?v=Mnc48BVZqrs
I tried to upgrade my Windows 7 laptop to Windows 10 but after it restarted, it got stuck on the loading screen. http://i1.wp.com/techverse.net/wp-content/uploads/2013/10/how-to-install-windows-8.1_windows-8.1-loading.jpg Please Help!!!
ok when i load some application's it just seems to freeze and do nothing same with text files this link here will show http://i.gyazo.com/6bc50a8f1d755cc0f9084053b6f3a297.mp4 same thing with the iwi as well and i know you can use winrar to...
Windows Update, infinite loading in Windows Updates and Activation
I'm on build 9926 and I have this issue when I open Windows Update, it will just load infinitely. No error codes, no display text, just a loading indicator that lasts forever. I was wondering if anyone here had that problem and if someone knows how...
Windows 10 Loading Screen doesn't continue in Installation and Upgrade
I'm having a trouble of it installing on Oracle VirtualBox, I mount the iso then start. 5573 It should have a loading ring below it (Just like in Windows 8) But it only stays like that like it doesn't do anything at all. I need help :\
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:40.
Find Us